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A detailed review of the data collection, integration and quality control points within the broadband data gathering
and mapping process are discussed in the subsections that follow. In addition, a diagram showing the overall
process can be seen below.
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A more detailed process flow can be supplied, upon request.
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BROADMAP

Beyond The Boundaries

PROVIDER OUTREACH

For the each data submission, an e-mail notification is sent to all providers with supporting deliverable dates.
The providers mainly used the Provider Portal web application to submit changes to and/or validate their
current coverage area(s).

In support of the data collection effort, providers that did not respond timely to the outreach were contacted
by phone.

OUTREACH MATERIALS

The original provider packet sent via e-mail to the providers included the following documents and files:
Letter from the State inviting them to participate in the program;
Copy of the Non-Disclosure Agreement (NDA);
Copy of the Mapping NOFA from the NTIA;
Copy of the NOFA Clarification from the NTIA;
Broadband service address example file in CSV format;
Word document describing service address example file;
Broadband service block example file in CSV format;
Word document describing service block example file;
Broadband service street example file in CSV format;
Word document describing service street example file;
Broadband subscriber example file in CSV format;
Word document describing subscriber example file;
Broadband wireless coverage area sample shapefile;
Word document describing wireless coverage area sample shapefile;
Instructions for downloading, installing and using the WinSCP SFTP application.

OUTREACH PROCESS

The provider outreach process is comprised of the following general steps:

e Send the provider package and introduction letter to the main point of contact for the provider.

e  Follow up with e-mail and telephone to verify that the main point of contact is correct.

e If necessary, discuss the NDA further and resolve any redlines.

e Once the correct primary contact is established, set up a telephone call, if necessary, to learn more
about the provider’s offerings and direct them to the appropriate outreach materials.
If providers are unable to be contacted (non-responsive) or indicate that they are not interested in
participating (non-cooperative), mark them as such on the provider tracking sheet. These providers
will be escalated to the State for further action.
As the providers are collecting the required data, provide instructions on downloading, installing and
using the WinSCP SFTP application, if required.
Arrange with the providers to transfer the data in whatever way they are comfortable: some
providers will find regular email acceptable; others will want to use the SFTP application.
After data is received and reviewed, it may be necessary to contact a provider for clarification or to
address incomplete datasets. In the interest of building and maintaining relationships, care is given
not to push the provider but to work with it to obtain accurate data in the best possible format.

Version 5.0 December 2013 Author: Renee Judkins
Page 5




BROADMAP

Beyond The Boundaries

DATA COLLECTION

DATA TRANSFER PROCEDURES

There are three primary ways data is collected from providers. These are:
e Secure FTP (SFTP) using the WinSCP application;

e  Regular e-mail;

e Mail.

INITIAL DATA REVIEW AND QUALITY ASSURANCE

The initial data review and quality assurance process consists of the following general steps:
1) Access the data from the SFTP site or e-mail.
a. If e-mailed, place copy of original dataset in the appropriate provider folder on the SFTP site.
2) Place copy of raw data on local computer in a working directory.
3) Review data and determine course of action based on type of data received.
4) Ensure data is complete and contact provider to address any gaps.

NOTE:
The goal is to get as many providers as possible to provide subscriber address data in the correct format.
Obviously, this will not be possible with all providers so we will continue to have to process various types of
provider-supplied data.

DATA INGESTION

DATA INGESTION OVERVIEW

The following subsections outline the process steps taken based on the type of input supplied by the data
provider:

e  Point Data:
o Subscriber location;
o DSLAM location;
o Central Office location;
o Broadcast Tower location.
Linear Data:
o TIGER® street segments.

Polygonal Data:

o Census Blocks;

o Coverage Area.
Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to
append to the bb_cov feature class. The bb_cov feature class is the interim dataset that is then processed
using the makeDeliverable.py Python script to create the MapConnect™ data layers that will be delivered
to the State and, ultimately, to the NTIA. Detailed instructions used in this process can be found in the
subsections below.
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BROADMAP

Beyond The Boundaries

POINT DATA

SUBSCRIBER LOCATION—ADDRESS DATA

In the event that the data provider supplies subscriber address data, the steps are as follows:
1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data
format.

a. Usually, this has the following columns: street address (number, pre-directional, pre-
modifier, street name, street type, post-directional and post-modifier concatenated), city,
state, ZIP.

2) Configure the ArcGIS® geocoding tool to use the TIGER® 2010 streets dataset.

a. In ArcCatalog®, create a new Address Locater by right-clicking in the white space of the
appropriate directory and selecting New>Address Locater from the dropdown menu.

b. Select US Streets with Zone and click OK.

NOTE:
It is likely that multiple Address Locators will have to be set up to handle the variety of provider address data
received.

c. Navigate to the TIGER Streets 2010 file and click OK.
d. Fillin the dialog box, as shown below:

New US Streets with Zone Address Locator

Name: [ CO_Geocode_TIGER _2009] Input Address Fields

The field containing: is recognized if it is named:

Description: | US Streets with Zone

Frimary table ] Zone Addr
Street

Reference data:
| Ci\Working'\Broadband \BaseData \TIGER_Streets.shp =

[v Store relative path names

Fields

House From Left: |LFROMADD Matching Cptions

Place Mame Alias Table. ..

House To Left: |LTO.-'-\DD

House From Right: |RFROMADD Spelling sensitivity:

House To Right: |RTOADD Minimum candidate score:

_— Minimum match score:
Prefix Direction: |<N0ne> =

Prefix Type: | “Mone= Intersections

Connectors: &| @ Separate connectors by a

Street Name: |FULLNAME space, e.g. & @,

Street Type: | <None> Output Options

Suffix Direction: | <Mone>

Left Zone: |21p|_

Side offset:

End offset:
IV Match if candidates tie

Led Lef Lef Lo L] Laf Lol Lo Lef Lo Lo

Right Zone: |ZIPR

Qutput Fields

[~ ¥ and Y coordinates I™ Standardized address
[ Reference data ID [~ Percent along

Advanced. ..
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e. Click OK.
3) Open ArcMap® and add the Excel spreadsheet with the address information.

4) Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.
5) Select the appropriate address locator by clicking Add..., then OK.

-

. Choose an Address Locator to use...

| Description
e CO_Geocode_TIGER_2009 LIS Streets with Zone

Cancel
6) Fill out the Geocode Addresses dialog box, as shown below:

r

= al
Geocode Addresses: CO_Geocode_TIGER_2009 PIx
Address table:
|Fibers | ﬂ
Address Input Fields

Street or Intersection:  |F| apDR -
Zone: 7IP_CODE -

Qutput

% Create static snapshot of table inside new feature dass
-~

Output shapefile or feature dass:

Advanced Geometry Options. .. |

Geocoding Options. ..
Help

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all
the default parameters.

8) Review results. See example below.
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-
% Interactive Rematch - glenwood_try1

Shaw results: |A\IAddrasses j Manage result sets. .. ‘ Refresh Rematch Automatically

W Matched: 97 (88%)

| | shape | Status | Score | Match_type | Side | A | B e s (5%)
» 0] Point 201 CENTENNIAL DR, 81801
Point 201 CENTENNIAL DR, 81601 B Unmatched: 8 (7%)
Point 201 CENTENNIAL DR, 81601
Point 210 CENTER DR, 81601 _
Point 15 MARKET DR, 81601
Point 40 MARKET DR, 81601
Point
Point
Paint
Paint
10 |Point
11/ Paint
12| Paint

58627 SOCCER FIELD RD, 81801
125 STORM KING RD, 81601
52800 TWQ RWERS PLAZA RD, 81601

@ | @|o e el

)

40 MARKET DR, 81601
2698 GILSTRAP CT, 81601

Record: ﬂj 1 jﬂ Records (of 110)

Address: 1 Candidate Candidate details:
Strest or Intersection [201 CENTENNIA. ES(an | Side_| Match_addr | LeftFrom [ LeftTo | RightFrom | RightTa o 01 | 0

Jone W 1 L 201 CENTENNIAL DR, 81601 201 299 200 298 To ,W W
PreDir [
PreType ,7
Streetilame [ CENTENNIAL
StreetType ,T
s [
Zone ,m ’m
Score

Side

Match_addr 201 CENTENNIAL C

R A ID B SID D D AR ib SIb I o)

@ e
@2

Standardized Address:
201 | | CENTENNIAL | ST | | 81601 < >

Geocoding Options... | Zoom to Candidates | ﬁ Pick Address from Map | Search | Unmatch |

9) Adjust geocoding parameters accordingly and repeat batch to resolve issues.
10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.
11) Visually inspect the data, as shown below:

r

% provider_data_QAQC.mxd - ArcMap - Arcinfo

file Edit View Bookmarks Insert Selection Tools CH2M Window Help

DEdSE BX o« (Bt ]| & @ O K? | b r
Georeferencing ¥ = - ArcPad DataManager ~ <21 5% 58 & [
3D Analyst =

x

Geocoding Result: glenwood_try1
.

[0 TIGER Streets

COUNTIES
[}

[}

BB_ConnectionPoint_MiddleMie

-
HIGHWAYS

i3]

BTG OS

i3]

FCROADS

]

BB_Service_Road_Segment

CITIES

&

@

B_Service_CensusBlock

1]

BB_Service_Overview

[l - 4

]

BB_Service_Wireless

municomm_coverage_area

5}

OoOooao
£

wired_coverage_sample_wgs84

]

M}Souj} Selection 20| & m ﬂ J
Drawing > R O~ A~ @) Arial ~||t ~| B r o -

-107.326 39.557 Decimal Degrees

12) Follow the steps detailed in Subscriber Location—GIS Data below.
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BROADMAP

Beyond The Boundaries

SUBSCRIBER LOCATION—XY DATA

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and
longitude, the steps are as follows:

1) Refine the format in Excel so that the data can be opened easily using ArcMap®.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and
make certain there are no merged cells.

Make certain that XY locations are in decimal degrees.

(i.) To convert from degrees, minutes, seconds (392 26’ 45.67”) to decimal degrees, use the
following formula: DD + (MM/60) + (SS5.555/3600).

b.

NOTE:

If XY locations from some other coordinate system are provided, you can use those in the process below but
you must know what the coordinate system is.

2) Open the Excel worksheet in ArcMap®.
3) From the menu bar, select Tools>Add XY Data...

Add XY Data

Atable containing X and Y coordinate data can be added to the
map as a layer

Choose a table from the map or browse for another table:

| ForImports ﬂ g

Specify the fields for the X and Y coordinates:

¥ Field: |LONG

=l
Y Field: ||_,'.\T j

Coordinate System of Input Coordinates

Description:

Geoaraphic Coordinate System:
Name: GCS_WIGS_1984

[ Show Details

v Wam me if the resulting layer will have restricted functionality

oK | Cancel |

Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate
system and click OK.

Results are an event layer, not a true spatial layer. Export the data by right-clicking the event
layer and selecting Data>Export Data... from the dropdown menu.

Follow the steps detailed in Subscriber Location—GIS Data below.
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SUBSCRIBER LOCATION—GIS DATA

If the provider supplies subscriber location in GIS format, the data will then be overlayed with census
blocks and it will be ready for processing.
1) First, run a spatial join with your TIGER census blocks layer as the target, and your point features
as the joining features, and then dissolve into separate county feature classes.
a. Within ArcGIS®:
(i.) Use the Spatial Join analysis command in ArcToolbox®, run an intersect using
JOIN_ONE_TO_MANY to retain all of your speeds

A
“\ Spatial Join

Target Features

| Basemnap\ TIGER2010_CBlock_WGS84_FL | @
Join Features

I Geocoding_ResultFINAL ;I @

Qutput Feature Class
N:\State\FL\BBProvider\Level 30414\ evel3_Final.shp

Join Operation (optional)
OIN_OME_TO _MANY|

Keep Al Target Features {optional)

Field Map of Join Features {optional)

- STATEFP10 (Text)
COUNTYFP10 (Text)
TRACTCE10 (Text)

[« B [x] &

[ Shape_Length (Double)

Match Option (optional)
INTERSECT

Search Radius {optional)

[ 0K J [ Cancel ] [Environments... ] [ <« Hide Help

Click OK.

This will create a full census block layer, but we will only need the records that are
populated from our points.

INTPTLAT10 | INTPTLON10 | SqMi| Loc_name | Status | Score | Match_type | Match_addr | Side | User_fid | Addr_type
+29 6561425 -082.3326004 | <Mulk= | <Nul= <Mull= <Null= | <Null= =Mull= <Null= | <Null= =Mul=
+29 6553576 -082.3344891 | <MNull= | <Nul= <Mull= <Null= | <Null= =Mull= <Null= | <Null= =Mul=
+29.6553616 -082.3334433 | <Mull= | <Nul= <Mull= <Null= | <Null= =Mull= <Null= | <Null= =Mul=
+29.6543061 | 0823325667 _| <Nulla| b <O | <NUI | <NUI> =Mul= o <Null=
+29.6531668 m <Null= | <Nul= =Null= | <Null= | <Null> <Nul= <Null= | <Null> <NOTE
+29.6511372 -082.3288155 | <Null= |l 2013_12_ | M 100 | A 400 SW 2Znd Av | R o StreetAddress,
+29.6496315 \0&3299438 =Null= | <Nul= <Mull> =Null> | <Null= =Mull= <Mull> | <Mull= =Mul= 4
+2§.6486650 | -082.33T000% = | <Null= <Null= [ <Null= | <Null= <Null= <Null= | <Null=__Ltet=™
+20.6125674 -082.3921586 | <MNull= | <Nul= < L etk o <Hull= | <Nulk= <Nulk=
+29.6591527 -082.4231817 | =Mull= | <Null= <Null= <Null= | <Null= <Mull= <Mull= | <MNull= =Mull=
+20.5863369 -082.3571521 | =Mull= | <Null= <Null= <Null= | <Null= <Mull= <Mull= | <MNull= =Mull=
+28.6380905 -082.3932620 |<Mult= | <Mul= <Null= =Null> | <Null= <Mull> <Mull> | <Null= <Mull>
+20 6465405 -082.3872885 | <Mult= | <Mull= <Null= =Null> | <Null= <Mull> <Mull> | <Null= <Mull>
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(ii.) From here, perform a select by attributes command to remove all “<Null>”
values

F B
Select By Attributes e =5

Layer: [€ Level3_Final |
[7] Onty show selectable layers in this list
Method: [Create a new selection

"Zp"
"Technology"
"MAXADDOWN"
"MAXADUP"
"TYPDOWN"

=) &) ()
08 (o) ()

SELECT * FROM Level3_Final WHERE:
"MAXADDOWN" <= MULL

=

A —

Click OK.

Right-click on your layer in the Table of Contents and choose Selection>Create
Layer From Selected Features. You will now work from your selection layer in
the table of contents.

2) Now you will create a new layer with only the information needed for your final result. Select Data
Management Tools>Generalization>Dissolve in ArcToolbox® and dissolve your selection layer based on
County/Provider/TT/Speed Tier so that unique records are created for each unique combination

a.

There may be repeated census blocks with different speeds reported from multiple points
lying with the block. As we only want the highest speeds available in each block, instead of
checking them in the dissolve, we will add them into the statistics field and ask for the max.
This will create fields with only the maximum speeds for each dissolved block
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‘{% Dissolve

Input Features

I Level3_Final selection

Output Feature Class
M:\state\FL\BBProvider \Level 3\0414'Level3.shp

Dissolve_Field(s) (optional)
[ oBIECTID

D Join_Count

[T] TARGET_FID

[ 10mv_FID
STATEFP10
COUNTYFP 10

[] TRACTCE1D

7] BLOCKCE1D

7] GEQID 10
1| 1

| selectal || Unselectal Add Field
Statistics Field(s) (optional)

Field Statistic Type

MAXADDOWN MAX
MAXADUP MAX
TYPDOWN MAX
TYPUP MAX

CIIEIEIE

{1 | 3 =

0K l [ Cancel l [Environments... l | Show Help == |

You will need to create one State County Fips field for appending into your
bb_covs. Select the dropdown for your Attribute table Options and choose Add
Field. Make this text and use a unique name.

.
Add Field (o]

Name: STCTY_FIPS|

Type: [T

Field Properties
[Length

[ ok [ cancal |

You will then field calculate this layer to be a combination of your State &
County fields.
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-
Field Calculator

Parser
(@) VB Script

Fields: = Functions:

FID T Abs ({ ))
= Atn
Shape cos ()
STATEFP10 Exp ()
COUNTYFP10 ® Fix ()
MAX_MAXADD {';tg(( ))
MAYX_MAXADU Sn()
MAX_TYPDOW Sar ()
MAX_TYPUP Tan ()

TRAMNS_TECH

[ show Codeblock =) (=]

STCTY_FIPS =
[STATEFP10] & [COUNTYFP10] B

About calculating fields [ Clear ] [ Load... ] [ Save... ]

Click OK.

3) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class created above into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.

Click the Add button, the click Next.

rSimple Data Loader g‘
Enter the source data that you will be loading from. Click Add to add it to

the list of source data to be loaded. You can load from muitiple data sets in
the same operation if they share the same schema.

Input data

List of source data to load
N:\State\FL\BEProvider Level3\0414\ evel3.shp

| Next> [ cancel

Load your matching fields and click Next.
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field

SPECTRUM [short int] <None=

MAXADDOWN [string] MAX_MAXADD [double]
MAXADUP [string] MAX_MAXADU [double]
TYPICOOWN [string] MAX_TYPDOW [double]
TYPICUP [string] MAX_TYPUP [double]
MD_GEOM [string] <None=

MD_EXISTS [string] =Nones=

MD_WHO [string] <Nonex=

MD_WHEN [DATE] <None=

MD PROCESS [string] <None>=

< Back ][ Mext = ][ Cancel

d. Fillin FRN, Provider Name, DBA Name, and other necessary fields in bb_cov

DSLAM OR CENTRAL OFFICE LOCATION—ADDRESS DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office address data, the steps are as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

DSLAM OR CENTRAL OFFICE LOCATION—XY DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office XY data, the steps are as follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

DSLAM OR CENTRAL OFFICE LOCATION—GIS DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office GIS data, the steps are as follows:
1) Buffer the DSLAM/Central Office points feature class.
a. Add the point feature class to ArcMap®.
Open the ArcToolbox® and go to Analysis Tools>Proximity>Buffer.
Set the buffer distance to 5 miles.
Set the dissolve type to ALL.
Name the output feature class.
Typical Buffer tool is shown below:
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Input Features

L]

& o

| Columbine
Qutput Feature Class
| C:\Working'Broadband\ProviderData'\Columbine \Columbine_Buffer _2.shp

Distance [value or field]
(* Linear unit

" Field

Side Type (optional)

L

End Type (optional)

4

(KN R R

Dissolve Type (optional)

Dissolve Field(s) (optional)
Orm
Ocompany
Ooea
Orrn

O ExcHANGE
Ostate
OrrovIDER
Ocu_cooe
MecorT

£

B

g. Click OK.

Use the resulting buffer feature class to clip the TIGER® street layer:
a. Add TIGER® street layer to ArcMap®.

b. Open the ArcToolbox® and go to Analysis Tools>Extract>Clip.
c. Complete the dialog box as shown below:

Input Features

| TIGER_Streets

Clip Features

| Columbine_Buffer

Output Feature Class

| C:YWorking'Broadband\ProviderData\Columbine\columbine_TIGER._dip.shp
XY Tolerance (optional)

| Meters

Cancel | Environments...| Show Help == |

d. Click OK.
3) Using ArcCatalog® and within the file geodatabase:
a. Right-click and create a new Feature Dataset.
(i.) For the Feature Dataset settings:
(1) Name the feature dataset accordingly.
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(2) Select horizontal coordinate system by importing the coordinate system associated
with the clipped TIGER® street layer by selecting Import and navigating to the
location of that feature class.

(3) No vertical coordinate system needed.

(4) Leave all x,y,z,m values at default.

(5) Click Finish.

4) Import previously created street feature class into new Feature Dataset.
5) Right-click Feature Dataset and create new Network Dataset—accept all default setting for the
Network Dataset.

NOTE:
The Network Analyst extension must be turned on.

6) In ArcMap® turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst.
7) Add the Network Dataset created in Step 5 to ArcMap.
8) Using the Network Analyst Toolbar dropdown, create New Service Area.

9) Open the Network Analyst Window by selecting the E button. See below.

|Service Area j
Facilil:iﬁ (1))
Polygons (0)
Lines (D)
Barriers (0)

10) Right-click Facilities layer, select Load Locations and navigate to the DSLAM/Central Office
facilities feature class.
a. You can select afield in the layer you are loading to attribute the new ‘Breaks_Length’
field. This will replace what you enter in the default_breaks box of the service area
properties if you plan on having different distance polygons from your facility.
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-
Load Locations

Load From: El columbine_points
¥ Orly show peint layers

-
Sort Field: |

Location Analysis Properties

Property Field Default value

Name
CurbApproach Either side of vehicle
1]

Attr_Length
Breaks_Length

Location Position

* |se Geometry

Search Tolerance: ‘ 5000

(™ Use Network Location Fields

Property
SourcelD
Source0ID
PosAlong
SideOfEdge

Advanced...

11) Click OK.

12) Click the Service Area Properties button .
13) For the following tabs, change the following properties:
a. Polygon Generation tab:
(i.) Select Merge by break value to prevent overlapping polygons or separation around
close facilities.
(ii.) Also disable the Trim Polygons option only if you want to prevent the output from
buffering close to your line layer around edges. If you use the Detailed option, you must turn
off the ‘Use Hierarchy’ option on the Analysis Settings tab.
Analysis Settings tab—using and converting the specified DSLAM buffer distance from feet
to meters—input buffer distance value in meters into the Default Breaks location (this will
only be used on features that have a <null> value for ‘Breaks_Length’).
(i.) Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used
as the buffer distance. See below.
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[

Layer Properties

Line Generation ] Accumulation ] Netwark Locations
General ] Layers ] Source Analysis Settings ] Polygon Generation

Settings Restrictions

Impedance: |Lengih {Meters) j
Default Breaks: 5486

Direction
" Away From Facility
" Towards Facility

Allow U-Tums: Everywhere >

¥ lgrore Invalid Locations

If you plan on having rings of distance around every facility, keep your
‘Breaks_Length’ field null and then enter each distance into the Default Breaks text

box, separated by a space. Example would be 10,000, 15,000, then 18,000 feet. See
Below.

Settings Restrictions

Impedance: Length (Meters) [] aveid Limited Access Roads
] Aveid Toll Roads

Default Breaks: 3048 4572 5486 [¥] Aveid Unpaved Roads
Onewa\;

[ use Time:

c. Click OK.

14) On the Network Analyst Toolbar, click the Solve button % to create service area polygons.
15) Right-click on the created service area polygon in the layer list, and select Data>Export Data from
the dropdown list.
16) Export to a feature class in the file geodatabase you created earlier.
17) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created in Step 16 into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
|Prc|\.rName [ztring] =Nonex
DBAName [string] <None=
FRNM [inf] <None=
| GeogUnit [string] <None=
_| GeogUnitiD [string] <None=>
| TransTech [ghort int] =None>
| MaxAdvDown [zhort inf] <Hone=
| MaxAdvUp [zhort int] <None=>
ARPU [float] =Nonex
SWNomSpeed [floafl =None=

e. Click Next, then Next again, then Finish.
18) In ArcToolbox®, go to Data Management Tools>General>Append.
19) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

Target Dataset

| C:\Working'\Broadband\ProviderData\Columbing\Columbine . gdb\bb_cov
Schema Type (optional)

Field Map {optional)

| .
QK | Cancel Environments... | Show Help == |

20) Leave the Schema Type as TEST.
21) Click OK.
22) In ArcMap®, open bb_cov for editing and manually input associated attribution.
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BROADCAST TOWER LOCATION—ADDRESS DATA

In the event that the provider supplies wireless broadcast tower location address data, the steps are
as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

BROADCAST TOWER LOCATION—XY DATA

In the event that the provider supplies wireless broadcast tower location XY data, the steps are as
follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.
2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

BROADCAST TOWER LOCATION—GIS DATA

In the event that the provider supplies wireless broadcast tower location GIS data, the steps are as
follows:
1) Download the required software (Radio Mobile) from the website:
http://www.cplus.org/rmw/english1.html
Install the software according to the standard directions, found here:
http://www.cplus.org/rmw/download/download.php?S=1
Open the application.
Load the broadcast tower location and elevation information by selecting File>Unit properties.
The following dialog box appears:

?‘! Units properties

~ MHame Elervation [m)

o

Pl

Althea
Athena [thes ] 2683

Caribiou
Chipeta
Frankling

Hori £ A0°04'26.6"N 105°30'33.1"
arZon-|
Horizon ! Copy DN7OFB Paste

Pozition

Littleraven

M atzanala-H
M anzanala-y
Moonstane Enter L&T LOM or DR Mave up
Firata
Tenapin Move down
E:Jti?ggo Place unit at cursor pogition

W apiti Export

™ Locked

Place cursor at unit position Impart

Style Sart

¥ Enabled " Left * Centre " Right

[ Transparent
I~ Molabel BackCalor ForeColor

Apply styule

i

¥ Small fant

lcon 16x1E pikels

i Ol [+

[™ Show only urits that are members of a visible network,

e

5) Add the information for all the towers supplied by the WISP data provider, including the
elevation. If provider does not supply elevation, this information can be obtained from Google
Earth.

a. If available, use the Import button to import a Google Earth KML of the tower locations.

Go to the National Map Seamless Server (http://seamless.usgs.gov/) and download elevation

data sufficient to contain the tower locations.

a. At least the 1/3” NED data is needed. Select this by clicking the Download button in the
upper right of the website and checking the box next to 1/3“ NED.
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b. Zoom to the area of interest and use the Download tools to define the area to download:

| |y
/=

c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI
GRID, as shown below:

L - - -
) The National Map Seamless Request Summary Page - Mozilla Firefox g@gl

http: /fextract.cr.usgs. gov/Website/distreq/RequestSummary. jsp?PR =0&CU =Native 87X =-1.082Y =-1,08ML=C 7.7

The National Map Seamless Server

Request Summary Page
‘You are logged in as Default Seamless User.

Modify Data Request HELP!

Data Exiraction Request Pieces:
Output Parameters Size (MB) || Download Links
National Elevation Dataset (NED) 1/3 Arc Second

&ZUSGS
-~
-

EROS Data Center

@ # M 4orr.frank@gmai.com

d. Download the data and unzip it.
7) Select File>Map Properties to define the map.
8) Enter a latitude and longitude in the center of the tower locations.
9) Set the size (in pixels) and the size (in kilometers) of the map.
10) Set the directory path leading to the BIL elevation data just downloaded.
11) The dialog box is shown below:
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[‘1: Properties of ..\default.map

— Centre — Size [pixel]
40°0328.8'N 10572927 6™/ Width{pixels) LTl e, Extract

DNTOGE [1000 [1000

Latitude Longitude

4 |.1 05.491  Size [km) Cancel

“Width{km] Height (k]
[100.00 [100.00 Top Left
40°3029°N
1050444/

|Jse cursor position

 Elervation data source
Drive or path Top layer Top Right

‘wiorld map |
Select a city name | IBIL LI Ic:'\geodata\bil\boulder Browse... | AD°3023"N

10475477 %/

Enter LAT LON o GRA [Wene  ~] | Browse... | Battam Left
39°3629"M
hd B T0E 0444
ISeIe-:t a unit j INc-ne —I I [OWs8 |
Bottom Right
INc-ne LI | Browse... | I IETTN
10475417
INc-ne LI I Browse... |
. Resolution
I™ Merge pictures [ Ignore missing files Battam layer | oo mepixel
[ Force giay scale Initisize matrix with elevation (m) [0 3.24 arcsecond

[ Adjust units elevation

12) Click Extract.
13) The elevation data is rendered as a hill shade, as shown below:

' ..\default.net - Radio Mobile - [..\default.tif]
[ Fle Edt View Tools Options Window Help &

CEORA 6QAC- IDE

|

[40°05'34"N 105°17'13™W X=673 Y=461 1724.1m

14) Select File>Network properties from the main menu.
15) Create a new network and enter in the frequency range under the Parameters tab, as shown
below:
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£ Networks properties

List of all rets

Default parameters Copy Met ‘
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| Cancel ‘ ak.

Mednet
Jade
Oluray
COkobile

Parameters ‘ Topology ‘ kM emberzhip | Systems ‘

Style

Met name

|Nedemet

Minirmurm frequency [MHz] | 2400
td aximum frequency [MHz] (2400

Puolarization

+ ‘ertical " Haorizontal

Maode of variability
* Spot

" Accidental
" Makbile

% of time
% of locations
% of situations |70

" Broadcast

Surface refractivity [M-Units) W

Ground conductivity [5/)
rourd conductivity [54m) 0005

Relative ground permittivity ,—
15

Clirnate

E quatarial
Continental sub-tropical

M aritime sub-tropical

Continental temperate

Maritime temperate over land

~
~
~
" Desert
o
~
~

Maritime temperate over sea

16) Leave all the other values as they appear, and select the Systems tab.

17) Create enough systems to cover all the varieties of equipment in the provider network. This will

include the antenna type, height and line loss, as shown below:

Systerm 11
Systern 12
Syztem 13
Syztem 14
System 15
System 16
System 17
System 18
System 19
System 20
System 21
System 22
System 23
Systern 24
Systern 25

18) Now click on the Membership tab, and assign the individual towers to their respective systems,

Default parameters

Copy Met ‘

| Cancel ‘

Parameters ‘ Topology | temberzhip | Systems ‘

|D'I j |Select from B adiozys01.dat

Syster name | Orri

Transmit power [ att)

Receiver threshaold (W)

Line loss [dB]

Antenna tppe |1
Antenna gain [dEi]
Antenna height [m)

Additional cable lozs [dB/m)

Add to Badiozys01. dat

(dem) |50
(dem) [107

[ Cable+cavities+connectars |
View
(ded) [1285
[ Above ground |
[ If antenna height differs |

Remove from Radiozys01.dat

providing the azimuth for non-omnidirectional antennas, as shown below:
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I8l Networks properties

Default parameters | Copy Met | ‘ Cancel ‘ k.

List of all nets
hedriet ‘

Jade Parameters
COuray
Ok obile

Topology | Membership ‘ Systems ‘ Style

Member of Nedernet
Rale of Athena

| Cormand j

Suyztem
| Chipeta
| Frankling |ED J
v| Horizan-E Antenna height [m)
| Horizon-w'
w| Litleraven
v Manzanala-H
| hanzanalay
v| Moonstone
| Pirata Antenna direction
w| Terrapin
v Tobago |Fi:-:ed (' j

v \-[\:'mh?' Azirnuth 7] Elevation angle [7]
w| W apit |
a0 [

List of all units

{* System

" Qther

Yiew pattern

19) Click OK.

20) Select Tools>Radio Coverage>Combined Cartesian from the main menu.

21) Complete the dialog box as shown below, providing the Maximum Range from the highest tower
beam radius supplied by the provider.

22) Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of
granularity), as shown below:

& Combined cartesian Radio coverage

Fixed uritfz] Mobile unit

[&nhea

v Althea el

v| Athena Antenna pattern
v Caribou

| Chipeta

v| Frankling

| HorizonE

| Horizon-w

v Littleraven [ Save raster data to file [TXT]
v| Marzanala-H [~ Save raster data to file [SIG)

: manza[]a\a-\f [ Save also units not selected Load data
oonstone
| Pirata [~ Draw pattem [ Complete.wa

| Tenapin X [ Sawe cowerage pictures in 'frames" directary
¥ Tobago ity G v Maimum range [km)

v Tutle

Ir network
|Nedsmst

¥ Use network antenna settings o) it

Save settings

Antenna height (m] Link Direction Mode

3 + Mobile Rx & Al picture

£ bobil -
B m Mobile T

Signal range to diaw
te S-Unit [™ Best unit

" dBm

cw %]

" dBpi/m

Draw size [pisels] M| Pl sl

4 I™ Rainbow

23) Set the Signal range to draw to S-Unit and type 5 in the From (>=) box.
24) Click on Draw. See below.
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\default.net - Radio Mobile - [..\default.tif]
[1) Ble Edt View Tools Options Window Help top

CFPRACQACS IHEW & @R ™|

PAR

[40°05'53"N 105*1510"W X=702 Y=455 1627m

25) Save the resulting image as a TIF by selecting File>Save Picture as.
26) Open ArcMap® and load the BIL elevation data you used in Radio Mobile.
27) Load the TIF image you created and georeference it using the corners of the BIL data.
a. The corners of the data can be seen in the TIF image.
28) Follow the georeferencing directions from the Coverage Area—PDF/JPG/Other Image Format
section below.
29) Use the Georeferencing Toolbar to Update the Georeferencing for the TIF dataset.
30) In ArcToolbox®, select Data Transformations>From Raster>Raster to Polygon and input the
georeferenced TIF you just created.
31) Open the resulting polygon feature class for editing using the Editing toolbar in ArcMap® and
clean up as necessary.
32) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created above into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[FrovMame [string] <Nones=
DBAMame [=tring] =Monex
FRM [inf] <None>
GeogUnit [string] <None>
| GeogUnitiD [ztring] =Monex
_| TransTech [ghort int] <None>
| MaxAdvDown [ghort int] <None>
| MaxAdvUp [zhort inf] =Monex
_| ARPU [float] <Nones
SWWNomSpeed [float] <Naone>

< Back | Next = | Cancel

e. Click Next, then Next again, then Finish.
33) In ArcToolbox®, go to Data Management Tools>General>Append.
34) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

CEX

Input Datasets =
| =l =

C:\Working'Broadband\ProviderData'\Columbine \Columbine. gdb\service _area_bb. .. +

Target Dataset
| C:\working\Broadband'\ProviderData\Columbine\Columbine. gdb\bb_cov

Schema Type {optional)
L=
Field Map (optional)

OK | Cancel Environments. .. | Show Help => |

35) Leave the Schema Type as TEST.
36) Click OK.
37) In ArcMap®, open bb_cov for editing and manually input associated attribution.
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LINEAR DATA

TIGER® STREET SEGMENTS—LIST, SPREADSHEET OR GIS DATA

In the event that the provider supplies TIGER® street segments in list or spreadsheet format, the
steps are as follows:
1) Join TIGER® road segments to 2000 census blocks feature class using one of two methods based
on how the data is provided:
a. |If the TIGER® data is provided with a Census Block ID, then join the segments to the Census
Block geometry based on that ID:
(i.) Load both datasets into ArcMap®;
(ii.) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join;
(iii.) In the dialog box, select the TIGER® road segments data and the proper attribute fields
for joining, as shown below:

-
Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

|J0in attributes from a table

1. Choose the field in this layer that the join will be based on:

|BLKIDFPOD =~

2. Choose the table to join to this layer, or load the table from disk:

[ TIGER_Streets [ g

[v Show the attribute tables of layers in this list

3. Choose the field in the table to base the join on:
-

Join Options
+ Keep all records

All records in the target table are shown in the resulting table.
Unmatched records will contain null values for all fields being
appended into the target table from the join table.

" Keep only matching records

If a record in the target table doesn't have a match in the join
table, that record is removed from the resulting target table.

About Joining Data

(iv.) Click OK.

If the data provided is a list containing TLIDs, then join to the TIGER®/Line data using the

TLID, and use a spatial join to associate the TIGER® segment with the coterminous block

based on the block ID:

(i.) Load both datasets into ArcMap®;

(ii.) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join;

(iii.) Select Join data from another layer based on spatial location from the dropdown
menu;

(iv.) Complete the dialog box, as shown below and click OK.
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r
Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

1. Choose the layer to join to this layer, or load spatial data from disk:

[ TIGER Streets | ﬂ

2. You are joining: Lines to Polygons

Select a join feature dass above. You will be given different
options based on geometry types of the source feature dass
and the join feature dass.

{* Each polygon will be given a summary of the numeric
attributes of the lines that intersect it, and a count field
showing how many lines intersect it.

How do you want the attributes to be summarized?
[ Average [~ Minimum [ Standard Deviation
I~ sum [~ Maximum [~ Variance

Each polygon will be given all the attributes of the line that is
dlosest to its boundary, and a distance field showing how
dose the line is (in the units of the target layer).

Note: A line falling inside a polygon is treated as being dosest
to the polygon, (i.e. a distance of 0).

3. The result of the join will be saved into a new layer.
Spedify output shapefile or feature dass for this new layer:

|C:"-.‘."a'orking"-.Broadband"-.Temp"-Join_Output_S.shp

About Joining Data

Export joined records into a temporary feature class.

If joined Census Block geometry is confined to one specific area, then dissolve blocks into one
record. If joined Census Block geometry is distributed throughout a particular State, then dissolve
sub-selections of census blocks for each county.

a. Use the County FIPS code to dissolve by county.

b. In ArcToolbox®, select Data Management Tools>Generalization>Dissolve.

c. Complete the Dissolve dialog box, as shown below:
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v
* Dissolve

Input Features

| blocks_Lm

Qutput Feature Class

| C:\Working\Broadband\BaseData\blocks_LUTM_Dissolve.shp
Dissolve_Field(s) (optional)
OFm

Ostaterraoo
COUNTYFPOD
OmracTceon
OsLockceno
OeLxiorroo
OAnameno

Owmrrccoo

Murnn

h

Select Al | Unselect All
Statistics Field(s) (optional)

Statistic Type

v

oK | Cancel | Environments. .. | Show Help ==

d. Click OK.
For each dissolved region, open the feature class for editing using the Editing tool in ArcMap®
and remove unnecessary slivers and other small holes. For general guidance on editing features
in ArcMap®, see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf
In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created above into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click on the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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"

. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[FrovMame [string] <Nones=
DBAMame [=tring] =Monex
FRM [inf] <None>
GeogUnit [string] <None>
| GeogUnitiD [ztring] =Monex
_| TransTech [ghort int] <None>
| MaxAdvDown [ghort int] <None>
| MaxAdvUp [zhort inf] =Monex
_| ARPU [float] <Nones
SWWNomSpeed [float] <Naone>

< Back | Next = | Cancel

e. Click Next, then Next again, then Finish.
6) In ArcToolbox®, go to Data Management Tools>General>Append.
7) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

CEX

Input Datasets =
| =l =

C:\Working'Broadband\ProviderData'\Columbine \Columbine. gdb\service _area_bb. .. +

Target Dataset

| C:\working\Broadband'\ProviderData\Columbine\Columbine. gdb\bb_cov
Schema Type {optional)

Field Map (optional)

OK | Cancel Environments. .. | Show Help => |

8) Leave the Schema Type as TEST.
9) Click OK.
10) In ArcMap®, open bb_cov for editing and manually input associated attribution if necessary.
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POLYGONAL DATA

COVERAGE AREA—PDF/JPG/OTHER IMAGE FORMAT

In the event that the provider supplies coverage area data in some image format such as PDF or JPG
format, the steps are as follows:
1) Ifin PDF format, open in Adobe Acrobat and Save As... JPG format.
2) Open the JPG image in ArcMap®.
3) Add the required base map vector data for georeferencing.
a. This generally will be either the CDOT data or TIGER® data.
4) Change the coordinate system of the data frame to the desired end coordinate system.
5) Zoom to the general location of the JPG map image.
a. Thisis the location based on the vector data, not the JPG image itself. For example, if you
know that the JPG image represents an area around the town of Limon, zoom to the town of
Limon in your vector data.
Open the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main
menu bar.
Using the Georeferencing toolbar, select Fit to Display; results are shown below:

achudbatavarnge v 1 B B G O
o b ) SRS B GO0 Ba @ 3y

|

S s B 70 A B
503543 4168 DmcoCmgros

8) Use the Control Point button "Z'- to add control points to the map.
9) Use common points in the base dataset and the JPG image.
a. For example, find major street intersections, county/city boundaries, etc.
b. Try to distribute the points more or less in the four corners on the image for the best
transformation.
10) Click on the location on the image first, then click on the corresponding location on the vector
database map, as shown in the image below:
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15 provider_data_processing 2.mxd - ArcMap - Arclnfo
Fle Edit View Bookmarks Insert Selecton Tools CH2M Window Help
== = [} o + freas ] || & @ O T k2 | Edtor v
Georeferending ~ | Layer: |Communicomm_Cov_100809_1_Pz | (}|~||,# & ArcPad DataManager ~ 4 % 8 G O

30 Analyst = @ woospov B N E BrO@EH EB& @ 3 H G

5 ~~ B
- £ Layers ~
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| 1
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= O Columbine .
. o
= O secom_tower _locations

.
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® O nunn_coverage_area

® O WebMap Service BLM_MAP_PLSS
O Nunn Broadband Map w middle mile

# [0 web Map Service BLM_PARCELS_wn

& [ NAIP_UTM13
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.
= O 8ig_Sandy
.
= O Geocoding Result: Geacoding_Resut
.

= [ Dubois_CORT_points
.

= O Nedernet WISP_points
.

= O geocode_streets_Ciip

= O geocode_streets
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o

= & FcrROADS
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= e [
ource | Selection | Catalo; o

@Oy 1
(0] Anal [0l B U A dv Fx +~
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11) After placing each control point, the image transformation will update automatically.
12) Repeat until satisfied with the transformation.

NOTE:
The transformation may take up to four points, although sometimes only two are necessary.

13) When satisfied with the transformation, select Update Georeferencing from the Georeferencing
toolbar dropdown.
a. This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image

file.

14) In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider
coverage area.

15) Add the shapefile to ArcMap®.

16) Using the Editor toolbar, select Start Editing. Set the Task to Create New Feature.

17) Use the Sketch Tool ? Tlto digitize a new coverage polygon using the coverage area outline
from the georeferenced JPG and add the required attributes manually.

18) Repeat the above steps for all subscriber speed coverage areas provided.

19) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—KML/KMZ

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format, the

steps are as follows:

1) Use a KML to SHP converter to translate file into an Esri® format.

2) http://arcscripts.esri.com/details.asp?dbid=15603

3) Download the script and follow the provided instructions for installing it in ArcToolbox®.

4) Double-click on the script in ArcToolbox® and navigate to the location of the KML file, as shown
below:
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-

£ Convert KML to SHP

KML File

| C:'\Documents and Settings'\forr\Desktop\Google\ftupton. kml

Feature Type

| PoLYGON

QOutput shapefile

| C:'\Documents and Settings\forr\Desktop'Google\ftupton_kml_to_shp.shp

oK | Cancel | Environments...| Show Help >> |

5) Add the new shapefile to ArcMap®. Repeat for all KML files provided.
6) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—CAD DATA

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:

1) Transform the CAD dataset into an Esri® format.

2) http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datase
ts

3) It may be necessary to contact the provider first to determine the coordinate system of the CAD
data.

4) If the CAD data is not in a standard coordinate system, it may be necessary first to use ArcMap®
to georeference the CAD data to a known coordinate system.

a) To do so, follow the instructions provided above in Coverage Area—PDF/JPG/Other Image
Format.

5) In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider
coverage area.

6) Add the shapefile to ArcMap®.

7) Using the Editor Toolbar, select Start Editing. Set the Task to Create New Feature.

8) Use the Sketch Tool ? Tlto digitize a new coverage polygon using the coverage area outline
from the georeferenced CAD file and add the required attributes manually.
9) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—GIS DATA

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:
1) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class either created above or supplied by the provider into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click on the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[FrovMame [string] <Nones=
DBAMame [=tring] =Monex
FRM [inf] <None>
GeogUnit [string] <None>
| GeogUnitiD [ztring] =Monex
_| TransTech [ghort int] <None>
| MaxAdvDown [ghort int] <None>
| MaxAdvUp [zhort inf] =Monex
_| ARPU [float] <Nones
SWWNomSpeed [float] <Naone>

< Back | Next = | Cancel

e. Click Next, then Next again, then Finish.
2) In ArcToolbox®, go to Data Management Tools>General>Append.
3) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

EBX

Input Datasets =
| =l @

C:\Working \BroadbandProviderData \Columbine \Columbine gdb\service_area bb...  ofu

Target Dataset
| C:\Working'\Broadband \ProviderData\ColumbineColumbine .gdb'\bb_cov

Schema Type (optional)
Field Map (optional)

oK | Cancel | Enuironments...| Show Help == |

4) Leave the Schema Type as TEST.
5) Click OK.

6) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.
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CENSUS BLOCKS—LIST OR SPREADSHEET

In the event that the provider supplies census block data in a list or spreadsheet, the steps are as
follows:
1) Ensure block polygons supplied by the provider are 2000 currency.
2) If other currency, convert to 2000 currency before proceeding.
a. Todo this, remove the trailing letter (a, b, etc.) from the block ID.
b. You will now have two blocks that equate to one block in the 2000 block geometry.
c. Delete duplicate block IDs, retaining the higher service tier in each case.
Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells,
colors, borders, etc.
Import the spreadsheet into ArcMap®.
Right-click on the 2000 census block feature class in the layer list in ArcMap® and select Joins
and Relates>Join from the dropdown menu. Join the census block list to the 2000 census blocks
feature class using the block ID and export joined records in a new feature class. The Join dialog
box and process can be seen above in the TIGER® Street Segments—List, Spreadsheet or GIS
Data subsection.
6) Follow the steps in Census Blocks—GIS Data below.

CENSUS BLOCKS—GIS DATA

In the event that the provider supplies census block GIS data, the steps are as follows:

1) Ensure that the blocks supplied by the provider are in the required data schema and are
complete as far as required attribution.

a. If not, manually enter the required attribution or contact the provider to fill gaps.

2) If census block geometry is distributed throughout more than one county, then select Data
Management Tools>Generalization>Dissolve in ArcToolbox® and dissolve based on
County/Provider/TT/Speed Tier so that unique records are created for each unique combination.
a. The Dissolve dialog box is shown above in the TIGER® Street Segments—List, Spreadsheet

or GIS Data section.
b. Two examples of undissolved census block polygons are shown below:

YAMHILL COUNTY
Undissolved Census blocks

.
~“Yamhill County
~__ | Provider A

= 1

,:PO!.'E'C@&V
Provider ASS——=% \ V©
“TT0 7

Speed Tier 1

POLK COUNTY

Undissolved census block polygons
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Dissolved Census Blocks

will all slivers and holes removed. VAMHILLCOUNTY

Yamhill County
Provider A
1710
Speed Tier 1

Polk County
Provider A
TT10
Speed Tier 1

POLK COUNTY

Census block polygons dissolved by county

3) For each dissolved region use the Editing toolbar in ArcMap® to remove unnecessary slivers and
other small holes.
4) In ArcToolbox®, select Data Management Tools>General>Merge and merge the processed
polygons into a single layer.
5) The merged census blocks will need to have the subscriber’s frn field added and populated.
6) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class either created above or supplied by the provider into it.
d. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, the click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:

. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field

|Prc|\.rName [ztring] =Monex
_| DBAName [string] <None>
FRNM [in] <None=
| GeogUnit [string] =None=
_| GeogUnitiD [string] <None>
TransTech [ghort int] =Mone>
| MaxAdvDown [ghort inf] =None=
| MaxAdvUp [zhort int] <None>
| ARPU [float] =Monex
SWNomSpeed [floafl =None=

Reset

< Back | Next = | Cancel

h. Click Next, then Next again, then Finish.
7) In ArcToolbox®, go to Data Management Tools>General>Append.
8) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:
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~
Input Datasets
| -l =

C:\Working'Broadband\ProviderData\Columbine\Columbine . gdb\service _area_bb... +

Target Dataset
| C:\Working'\Broadband\ProviderData\Columbing\Columbine . gdb\bb_cov
Schema Type (optional)

Field Map {optional)

QK | Cancel Environments... | Show Help == |

9) Leave the Schema Type as TEST.
10) Click OK.
11) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.

METADATA TRANSACTIONS

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts
staging environment, the GIS-Analyst runs transactions to compare that fGDB with the one stored on the Core
server to ensure metadata on all changes is recorded.

The steps taken to run transactions on the updated Core database are outlined below:
1) Openacommand line window and run generateTransactions.py:
a. Usage: generateTransactions.py [Core fGDB] [Staging Environment fGDB]
b. Example of command line:
<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb
2) Shown below is an example of the output screen that will be displayed:

Collecting Transactions

Calculating rec_id field for BBCov_@_BB_POLY_TEMPLATE
value can not he B or less
Trouble creating the progress meter

Calculating rec_id field for BBCov_18_CenturyLink
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Merging change: HX:~BDIA_BB_GDBs\MS_BB_POLY_SRU_AREAS .gdb~AddPt
Calculating Transaction fields for AddPt

®:~BDIA_BB_GDBs~M5_BB_POLY_SRU_AREAS .gdb“AddPt...changes iz complete.

Your transzaction FeatureClasses are in:
~michigans~AllAccess~BDIA_BB_GDB=_HIST-~MS_BE_POLY_SRU_AREAS_HIST .gdb

elapsed time = 2994.4 seconds

3) After the process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb:
a. The transactions scripts records changes at a feature level.
b. Shown below is a screenshot supporting the directory structure of the historical f{GDB.

ArcCatalog - ArcView - MABDIA_BB_GDBs_HIST\CO_BB_POLY_SRV_ARFAS_HIST.gdb
 —————

File Edit View Go Tools Window Help

|53
Location

Stylesheet:

|M \BDIA_BB_GDBs_HISTNCO_BB_POLY_SRV_AREAS_HIST gdb

28] CO_BE_POLY_SRV_AREAS_HIST.qdb| -

-] AddPt

-.[5l] BBCov_0_POLY_TEMPLATE

-.[E] BBCov_10_Agate

BBCov_10_BigSandy

BBCov_10_Bijou
BBCov_10_Blanca

-.[5l] BBCov_10_CenturyLink
BBCov_10_Columbine
BBCov_10_Covad

BBCov_10_DuboisTelExchange
EBCov_10_ESRTA
BBCov_10_Farmers

-.[51] BBCov_10_Glenwood
BBCov_10_HaxtunTele
BBCov_10_Internet_CO

- &l BBCov_10_JED
BBCov_10_Munn

..[5l| BBCov_10_PineDrive
BBCov_10_PlainsCoop
BBCov_10_Qwest

BBCov_10_Rico

=l

Contents ] Preview } Metadata ]

Name

Type

Medified

BBCov_10_Nunn

[ addpt
BBCov 80 ATT
BBCov_80_Sprint
BBCov_10_DuboisTelExchange
BECov_70_Mohilelnet
BECov_10_Sunflower
BECov 10 Qwest
BECov_30_XOComm
BBCov 41_Comcast
BBCov_20 XOComm
BECov_50_Rye
BECov_71_SECOM
BBCov_50_Glenwood
BBCov_10_Rico
BBCov 71 _Sanlsabel
BECov_B0_Verizon
BBCov_10_Wiggins
BBCov_10_PlainsCoop
BBCov_70_Bijou
BBCov_30_Covad
BBCov_70_SouthPark

File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class

8/30/2010 8:57:53 AM
11/30/2010 4:49:46 PM
11/30/2010 4:37:35 PM
8/30/2010 9:24:00 AM
8/30/2010 8:21:41 AM
8/30/2010 8:22:48 AM
8/30/2010 8:23:55 AM
8/30/2010 8:25:11 AM
8/30/2010 8:26:18 AM
8/30/2010 8:27:24 AM
8/30/2010 8:28:32 AM
8/30/2010 8:29:33 AM
0/10/2010 10:59:47 AM
8/30/2010 8:32:01 AM
8/30/2010 8:33:21 AM
8/30/2010 9:31:55 AM
8/26/2010 2:33:20 PM
8/30/2010 8:37:43 AM
11/30/2010 4:35:50 PM
11/30/2010 4:36:30 PM
9/10/2010 11:07:22 AM
8/30/2010 8:42:13 AM

BBCov 10 _Rye
—

e Gepdaicbace Focte e L ERE Ry

c. Attribution associated with each added/removed/changed feature is tracked, including the
following additional columns appended to the end of each:
(i.) Commit_by
(1) Records the GIS-Analyst who committed the changes to the historical fGDB.
(ii.) Commit_date
(1) Records the date and time stamp on which the changes were committed.
(iii.) Trans_type
(1) This field reflects the type of change recorded;
(2) Categorized by: Adds/Change/Deletes.
(iv.) New_values
(1) Records the new values when a change was completed on a feature. Example:
Name or speed change.
MD_Process also is transferred from the edited fGDB to the historical f{GDB, which states the
actions completed by the GIS-Analyst.
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& ArcCatalog - ArcView - MABDIA BB GDBs HIST\CO BB POLY SRV_AREAS H

File Edit View Go Tools Window Help

& | Ll B AP |N

Location:  [M:\BDIA_BB_GDBs_HIST\CO_BB_POLY_SRV_AREAS_HIST gcb\AddPt |

Siylesheet ESRI

Conterts Proview | Metadata |

5 CO_BB_POLY_SRV_AREAS_HIST.gdb
0 Adapt md_address ma_process commit_date trans_type new_values
BBCov0_POLY TEMPLATE 200BaseB Bl eladalaFields.py_v1 2, added Jab Mid Mie poin's back into db per criigen cmabey &2472010 4435 | change
i py_v1.2, added Jab Id Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
BBCow 10 Agate 2ddBaseBBl etadataFiekis.py_v1.2, added Jab Iid Mik points back into db per criigen cmabey 82472010 4:43:5 | change
BECov_10_Bigsandy a0dBaseBl ctadataFicids.y_v1.2, added Jab I i€ ponts back nto db per criigen cmabey 8242010 4:43:5 | change
BBCov 10 Bjjou - addBas<BBMetadataFiekds. py_v1.2, added Jab Wid Mie poinis back into db per criigen cmabey 82472010 443 | change
BBCov_10_ Blanca 20dBascBBl cladataFicids.py_v1.2, added Jab Mid Mie points back nto db per crilgen cmabey E24/2010 4435 | change
BBCov_10_Centurylink py_v1.2, added Jab I Hie points back into db per oriigen cmabey 82472010 4435 | change
BBCov_10_Columbine py_v1.2, added Jab i Hie points back into db per criigen cmabey &/24/2010 4.435 | change
BBCov10_Covad py_v1.2, added Jab I Hie points back into db per criigen cmabey &/24/2010 4435 | change
BECov_10_DuboisTelbxchange py_V1.2, 50ded Jab I Hie points back o db per critigen cmabey &24/2010 4:43:5 | change
- py_V1.2, added Jab Wd Mie poinis back nto db per criigen Cmabey 82472010 4:4335 | change
BCov_10 ESRTA py_v1.2, added Jab Wd Mie poinis back nto db per criigen Cmabey 82472010 4:4335 | change
BBCov 10 Faimers py_v1.2, added Jab Id Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
BBCov_10_Glenwood py_v1.2, added Jab Mid Mie points back into db per critigen cmabey 8242010 4:43:5 | change
BCov_10_HaxtunTele py_v1.2, added Jab Id Mie poinis back nto db per criigen cmabey &2472010 4:43:5 | change
BBCov_10 Internet CO 20dBaseB Bl ctadataFicids.y_v1.2, added Jab I i€ poMts back nto db per criigen cmabey 8242010 4435 | change
BBCov_10_JED a0dBaseBl ctadataFicids.y_v1.2, added Jab I i€ ponts back nto db per criigen cmabey 8242010 4:43:5 | change
BCov 10 Nunn | 20dBas<BBl cladataFicids.py_v1.2, added Jab Mid Mie points back nto db per crfigen cmabey E24/2010 3435 | change
BB Cov10_FineDrive 20dBascBBl cladataFicids.py_v1.2, added Jab Mid Mie points back nto db per crilgen cmabey E24/2010 4435 | change
0 py_v1.2, added Jab I Hie points back into db per oriigen cmabey 82472010 4435 | change
EBCov.10.PlainsCoop py_v1.2. added Jab Hid Nie points back nto db per criigen cmabey 872412010 4435 | change
BCov_10_ Quest py_v1.2, added Jab Mid Nie points back nfo db per criigen cmabey 812472010 4435 | change.
8BCov 10 Rico py_V1.2, 50ded Jab I Hie points back o db per critigen cmabey &24/2010 4:43:5 | change
BBCov 10 Rye py_V1.2, added Jab Wd Mie poinis back nto db per criigen Cmabey 82472010 4:43:5 | change
BCov_10_SandT py_v1.2, added Jab Wd Mie poinis back nto db per criigen Cmabey 82472010 4:4335 | change
BBCov10_Sunflower py_v1.2, added Jab Id Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
EECov 10 TDS py_v1.2, added Jab Wd Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
BCov 10 Wiggins py_v1.2, added Jab Id Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
B 20 o 20dBaseB Bl ctadataFicids.y_v1.2, added Jab I i€ poMts back nto db per criigen cmabey 8242010 4435 | change
20 a0dBaseBl ctadataFicids.y_v1.2, added Jab I i€ ponts back nto db per criigen cmabey 8242010 4:43:5 | change
BBCov 20 Internet CO 20dBas<BBl cladataFicids.py_v1.2, added Jab Mid Mie points back nto db per crfigen cmabey E24/2010 3435 | change
BCov_20_NewEdge addBascBBMctadataFields py_v1.2, added Jab Mid Mie poinis back into db per criigen cmabey 8472010 4435 | changs.
BBCov_20_XOComm py_v1.2, added Jab I Hie points back into db per oriigen cmabey 82472010 4435 | change
8BCov_30_Covad py_v1.2, added Jab i Hie points back into db per criigen cmabey &/24/2010 4.435 | change
BCov 30 Internet CO py_v1.2, added Jab I Hie points back into db per criigen cmabey &/24/2010 4435 | change
BBCov 30_NewEdge py_V1.2, 50ded Jab I Hie points back o db per critigen cmabey &24/2010 4:43:5 | change
B Cov 30 TWTelecom py_V1.2, added Jab Wd Mie poinis back nto db per criigen Cmabey 82472010 4:4335 | change
e py_v1.2, added Jab Wd Mie poinis back nto db per criigen Cmabey 82472010 4:4335 | change
BCov_30_ X0Comm py_v1.2, added Jab Id Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
8BCov_40_CommComm py_v1.2, added Jab Wd Mie poinis back nto db per criigen cmabey &24/2010 4435 | change
BBCov_41 Baja <AARaaaR Rl atarataFiakie me 111 3 arian 1an WA Mia nninfe har nfe b nar ~rfinan cmaner #arnin 4475 | ohanna
BCov_41_Bresnan
BBCov_41_Comcast Record: ﬂ j 1 j ﬂ Show: W Records (of 20424) Options +
e —

BBCov_d1_EagleCom

DATA PROCESSING

DATA PROCESSING OVERVIEW

The following subsections detail the steps and layout required to process the service provider data further
to meet NTIA requirements:
e  Weighted Nominal Speed;
e Middle Mile;
Broadband Coverage Template.

WEIGHTED NOMINAL SPEED

The weighted nominal speed is populated in one of the following two ways: subscriber data supplied by
provider or value supplied by provider.

SUBSCRIBER DATA SUPPLIED BY PROVIDER

Where the data provider supplies subscriber speed information, the following formula from the NOFA
is used:
(speed tier-1in kbps x no. of tier-1 subscribers) + (speed tier-2 in kbps x no. of tier-2 subscribers) + (etc.)
Total average monthly subscribers

Data is initially broken up in the following order:
1) Stcty fips;

2) Transmission technology type;

3) Subscriber tiers.
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VALUE SUPPLIED BY PROVIDER

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be
populated instead of using the NOFA formula. These obtained or calculated values are used to update
the service overview layer.

This can be done manually or by creating a table with the provider’s FRN and average weighted speed

and joining it to the service overview table in ArcMap®.

1) To join, right-click on the layer to join to and select Joins and Relates>Join from the dropdown
menu.

2) Then navigate to the table to join to and select the join fields from the dropdown list.

3) Then open the source table (the table in ArcMap®) and right-click on the header of the Average
Weighted Speed field and select Calculate Field from the dropdown menu.

4) Use the value of the average weighted speed from the joined table.

MIDDLE MILE

Middle mile information generally is provided in spreadsheet or text file format. The process is to take
what is supplied by the provider and translate it into the required data schema.
1) If the data is supplied with address information, follow the process outlined above in Subscriber
Location—Address Data.
2) If the data is supplied with associated XY coordinates, follow the process outlined above in
Subscriber Location—XY Data.
3) Once the datais in GIS format, use the Append (Data Management Tools>General>Append)

command in ArcToolbox® to append the data to the overall middle mile dataset.
4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the
source to the target dataset.
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BROADBAND COVERAGE TEMPLATE

The table below lists descriptions of the fields within the bb_cov layer, which is the interim dataset used
to create the final product deliverable.

ALIAS

DESCRIPTION

SHAPE

Internal Shape storage

OBJECTID

Internal Object ID

RECORD_ID

Unique ID for this record, and is required for Transactional updates
to function properly.

STATE_COUNTY_FIPS

State/County FIPS code

PROVIDER_ID

Unique numeric identifier for each provider (Parent Source ID)

PROVIDER_NAME

Unique name for each provider

DOING_BUSINESS_AS

An alternative "Doing-Business-As" name for the provider

TYPE_OF_PROVIDER

Type of Provider (1:Broadband provider as described in the NOFA,
2:Reseller, 3:Unknown, 4:Business Only)

FCC_REGISTRATION_NUMBER

Provider FCC Registration Number

BBCOV_NAME

BroadMap Broadband Coverage name (usually Place or County
name)

TECHNOLOGY_OF_TRANSMISSION

Unique code for the transmission technology type described by
this layer

SPECTRUM_CODE

Unique code for the spectrum [WIRELESS ONLY]

MAXIMUM_ADVERTISED_DOWNS
TREAM_SPEED

Maximum advertised downstream speed available within given
area (speed tier)

MAXIMUM_ADVERTISED_UPSTRE
AM_SPEED

Maximum advertised upstream speed available within given area
(speed tier)

TYPICAL_DOWNSTREAM_SPEED

Typical downstream speed available within given area (speed tier)

TYPICAL_UPSTREAM_SPEED

Typical upstream speed available within given area (speed tier)

MD_GEOMETRY

Metadata: Comma separated list of source id's from which the
polygon extent was produced

MD_EXISTS

Metadata: Comma separated list of source id's used in
understanding and editing this feature

MD_WHO

Metadata: Name of the editor who last edited this feature at the
time in md_when

MD_WHEN

Metadata: Date/time that this feature was last edited

MD_PROCESS

Metadata: Comma separated list of processed used to create
and/or modify this layer

SHAPE_AREA

Area in square decimal degrees

SHAPE_LENGTH

Length in decimal degrees

VERIFICATION AND VALIDATION

PROVIDER VALIDATION—PROVIDER PORTAL

Following the collection and aggregation of provider data, the aggregated data is validated by the
provider to ensure it is an accurate representation of their coverage area and supporting broadband

information.
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This validation is completed through the Provider Portal web application, which is a secure

interactive map that displays the provider’s coverage areas and allows the provider to

validate, submit feedback or request changes.

o If changes are requested, then the features on the portal are updated and an automatic
request is sent to the provider to complete the validation process.

Providers that did not use the Provider Portal are asked to validate a PDF map displaying

their coverage area(s). This is accomplished via e-mail notification.

PROVIDER VERIFICATION—THIRD PARTY SOURCE REVIEW

After the provider has validated its coverage areas, a third-party source comparison and analysis can
be performed. Not all grantees choose to participate in this form of verification.

Where anomalies or discrepancies are identified, a “SCAN” point is dropped and descriptive
comments are applied to be reviewed later with the provider. During the provider review, the map is
displayed along with the “SCAN” points and potential refinement is completed based on input from
the provider.

The table below shows third-party sources used:

THIRD-PARTY SOURCE NAME SOURCE TYPE VERIFICATION TYPE

Mobile Pulse) Speed Tests — Speed tests are used to verify Terrestrial Mobile
Wireless Coverage Wireless (TT 80) coverage, upload and download
speeds.

Media Prints Cable Boundaries Used to verify the following TT:

Cable Modem—DOCSIS 3.0 (40) and Cable Modem—
Other (41).

Compare fiber backbone structure to the coverage
reported by the providers - Optical Carrier/Fiber to the
End User (50).
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ASSIGNING CONFIDENCE VALUES

All findings and results from the abovementioned validation and verification activities, plus internal
peer quality reviews, are captured and tracked in a Validation table (see example on the following
page) and form the basis of the confidence value assigned for each provider and then each
technology.

CONFIDENCE VALUE | DESCRIPTION

0 Coverage area has not been reviewed.
10 Extremely Low:
Single Source QC.
20 Very Low:
Needs additional validation\verification.
30 Low:
Even with validation\verification, coverage still is suspect.
40 Acceptable:
Confirm with State prior to shipment.
50 Meets requirements to be included in shipment.
60 Moderate:
Meets NTIA/State’s standards, representative of Technology Type (TT).
70 High:
Accurate representation of coverage based upon TT.
80 Very High:
Multiple validation\verification with most third-party sources.
90 Extremely High:
Multiple validation\verification sources.
Perfect:
Multiple validation\verification sources, with complete alighment with
sources and ground truth verification activities.

The Validation table is maintained as updates or changes occur for each provider, down to
technology type, with the overall goal to improve the confidence values and overall map
representation.

COMMUNITY ANCHOR INSTITUTION (CAI) DATA

DATA COLLECTION

The CAl data was initially collected from the State to create the baseline inventory. All location
information and broadband coverage data supplied also was ingested into the data deliverable.
Additional collection of CAl information was done via data mining and/or webscraping to build out
the inventory further. For example: Collection of additional CAls and location information.

The State-agency-provided CAl inventory was comprehensive but the challenge is collecting
broadband related data: service provider(s), technology and speed data for each CAI. Availability of
the CAl portal has not significantly increased submission of this data. Additional promotion to CAls to
use the CAl portal will be needed to increase this data for subsequent deliverables.

INSTITUTION DATA

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet
format. The general process for incorporating this data is as follows:
1) If the datais provided in Excel or some similar format:
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Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.
Standardize the address format as defined in the staging CAl database.
If the spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY
Data tool in ArcMap® to create a spatial data layer.
If there are only addresses, then follow the geocoding steps outlined above to create spatial
data points for each of the institutions.
(i.) Institutions that do not geocode based on the TIGER® 2010 dataset will have to be
located manually using Google Maps, Google Earth or some other information source.
2) If the CAl source data is in GIS format, add the Latitude and Longitude fields and use the
Calculate Geometry tool to populate them, using the WGS 84 coordinate system.
3) Using ArcCatalog®, load the new data into the staging CAl database.
4) This database is ready for the makeDeliverable.py script to process the information into the final
State and NTIA deliverables.

COMMUNITY ANCHOR INSTITUTION (CAI) PORTAL UPDATES

A web application has been released to allow for further data collection and validation of anchor
institution location information, broadband coverage and speed test data. Information collected from
the CAl Portal is then ingested into the overall inventory and will be compared later against the
provider coverage areas mapped to locate any potential discrepancies.

PRODUCT EXTRACT

PYTHON SCRIPTS

The following subsections make use of Python scripts. In general, to use a Python script you must have
Python installed on your computer. To download the latest version of Python, go to
http://www.python.org/download/ and download the latest stable version. As of August 2010, this was
version 2.7. Once this is installed, the general way to run a script is to type the following at a command
prompt: C:\Python27\python.exe C:\<location of script>. Many of the scripts provided have environment
variables that must be set before they can be run.

The Python code for BroadMap’s product extract has been incorporated into a Hudson Cl System, which is
detailed in the Process Operation and Monitoring section of this document. This was a process
improvement activity so that all processes can be monitored, controlled and will contain historical
tracking on each process.

PRODUCT EXTRACT PROCESS

The MapConnect™ product extract process, BDIACreateSBDDOutputMigratedBBCov.py, uses our internal
BB_Cov model to create the following layers rolled up to NATL_Broadband_Map in accordnace to the
current NTIA data model specifications.
e BB_Service_RoadSegment
o This layer contains all broadband services associated with specific street segments for census
blocks larger in area than two square miles.
BB_Service_CensusBlock
o Contains all broadband services associated with census blocks of no greater than two square
miles.
BB_Service_Wireless
o This layer contains all wireless services not associated with specific addresses.
e BB_Service_Overview
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o This layer contains subscriber-weighted nominal speed for each provider's service area at a
county level and is meant to act as a summarized view.

BB_ConnectionPoint_MiddleMile

o This layer contains middle-mile and backbone interconnection points.

BB_Service_CAlnstitutions

o Broadband Service at Community Anchor Institutions (CAl).

o Community Anchor Institutions consist of schools, libraries, medical and healthcare
providers, public safety entities, community colleges and other institutions of higher
education as well as other community support organizations and entities.

BB_ConnectionPoint_LastMile

o This layer contains last mile infrastructure points, which is populated only if data cannot be
provided at a more granular level.

BB_Service_Address

o Represents broadband availability for service address points. Address Point availability refers
to those individual addresses at which each facilities-based provider of broadband service
can provide broadband services of minimal characteristics within 7-10 business days.

State_Boundary

o State boundary supporting topological validation of point feature classes.

NATL_Broadband_Topology

o Supports basic topology quality checking. Example: No CAls or Middle Mile points outside of
the State boundary.

PRODUCT STATISTICS

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py)
extracts the following information supporting that product deliverable.
e  Provider Statistics:
o Collects all provider information, listing by Provider Name.
o Provides output of FRN.
o Counts the number of features supported within the following layers:
Census Block;
Street Segment;
Max Upstream;
Wireless Services;
Infrastructure Points.
o These updates were made to support the Data Package required to accompany every NTIA
product deliverable.
e Community Anchor Institution (CAl) Statistics:
o Breaks down CAl to the eight categories:
1: School: K through 12;
: Library;
: Medical/Healthcare;
: Public Safety;
: University/College;
: Other Government;
: Other Community non-government;
None: Unknown Category. In cases where this occurs, further investigation is completed
prior to product shipment to ensure all CAls are categorized accurately.
Reports out the following counts:
=  Total CAls within that category;
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Total CAls that contain partial BB coverage. Contains any of the following information for a
given CAl: BB Subscriber, Transmission Technology, Speed Down Speed Up;
Total CAls that contain full BB coverage. Contains all of the abovementioned BB information
for a given CAl.
The output of this script is two CSV files: Anchorlnstitutions.csv and Providers.csv. These files then can be
inspected to ensure that there are the expected number of CAls and providers for every release.

QUALITY ASSURANCE

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase and
on the final product. For scheduled product releases, a test product extract and subsequent manual and
algorithmic QC run is completed along with a release review. The product specifications, project status reports
and previous product release notes are used as references throughout this review.

The following parameters are tested using the methodology listed below each:
e  Product Deliverable Format:
o Correct names and format of data deliverables.
= BDIA_QC_SUITES.
Correct Projections/Datum.
=  Manual interaction with product.
o Metadata Present and Correct.
=  Manual interaction with product.
Table Structure:
o Allrequired tables included.
= BDIA_QC_SUITES.
o Extraneous tables identified.
= BDIA_QC_SUITES.
Field Structure:
o Allfields included.
= BDIA_QC_SUITES.
Extraneous fields identified.
= BDIA_QC_SUITES.
o Correct field names, types and widths.
= BDIA_QC_SUITES.
Field Domains:
o Valuesin all tables are constrained to the specified values specified:
=  This action is accomplished via BDIA_QC_SUITES and manual review of the product;
=  This tends to identify project completeness issues as fields with a null value are identified.
Geometric Representation:
o Identify if all layers have the correct geometric representation:
=  Manual review of the BB_ServiceOverview layer;
= Dependent on NTIA and client requirements.
Geographic Extent:
o Product includes the necessary Geography associated with Product?
=  Manual Review—ArcGIS®.
o Isthere extraneous geography included in Product?
=  Manual Review—ArcGIS®.
Completeness:
o Products contain the expected amount of data?
=  Manual review of product statistics relative to weekly State reports and defined expectations.
e  Accuracy:
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o Product meets the stated accuracy requirements for the deliverable?
= Sampling procedure to manually review source material to resulting product;
=  Provider Validation;
= Verification using Third-Party Data;
= Verification against reality, where applicable.
Data Regression:
o Any unexplainable data loss or change?
=  This action is accomplished by comparing results within product statistics script
(BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product.
Confidentiality:
o Any unauthorized confidential information included in the delivery?
= Review of NDAs and delivery expectations.
Prior Issues Resolved:
o Have expected internal issues been resolved?
=  Manual review of data against previous product release notes.
o Have agreed-upon customer issues been resolved?
=  Manual review of data against previous product release notes, status report and client feedback.
Delivery Medium:
o Has the product medium been verified?
=  Manual review.
All files present.
=  Manual review of SFTP site is done to ensure all files are copied correctly, including file/directory
size.
Correct location.
=  Manual review—confirmation of SFTP link, username and password.

QC SUITE

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These
scripts are all run in concert and are called from the test_runner script and the test_BDIAProductGDB
script.

CONFIGURATION

These scripts establish the configuration for the test_BDIAProductGDB script, which is the core of the
QC Suite.

update_test_config

active_config

config_ PROCESS0O1_automated

config_ PROCESSO1_manual

set_active_config

LIBRARIES

These scripts provide additional functionality that is called from with the test_ BDIAProductGDB
script.

bb_unittest_fixture

bbcov_structure

BC_XmlWriter

file_folder

search_and_replace

unittst_fixture

validate_BB_DB

validate_BB_GDB
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xmlrunner_gui
QC SUITE

This is the core script for performing automated QA/QC on the interim and final data deliverables.
test_BDIAProductGDB

OTHER

These scripts perform other functions detailed below:

test_runner—this is the main script that runs all the other QC scripts and imports all the necessary
scripts and libraries.

which_build—this determines the current build and passes information to the configuration scripts.

PROCESS OPERATION AND MONITORING

Product Extract, BDIACreateSBDDOutputMigratedBBCov.py, is run within BroadMap using a platform called
Hudson that has been enhanced to support BDIA product extraction, process monitoring, as well as product
validation. The same platform can be planned for implementation for the State, if desired.

Below are previous examples of the product create, product validation, product statistics and monitoring
processes that are managed within the BroadMap Hudson ClI-System. All of the above-mentioned Python
scripts, with the exception of metadata transactions script, are run via this system.

BDIA PRODUCT CREATE

Below is an example of the main page where the type of product build can be selected.

ENABLE AUTO REFRESH

= New Job
. Menzae Hugson BROADMAP
& peonle I

"> Build History

Build Queue All | BDIA Product Create | BDIA Product Validation  BDIA_Sourcing  BMapENG_MeshTools | BMapQC_SpecChecks | Census Production | Census, Demographics, and Postal Prod

Ne builds in the queue. Job |

Build Executor Status
# Master

Building Census Aligner
UsA) 2211

BDIA BBCov PCat SourceCheck

BDIA BBCov SpeedCheck

Idle
Idle
1dle

Building
Post_Process Postal £102
| e————

BDIA BBCovStats NEWVOLD

BDIA Build

BDIA CAI QC

o
o

B0 0LB-

Idle

®

Alaska

Building Census Aligner
UsA) =208

BDIA Product DataPackage

BDIA Product Summary

Building Census Aligner

USA) 2210 BDIA Product validation AS

3 Idle
4 Idle

BoH

BDIA Product Validation CNMI
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Selecting based on the type of process that will be initiated is shown below:

Hudson » BDIA Product Create = BDIA ProductCreate

4 Back to Dashboard
0, status
"2 Changes

@ worksoace

: g Delete Pro E;)

#7 cenfiure
% Build History (trend)
@ #123 Dec, 2010 12:30:00 PM 186K8
Running for provider portal update
@ #122 Dec9, 20109:53:37 AM 179K8
Running for provider portal update - Test will rerun
when Midce is complete
@ #121 Dec7. 2010 6:09:02 PM 46KB
SD build for portal test
@ #119 Decl,201012:41:51 AM 125K8
€0 Monthly Deliverable w/ Crit Feedback - Reund 2
@ #118 Nov 30, 2010 4:58:46 PM 50K
0 Monthly Deliverable w/ Crit Feedback

Project BDIA_ProductCreate

OR on Alaska

F=
@ Last Successful Artifacts

® bdiaZntia.log &
® makeDeliverable.log &
® robocopy.log &

.
| = Recent Changes
—_

Permalinks

ast build (#123), & days 23 hr ago

ast stable build (#123), 4 davs 23 hr age

ast successful build (£123), 4 davs 23 br agn
ast failed build (£131), 6 days 18 hr ago

ast build (#121), 6 davs 18 hr age

Hudson » BDIA Product Create » BDIA ProductCreate
4 Backto Dashboard

Oy status

= chonges

W workspace

) Build Now

@ Delete Project

2, Confiaure

State OR
State or Territory to Process

BDIA_ProductCreate

his build requires paramets

The Console Output can be reviewed to see the progress of product create. Following the completion of

each product creation process, an e-mail notification is automatically sent to the team.

# Dackosroiea

O Console Output

13
ho Soascony SETUEN CONE 3 iRATAL BSRA L gusa TR
20B0COPY RETURN CODE 4 TAIL MISM XTRA COPY & gueo IRAOR
Scmscory ETUE ConE d TAIL IS RTRL 4 gose R
P RETURM con 3 TAIL ¢ vace maRon
20B05OPY RETURN CODE § TATL KTRA & qeve TRAGR
acha S0RGCORY BETURN CONE 3 TALL COFY 4 yote ERROR

eche FOBOCOPY RETURN GOUE 3 TAIL & gese ERMOR

(dwdson e

buzon + BOLA Produce Craate - BOIA POductCrases » 2117

All processes run via the BroadMap Hudson Cl-System are stored for historical reporting. Each process can
be reviewed, including the Console Output and Build Artifacts from that run.

Hudson
Hudson » BDIA Product Create » BDIA ProduciCreate > £161
4 Back to Project
O, status
"7 Changes
B console output
Parameters
24 this build
[7] ounstream buid view
4 Previous Build

W Next Build

O Build #161 (Mar 28, 2011 9:44:40 PM)

OR Pre-Release Build

Build Artifacts

® baizontia.log &
» makeDeliverable.log &
* robocopy.log =

Revision: 3099
No changes.

Started by user anonymous

Q, search ©)
ENABLE AUTO REFRESH]

Dalata this buid

Started 1 day 1 hr ago
Took 3 hr 31 min on Alaska

[Zedit description
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PRODUCT VALIDATION AND STATISTICS

Once the product creation process is complete, Product Validation and Statistics are then initiated. These
support the BDIA_BBCovStats_ NEWvOLD.py script and the BDIA_QC_SUITES scripts detailed above.

All statistics and reports are stored for historical review with the capability to place violation criticality on
each quality control check, allowing the identification of errors because of project status/completeness
verses project correctness. Example: Typical Speeds populated.

Below is an example of the report provided based on various control points running over a specified
period:

Hudson

Hudson = BRIA Product Validation » BOIA Product Validation €O

# Dackio Dashbonrd

Project BDIA_Product_Validation_CO
“This job chacks db integrity on fila GeoDatabase.

Record Error Monitor

[~ BB_Sarvica_GAInslitutions Errar  BB_Sarvice_Wirelas Erfor - B8_Service_CansusBlock Error
4 BB_Sanvice_Road_Segment Enor -4 BB_Senvice_Ovarview Eror

Latest Stats Re

Wedit descriotion
S0isk Usage: Workspace 239M8, Buids 1G8

Test Result Trend

Similar to the Product Create process, all results from the process are maintained:

T T

Hugdaon » EDIA Product validation + r » 2220 ENABLEAUTQ REFRESH

# Back to Froiect
_ Build #270 (Nov 18, 2010 9:56:35 AM) [Cosn natue |

Started 26 days ago.
Took 39 min an master

[ErT—

(#add sescrovon

Test Result (2 failures / +1)
hudsontest,sutes test BDIAPT B01AProdueGDBETorSymmary Cinss BDIA STRUCTURE QC SUMMARY.
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Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA
data model or project completion statements. Any errors of concern are communicated ahead of product
delivery and included within the product release notes. Further detail on the Hudson-Cl System
environment can be found by navigating to the following link:

http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson

Hudson » BDIA Product Validation €O
# Back to Dashboard Project name BDIA_Product_Validation_CO

0, status Description <p>This job checks db integrity on fils <lp>
— <im@ src=http://vermont:8080/job/BDIA_Product_Validation_CO/plot/getPlot7index=0amidth=6508height=350>
™, Changes <p>Latest Stats Regression: <a href="http://vermont:8080/job/BDIA_Product Validation_CO/lastSuccessfulBuild/artifact/SBDD_TRANSFER_counts_diff.html" >Link</a><p>
<p> Latest Provider Regrassion: ttp://vermont:8080/job/BOIA_Product_Validation_CO, DD _diff.htm!">
gression: <a /[vermont:8080/job/BOIA_Product_Validation_CO/lastSuccessfulBuild/artifact/CO_error_: ry_diff.heml

@ workspace
"> Link</a><p>
£) suidow <p>Latest CAI Regression: <a href="http: /job/BDIA_Product_Validation_¢ D_TRA _diff.html">Link

 Delste Project
Discard Old Builds
#, Confiure
B st Days to keep builds
g Fet
&5 Build History (trend) Max # of builds to keep 29

#2600  Dec22, 2010 9:47:05 AM 208 ifnot smpy, only up to thiz number of build records are kept

if not empty, build records 2re only kept up ta this number of days

#279  Dec21, 201011, am
#272  Dec17, 2010 9:41:12 PM 4MB This build is parameterized

€O 50W deliverable validation
#2701 Dec, 2010 8:16:58 AM

String Parameter
Name TestMethodprefix
2270
Default Value Bp1A_STRUCTURE
2269
aass Description
#267  Nov 18, 2010 9:08:05 AM
QC on S0W monthly €O product
#266  Sep 20,2010 11:12:09PM
#2365 Sep26,201011:17:56EM
0 validation build
#264  Sep 24,2010 12:22:28PM
#263  Aug 31,20101:20:41 M
#262  AuG 3L 2010 1:17:05 P
#261  Aug 31, 2010 12:20:02 PM 1 Default Value //zlaska/Release Candidates/C0_20101117-1947

String Parameter

Name GDBlLocation

. R 38 a
260 Au030.20108:25:98 AN Description  parent path for the release candidate GRE

PRODUCT EXTRACT DATA DELIVERY

Product delivery for MapConnect™ Broadband is handled two ways, depending on client requirements:
1) State Submittal:
a. Datais submitted via SFTP site;
b. Product Release Notes and QC Test Report accompany the delivery.
2) NTIA Submittal:
a. Directions for using the NTIA State Broadband Data file submission tool:
(i.) Go tothe following website: https://esupport.fcc.gov/statedata;
(ii.) Enter your username and password as provided to you from the NTIA program
administrator;

FCC SUPPORT CENTER

State Data

Broadband State Data Management Tool

Login

Username: *

Password:*

(iii.) Click in Upload a file field;
(iv.) Browse to local file for submission using the Browse button. Select file, then select
ATTACH FILE. See example below.
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FCC SUPPORT CENTER
Broadband State Data Management Tool Alaska (jgeorge@denali.gov) Logout

Upload File| | View Files

UPLOAD NEW FILE

* denotes required field.

Upload File

Upload File* T
5 C:\Users\20100323142745_offer20100323 pdf [[NEEEE] ATTACH FILE

(v.) Logout/Receipt using the Logout button in the top right of the screen;
(vi.) A receipt of submission is e-mailed to username e-mail address.
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