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Beyond The Boundaries

This white paper highlights the Submission Summary for this deliverable, as well as describes the Data Gathering,
Data Integration, Data Validation and Verification and Quality Control processes used to create the Broadband
Mapping Project’s October 1, 2011 data submission. To support varying levels of technical and program
knowledge, both a high-level summary and a detailed process review are supplied.

PROVIDER DETAILS

PROVIDER PARTICIPATION

Providers Included
Alliance Communications Cooperative
AT&T MOBILITY
Beresford Municipal Telephone
CenturyLink
Cheyenne River Sioux Tribe
Consolidated Telecom
DigitalBridge Communications (BridgeMaxx)
Faith
Fort Randall
Frontier Communications
Golden West Communications
Interstate Telecommunications Cooperative
Kennebec Telephone Company
KeyOn Communications Inc.
Knology, Inc.
Long Lines
Mediacom Communications Corporation
Midcontinent Communications
Midstate Communications
Mitchell Telecom
MNW Wireless

New Providers Since Last Data Submission
o  MNW Wireless

e Northern Wireless

e StarBand Communications

Non-Responsive/Non-Cooperative Providers
e None

Northern Valley Communications
Northern Wireless

Qwest Communications

RC Communications

RC Technologies, Inc.

Roberts County Telephone Cooperative
Santel Communications

SDN Communications

Sioux Valley Wireless

Sprint

StarBand Communications Inc.

Swiftel Communications

T-Mobile

Triotel / McCook Cooperative

Valley Telecommunications Cooperative
Valley Telephone

Venture Communications

Verizon Wireless

West River Cooperative

West River Telecommunications Cooperative
Western Telephone Company
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Other Provider Comments

CenturyLink and Qwest have merged and submitted separate data for this round with the
same FRN. Data was aggregated into one footprint and the Qwest provider name was
removed.

Expanded provider outreach to include the Form 477 filers and discovered that the majority
of them that aren’t already included in the map are not broadband providers. Attached is a
spreadsheet reflecting the results of this review:

@

477ProviderReview.
xlsx

COVERAGE AREA CHANGES

Coverage Footprint Reductions/Map Refinement —

Alliance Communications (TT-10 and TT-50)

Fort Randall Telephone Company (TT-10)

Golden West Cablevision Inc (TT-10, TT-41, TT-50)
Splitrock (TT-50)

Coverage Footprint Expansion —

Beresford Municipal Telephone (TT-20)

CenturyLink (TT-10)

e Due to Qwest acquisition

Interstate Telecommunications Cooperative, Inc. (TT-10, TT-20 and TT-50)
Kennebec Telephone Company Inc

e Inclusion of TT-50

Midcontinent Communications (TT-40 and TT-50)
Midstate Communications (TT-10, TT-40, TT-50, TT-70)
Mitchell Telecom (TT-50)

NVC (TT-10)

RC Communications (TT-10)

Roberts County Telephone Coop. Assn (TT-10)

Santel Communications Cooperative (TT-10)

SDN Communications (TT-50)

Splitrock (TT-10)

Swiftel Communications (TT-10 and TT-50)

TrioTel Communications, Inc. (TT-10 and TT-50)
Valley Telecommunications (TT-10 and TT-50)
Venture Communications Coop. (TT-10 and TT-50)
Verizon Wireless (TT-80)

West River Cooperative Telephone Company (TT-10 and TT-50)
West River Telecommunications (TT-10)
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DATA CORRECTIONS

Business only provider coverage areas were added back into the data now that the NTIA data
model supports it with the inclusion of the EndUserCat field.
e Midcontinent Communications

DATA VALIDATION & VERIFICATION

Provider coverage areas were individually compared against third-party data to identify if the
footprint is in alignment. In cases where anomalies were identified, we contacted the provider
for further validation and refined the map, where needed. The third-party data sources used for
this review are as follows:

o Comsearch

o Pitney Bowes

o American Roamer

For wireline and fixed wireless technologies, a set of reviews were conducted. Coverage areas
were first reviewed for accuracy by the providers directly via our online provider portal.

Coverage areas were compared against known telecommunications exchange and territory
boundaries.

Coverage areas were compared by state telecommunications personnel against previously stated
service boundaries, known areas of operation, and areas/locations where state-funded agencies
have broadband services or have attempted to obtain broadband services.

Crowd sourcing efforts were also undertaken to verify and validate broadband coverage areas. A
survey of community anchor institutions was sent by postal mail and electronic mail where
possible, collecting information on broadband service availability, technology in use, advertised
speeds, and results of a speed test. This effort engaged government technology personnel along
with the technology leadership of the healthcare systems of South Dakota, the K-12 education
technology coordinators, and technology personnel of higher education. Other industry sectors
were also included in the survey by direct mailing and articles in trade publications. This
information was overlaid onto provider coverage areas and analyzed for alignment with stated
capabilities.

A public crowd sourcing campaign, including television spots, press releases, and online
marketing/social media efforts was started requesting citizens to take speed tests from home,
work, and elsewhere via our broadband website. Combining address collection and verification
with the speed test, over 5,000 consumer and business locations across the state have been
collected. These results have been combined with the data collected by the FCC Consumer
Broadband Test and FCC Mobile Application to generate a master list of known broadband
addresses and speeds. This master list was analyzed for alignment with provider stated coverage
areas and attribution.
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For verification of TransTech 80, Mobile Wireless, a series of drive tests were conducted across
the state. Using specialized software on mobile handsets, information on signal strength and
broadband speed was GPS-tagged and collected. To date, nearly 17,000 miles of local roads,
state and federal highways have been driven, collecting over 5,000 GPS-tagged speed tests and
over 600,000 signal strength values. This data was overlaid onto coverage polygons received
from each mobile wireless provider and analyzed for accuracy.

Locations discovered to not have mobile wireless coverage but stated by the provider are being
scheduled for additional focus testing and reporting to the provider for review.

Locations found with broadband data coverage but not included with the provider’s original data
will also be sent to the provider for review upon discovery. To date, none have been fully
confirmed.

Speed test results were compared against providers advertised speeds for anomalies.
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COMMUNITY ANCHOR INSTITUTION (CAI) DETIALS

OVERALL STATISTICS

. T . Overall Broadb.and Advertised Advertised
Community Anchor Institution - Categories Subscriber
Count (1or2) Speed Down Speed Up

Category 1 - School K through 12 453 451 64 64

Category 2- Library 120 120 17 16

Category 3 - Medical/Healthcare 204 172 27 26

Category 4 - Public Safety 480 468 32 32

Category 5 - Universities/Colleges 40 40 26 26

Category 6 - Other: Government 56 54

Category 7 - Other: Non-Government 3 3

Total

CAl CHANGES

A revised approach to the development of the South Dakota CAl list began for the Oct 2011
submission. Prior efforts involved the use of a combination of data sources, including locations
gathered from the South Dakota Department of Education, the South Dakota Board of Regents,
the South Dakota Bureau of Administration, trade organizations, healthcare systems, data
purchased from the InfoUSA group, and resources internal to the South Dakota Bureau of
Information and Telecommunications. This approach was found to include institutions that
would not fit the true spirit and definition of a CAI. As such, SDBIT removed those CAl's from the
list, while updating the list to include newly opened facilities.

The list of changes include, but are not limited to:

e Inclusion of the most recent K-12 education facility list, removing recently consolidated K-12
school district locations and included newly opened facilities
Updating the library list to the most recent obtained from the South Dakota State Library
Reduction of healthcare facilities to hospitals, major clinics, and facilities for an entire
community/locality; thereby removing specialized and limited practice facilities such as
dentists, dialysis centers, and chiropractors
Reduction of public safety locations to facilities staffed at least part-time
Inclusion of the most public higher-education facilities list obtained from the South Dakota
Board of Regents
Inclusion of additional higher-education facilities, including newly-opened facilities,
expanding campus locations, seminaries, and additional private schools located since
previous submissions
Reduction of government community support locations to those that provide services to a
community, such as social services offices, city halls, courthouses, public health nurse
offices, and job service locations; Locations removed include maintenance and fueling
facilities, government storage facilities, and state park ticketing offices
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Reduction of non-government community support locations, including removal of smaller
airport facilities, churches and other houses of worship, and retail offices

There were 489 CAlIDs added to the CAl Inventory for Category 1: K-12 Schools, Category 2:
Libraries and Category 5: Colleges, which were extracted from the three databases
communicated by NTIA. These databases are as follows:

For K-12 institutions (CAl type 1) please add the NCES ID CCD ID value found here:
http://nces.ed.gov/ccd/bat/

For Higher Education (CAl type 5) please add the NCES IPEDS ID value found here:
http://nces.ed.gov/ipeds/datacenter/

For Libraries (CAl type 2) please. Combine (do not add) “FSCSKey” and “FSCs_SEQ” from the
“puout08av2000” file and place them here:
http://harvester.census.gov/imls/data/pls/index.asp_(FYI the LIBID is your state’s unique ID
for libraries)

SUBMISSION RECEIPT

SUBMISSION RECEIPT RESULTS

e Attached are the results from the NTIA data submission receipt quality script.

A

SD 2011 10 O01.txt

The only item flagged in the submission receipt output is the following error, which has been
verified as correct entries within the data submission.

Field Check: FAILED  CAlnstitutions_ TRANSTECH has 2679 UNEXPECTED VALUES for
query: TRANSTECH <> 0 AND TRANSTECH <> 10 AND TRANSTECH <> 20 AND TRANSTECH <>
30 AND TRANSTECH <> 40 AND TRANSTECH <> 41 AND TRANSTECH <> 50 AND TRANSTECH
<> 60 AND TRANSTECH <> 70 AND TRANSTECH <> 71 AND TRANSTECH <> 80 AND
TRANSTECH <> 90 AND TRANSTECH <> 0

This was flagged due to an inconsistency between the data model and the submission
receipt script, which has also been communicated by other Grantees on PBWorks.

Hyperlink to Grantee Workspace in which the same issues were identified by other Grantees:
https://sbdd-granteeworkspace.pbworks.com/w/page/42442088/Data%20Model%20lIssues-June2011
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DATA GATHERING

BROADBAND SERVICE AREAS, MIDDLE MILE AGGREGATION POINTS AND
BROADBAND SERVICE OVERVIEW

The collection of Broadband Service Areas, Middle Mile Aggregation Points and Broadband Service
Overview information is handled through the following Provider Outreach Process:
e  Build and maintain an inventory of Broadband providers through research and State inputs.
e Update provider material that describes the data requirements and logistics for data transfer.
e Update Non-Disclosure Agreement (NDA) for use in project, where applicable.
e Maintain multiple protocols for the provider to submit data, including Secure File Transfer
Protocol (SFTP) technology when desired.
Conduct one-on-one informational discussions with each provider to communicate the following:
o Requirements of this project;
o Broadband data required to support the product data model;
o Submission protocols available;
o Capability to validate how the supplied data is aggregated.

Download/receive provider data.
Establish a repeatable process with provider. Maintain provider communication, transaction and
data handling records throughout the project (dates contacted, data received, etc.).

COMMUNITY ANCHOR INSTITUTION (CAl)

The collection of CAl information is handled through the following CAI Collection Process:

e Collect and maintain inventory of CAls through data mining, research and State inputs.

e Maintain web-based CAl portal for institutions to add or confirm attribution, location and enter
broadband-specific information.
Upload web-based data to Core Database for standardization.
Perform internal cleansing, such as removing duplicate records, identifying gaps in broadband
attribution and verifying category.
Geocode CAl locations.
Translate Core Database data to deliverable-ready format.
Continue engagement with non-responsive institutions.
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DATA INTEGRATION PROCESS

The data integration and processing mechanisms currently used allow for multiple types of inputs and result in
a standardized output that meets the NTIA deliverable requirements. This flexible process supports data
model changes and project-requested enhancements.
e  Receive inputs from providers via submission protocols; upload into Sourcing Database and catalog

with provider information.

Review provider-supplied data for completeness and for potential discrepancies that require

resolution prior to processing and flag as necessary.

Categorize input into data-type category (addresses, block lists, paper maps, etc.).

Standardize input based on data type within Staging Database.

Create Compact Polygons (CP)—(internal methodology for generating area-based feature for

coverage in Staging Database).

Apply broadband attribution to CP; apply metadata to CP.

Perform quality analysis of the CP against the source supplied to identify any completeness or

accuracy issues.

Request additional information from the provider if elements of coverage are missing or contain

discrepancies. This is a second manual quality check to ensure data is complete.

o Process coverage area to build the required NTIA data model layers.

Process CAl data input into internal standardized format, as discussed above in the Community

Anchor Institution (CAIl) subsection, based on NTIA and State-level requirements.

DATA VALIDATION AND VERIFICATION

Following the creation of the product, process steps within Data Validation and Verification occur. To ensure
the data collected and processed is as accurate and comprehensive as possible, provider validation and
internal verification activities are employed. After the initial mapping of providers’ coverage areas and
serviceability claims, additional reviews are performed using the methods described in the subsections below
(Third-Party Data Verification, Broadband Provider Validation, Confidence Values).

THIRD-PARTY DATA VERIFICATION

The coverage is visually and programmatically compared against third-party data. Pitney Bowes and
American Roamer data are used in cases where a coverage area is questionable. All anomalies identified
during this analysis are reviewed with the providers.

BROADBAND PROVIDER VALIDATION—PROVIDER PORTAL APPLICATION

Providers are trained on and requested to use a secure interactive web application to review their current
coverage area(s) and supporting broadband attribution and validate their data or submit change requests
to update their data. All provider change requests go through the Data Integration Process and are
reviewed with the provider to complete validation.
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CONFIDENCE VALUES

All verification, validation and manual quality review results are tracked by provider/technology type and
stored and maintained within a Validation table. A confidence value is assigned, based on internal
assessments of the collected information, to highlight the provider coverage areas and/or attributions
that would benefit from further investigation and/or enhancements.

QUALITY CONTROL

Following collection, processing and analysis of the provider and CAl data, the product is checked manually
and algorithmically against the NTIA data model. Some of the items included within these checks are:

e Format correctness;

e Table and field structure;

e Valid values, including default values, where applicable;

e  Geographic extent and topology errors.

Prior to data submission, another quality control script supplied by NTIA is run. This script,
SBDD_CheckSubmission.py, creates an output in text form that is required to be submitted along with the final
deliverable. All errors must come up clean, unless otherwise specified by NTIA. Exceptions to the script as
noted by NTIA on the SBDD Workspace on 03/25/11 can be found at the following link: https://sbdd-
granteeworkspace.pbworks.com/w/page/38218329/CheckSubmissionExceptions

e Longitude values for States outside the lower 48 (any table);

e CAlresults for Transtech, MaxAdUp, MaxAdDown if BBService is “No” or “Unknown”;

e  Overview MaxAdDown, MaxAdUp if 100% of record-level data has MaxAdDown or MaxAdUp

populated.
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A detailed review of the data collection, integration and quality control points within the broadband data gathering
and mapping process are discussed in the subsections that follow. In addition, a diagram showing the overall
process can be seen below.

Import a Baseline Mapping

Data & Metadata

Source2Core Transform
CAl Outreach
Portal

= 0= quality Gate
'ﬂ*’) |:> = = that ensures data
Conflict Resolution and system
Partal DalsConslation transformation or
Data Aggregation gt

Release Maodel
Candidate Transform
GDB

Quality Gate

|
{
State Map
Paortal

Lt
a‘aﬁ
[

‘Wieb Products/Services NTIA Deliverabla State Deliverable
|

¥
Release Procedure

Final Delivery

PROVIDER OUTREACH

For the October 2011 data submission, an e-mail notification was sent to all providers with supporting
deliverable dates. The providers mainly used the Provider Portal web application to submit changes to and/or
validate their current coverage area(s).

In support of the data collection effort, providers that did not timely respond to the outreach were contacted
by phone.
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OUTREACH MATERIALS

The original provider packet sent via e-mail to the providers included the following documents and files:
e Letter from the State inviting them to participate in the program;
e  Copy of the Non-Disclosure Agreement (NDA);
e Copy of the Mapping NOFA from the NTIA;
e  Copy of the NOFA Clarification from the NTIA;
Broadband service address example file in CSV format;
Word document describing service address example file;
Broadband service block example file in CSV format;
Word document describing service block example file;
Broadband service street example file in CSV format;
Word document describing service street example file;
Broadband subscriber example file in CSV format;
Word document describing subscriber example file;
Broadband wireless coverage area sample shapefile;
Word document describing wireless coverage area sample shapefile;
Instructions for downloading, installing and using the WinSCP SFTP application.

OUTREACH PROCESS

The provider outreach process is comprised of the following general steps:

e Send the provider package and introduction letter to the main point of contact for the provider.

e  Follow up with e-mail and telephone to verify that the main point of contact is correct.

e If necessary, discuss the NDA further and resolve any redlines.

e Once the correct primary contact is established, set up a telephone call, if necessary, to learn more
about the provider’s offerings and direct them to the appropriate outreach materials.
If providers are unable to be contacted (non-responsive) or indicate that they are not interested in
participating (non-cooperative), mark them as such on the provider tracking sheet. These providers
will be escalated to the State for further action.
As the providers are collecting the required data, provide instructions on downloading, installing and
using the WinSCP SFTP application, if required.
Arrange with the providers to transfer the data in whatever way they are comfortable: some
providers will find regular email acceptable; others will want to use the SFTP application.
After data is received and reviewed, it may be necessary to contact a provider for clarification or to
address incomplete datasets. In the interest of building and maintaining relationships, care is given
not to push the provider but to work with it to obtain accurate data in the best possible format.
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DATA COLLECTION

DATA TRANSFER PROCEDURES

There are three primary ways data is collected from providers. These are:
e Secure FTP (SFTP) using the WinSCP application;
e  Regular e-mail;
e Mail

INITIAL DATA REVIEW AND QUALITY ASSURANCE

The initial data review and quality assurance process consists of the following general steps:
1) Access the data from the SFTP site or e-mail.
a. If e-mailed, place copy of original dataset in the appropriate provider folder on the SFTP site.
2) Place copy of raw data on local computer in a working directory.
3) Review data and determine course of action based on type of data received.
4) Ensure data is complete and contact provider to address any gaps.

NOTE:
The goal is to get as many providers as possible to provide subscriber address data in the correct format.
Obviously, this will not be possible with all providers so we will continue to have to process various types of
provider-supplied data.

DATA INGESTION

DATA INGESTION OVERVIEW

The following subsections outline the process steps taken based on the type of input supplied by the data
provider:

e Point Data:
o Subscriber location;
o DSLAM location;
o Central Office location;
o Broadcast Tower location.
Linear Data:
o TIGER® street segments.

Polygonal Data:

o Census Blocks;

o Coverage Area.
Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to
append to the bb_cov feature class. The bb_cov feature class is the interim dataset that is then processed
using the makeDeliverable.py Python script to create the MapConnectTNI data layers that will be delivered
to the State and, ultimately, to the NTIA. Detailed instructions used in this process can be found in the
subsections below.
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POINT DATA

SUBSCRIBER LOCATION—ADDRESS DATA

In the event that the data provider supplies subscriber address data, the steps are as follows:
1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data
format.

a. Usually, this has the following columns: street address (number, pre-directional, pre-
modifier, street name, street type, post-directional and post-modifier concatenated), city,
state, ZIP.

2) Configure the ArcGIS® geocoding tool to use the TIGER® 2009 streets dataset.

a. In ArcCatalog®, create a new Address Locater by right-clicking in the white space of the
appropriate directory and selecting New>Address Locater from the dropdown menu.

b. Select US Streets with Zone and click OK.

NOTE:
It is likely that multiple Address Locators will have to be set up to handle the variety of provider address data
received.

c. Navigate to the TIGER Streets 2009 file and click OK.
d. Fillin the dialog box, as shown below:

New US Streets with Zone Address Locator

Name: [ CO_Geocode_TIGER_2009] Input Address Fields

Fesrioe | US Steats with Zone The field containing: is recognized if it is named:

Primary table l Zone Addr
Street

Reference data:
| C:\Working'Broadband \BaseData\TIGER _Streets.shp =

[ Store relative path names

Fields

Matching Opti
House From Left: |LFROMADD atcning Options

Place Mame Alias Table...

House To Left: |LTOADD

House From Right: |RFROMADD Spelling sensitivity:

House To Right: |RTOADD Minimum candidate score:

R Minimum match score:
Prefix Direction: |<N0ne> -

Prefix Type: | <None Intersections

Connectors: ale Separate connectors by a

Street Name: |FuLLNAME space, e.q. "R @, [

Street Type: | <None Output Options

Suffix Direction: |<N0ne> Side offset: in |Feet

End offset: 3 % ~p——
[V Match if candidates tie

Left Zone: |ZIPL

Ll Led Lef Lol Led L Lef L L] Lef el

Right Zone: |ZIPR

Qutput Fields

[~ Xand Y coordinates [~ Standardized address
™ Reference data ID ™ Percent along

Advanced... QK | Cancel
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e. Click OK.

Open ArcMap® and add the Excel spreadsheet with the address information.

Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.
Select the appropriate address locator by clicking Add..., then OK.

%= Choose an Address Locator to use...

| Description
e C0_Geocode_TIGER_2009 IS Streets with Zone

Cancel
6) Fill out the Geocode Addresses dialog box, as shown below:

r

— P
Geocode Addresses: CO_Geocode TIGER_2009 PIx
Address table:

|Fibers | ﬂ

Address Input Fields

Street or Intersection:  |F| appR -
Zone: 7IP_CODE -

Qutput

% Create static snapshot of table inside new feature dass
~

Output shapefile or feature dass:
|C:"-.Working"-.BrDadband"-—.vaiderData"-.GIenwoodSprings"-glenwooc

Advanced Geometry Options. .. |

Geocoding Options. ..
Help oK | Cancel |

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all
the default parameters.
8) Review results. See example below.
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——
Interactive Rematch - glenwood_try1 F—_||'E|E\

Show results: ‘AIIAddrassEs j Manage result sets... ‘ Refresh Rematch Automatically

B Matched: 97 (88%)

| | shape | Status | Score | Match_type | Side | A B Ted: 5 (5%)

» 0] Foint 0] 201 CENTENNIAL DR, B1601

Point [ 201 CENTENNIAL DR, B1601 B Unmatched: 8 (7%)

Point [ 201 CENTENNIAL DR, 81601

Foint [l 210 CENTER DR, 81601 ————
Foint [ 15 MARKET DR, 81601

Point [ 40 MARKET DR, 81601

Point u
Point T
Point [
Point M
‘10 | Point u
1 Point [
12| Point T

Record: ﬂj 1 jﬂ Records (of 110)

Address: 1 Candidate Candidate details:
Stestor Intersecton 201 camias | |5 | side_| Match_addr LeftFrom | LefiTo | RightFrom | RightTo Er 201 | 200

Zone W 81 L 201 CENTENNIAL DR, 81601 201 293 200 293 To 299 208
PreDir

PreType

StreetMame |  CEMTEMMIAL
StreetType DR
SufDir

Zone 81601 | 81601
Scare

Side:

Match_addr |201 CENTENNIAL C

58627 SOCCER FIELD RD, 81601
125 STORM KING RD, 81801
52800 TWO RWERS PLAZA RD, 81601

|~ | en| |||~

w

40 MARKET DR, 31801
2698 GILSTRAP CT, 81601

P F>PFEF>PE PP R

@ @
a2

Standardized Address:
201 | | CENTENNIAL | ST | | 81601 < >

Geocoding Options... | Zoom to Candidates | @ Pick Address from Map | Search | Unmatch |

9) Adjust geocoding parameters accordingly and repeat batch to resolve issues.
10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.
11) Visually inspect the data, as shown below:

=

. provider_data_QAQC.mxd - ArcMap - Arcinfo

File Edit View Bookmarks Insert Selection Tools CH2M Window Help

DS HS =} + 2R L VAP OE J=F Al
Georeferendng > [~ ArcPad Data Manager ~ -@ 3 -’ E- =]

3D Analyst ¥

o®

= b Geocoding Result: glenwood_iry1
.

KA w
du oAk

[0 TIGER_Streets

COUNTIES

BB_ConnectionPoint_MiddieMile
®
HIGHWAYS

BITE 3

FCROADS

BB_Service_Road_Segment
CITIES

BB_Service_CensusBlock
=
BB_Service_Overview
]

BB_Service_Wireless

Ll - 4

3

% x

O
MMUNICOmM_coverage_area

[}

wired_coverage_sample_wgs84

O

£

M.Soui]sdecﬁnn 20| ﬂ J
prawing * K Or A~ @] Anal -j0 -~ B ru =

-107.326 39,557 Decimal Degrees

12) Follow the steps detailed in Subscriber Location—GIS Data below.
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@ BROADMAP

SUBSCRIBER LOCATION—XY DATA

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and
longitude, the steps are as follows:

1) Refine the format in Excel so that the data can be opened easily using ArcMap®.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and
make certain there are no merged cells.

Make certain that XY locations are in decimal degrees.

(i.) To convert from degrees, minutes, seconds (392 26’ 45.67") to decimal degrees, use the
following formula: DD + (MM/60) + (SS.555/3600).

b.

NOTE:

If XY locations from some other coordinate system are provided, you can use those in the process below but you
must know what the coordinate system is.

2) Open the Excel worksheet in ArcMap®.
3) From the menu bar, select Tools>Add XY Data...

Add XY Data

Atable cortaining X and Y coordinate data can be added to the
map as a layer

Choose a table from the map or browse for another table:

| ForImports ﬂ g

Specify the fields for the X and Y coordinates:

¥ Field: |LONG

=l
Y Field: ||_,'.\T j

Coordinate System of Input Coordinates

Description:

Geographic Coordinate System:
MName: GCS_WGS_1584

™ Show Details

[+ Wam me if the resulting layer will have restricted functionality

oK | Cancel |

Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate
system and click OK.

Results are an event layer, not a true spatial layer. Export the data by right-clicking the event
layer and selecting Data>Export Data... from the dropdown menu.

Follow the steps detailed in Subscriber Location—GIS Data below.
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If the provider supplies subscriber location in GIS format, the only process step is to load that data

into the appropriate data schema and it will be ready for processing.

1) First, load the data into the Point Address database schema (please see Appendix D for an
example of the Point Address database schema.) using an empty feature class in that schema.

2) In ArcCatalog®, right-click on the empty feature class and select Load from the dropdown menu.

3) Navigate to the provider address GIS dataset and then map the attribute fields accordingly, as
shown below:

SUBSCRIBER LOCATION—GIS DATA

-
Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
ztreet_id [in] <MNone=
zide [ztring] <Mone>
featurs_id [in] <Mone=
point_type [zhort int] <Mone=

add_hou=ze_num [ztring] | BLDG_MUM [=tring) il |

add_pre_dir [2tring] PRE_DIR [=tring]
add_pre_type [=tring] <Mone=
add_name_body [2tring] STREET_NM [string]
add_=suf_type [2tring] SUF_TYPE [=tring]
add =uf dir [ztring] SUF TY'PE [=tringl

Reset

= Back | Mext = | Cancel

Once you have successfully loaded the provider address data into the temporary database with
the correct schema, you now will append that data to the overall Point Address database.

In ArcToolbox®, use the Append command (Data Management Tools>General> Append) to add
the features into the overall Point Address database, as shown below:
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Input Datasets

C:\Working\Broadband\Provider_Data_Example.gdb\Temp_Address

l& [ [X |+ &

Target Dataset
| C:\Working'\Broadband\Provider_Data_Example. gdb\Address_Database

Schema Type {optional)
| TEsT
Field Map {optional)

le 2 X [+ 1] |®

A

Cancel | Environments... | {Show Help ==

Since the data is already in the Point Address database schema, there is no need to alter the Field
Map in the Append tool.
After appending, calculate metadata reflecting geometry source and representation values.
Break provider-specific points into separate county feature classes and perform the following
steps per county feature class:
a. Within ArcGIS®:
(i.) Summarize download and upload speeds [first,last] to determine all speeds available for
county.
(1) This will save as a DBF table. Keep track of location for future reference.
(ii.) Buffer county address point featureclass to 150’.
(1) During buffer command, dissolve on ad_down; ad_up; provider; dba; frn; tt; all
metadata fields; stctyfips. Save as.... county_fastestdown_fastestup.
(2) Example using Qwest data: boulder_40128 20128, where boulder=county;
40128=ad_down; 20128=ad_up.

NOTE:
These attribute fields are specific to the Point Address database.

(iii.) Select the features that represent the lowest speeds.
b. Using XtoolsPro (http://www.xtoolspro.com/):

(i.) In the XTools Pro toolbar, select XTools Pro>Layer Operations>Erase Features.

(ii.) Use the same feature class for Input and Overlay.

(iii.) Check Use selected features on the Input feature, as shown below.

(iv.) Repeat and erase slowest speeds one speed at a time. Save each new feature class as
the next slowest speed, using the same naming convention as shown in a.(ii.)(1) above.
A general example is shown below:
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Erase Features

Input feature layer:

[ boulder_12128_g95 |
[v Use selected features
(1/2 feature selected)
Output storage:
| Ci\Working\Broadband\ProviderDat.. . \boulder _7168_896

v Add output feature dass to current map
[v Create spatial index

Qverlay layer:

|2 boulder_12128 835 |
[ Use selected features (1 feature is selected)

Help CK | Cancel

Return to ArcGIS®:

(i.) Edit/delete speeds from the attribution table of each feature class, so each remaining
feature class has only one speed value.
(ii.) Merge individual speed feature classes using the Merge command in ArcToolbox® (Data
Management Tools>General>Merge). The dialog box is shown below:
EEXR
@ Input Datasets -

@ Output Dataset

Field Map {optional)

X |+ & |e|2|x|+|®

Cancel | Environments... ‘ TShow Help 55

(iii.) Merge individual county feature classes using the Merge command in ArcToolbox (Data
Management Tools>General>Merge).

(iv.) Since the county files are all in the same schema, DO NOT alter the Field Map portion of
the command interface.
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4 BROADMAP
w Beyond The Boundaries
(v.) When all the county files are merged into one dataset, use the Append command in
ArcToolbox® (Data Management Tools>General>Append) to add the features to the
bb_cov interim dataset. Use the Field Map portion of the Append tool to map the
appropriate field values to their corresponding fields in the bb_cov feature class.

DSLAM OR CENTRAL OFFICE LOCATION—ADDRESS DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office address data, the steps are as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

DSLAM OR CENTRAL OFFICE LOCATION—XY DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office XY data, the steps are as follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

DSLAM OR CENTRAL OFFICE LOCATION—GIS DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office GIS data, the steps are as follows:
1) Buffer the DSLAM/Central Office points feature class.
a. Add the point feature class to ArcMap®.
Open the ArcToolbox® and go to Analysis Tools>Proximity>Buffer.
Set the buffer distance to 5 miles.
Set the dissolve type to ALL.
Name the output feature class.
Typical Buffer tool is shown below:

Input Features

| Columbine
Qutput Feature Class
| C:\Working'Broadband \ProviderData\Columbine \Columbine_Buffer_2.shp

Distance [value or field]
(* Linear unit

" Field

Side Type (optional)

End Type (optional)

Dissolve Type (optional)

Dissolve Field(s) (optional)
Ormo

O company
Ocea
Orru

O EexcHANGE
Ostate

O rroviDER
Ocu_cooe
MeorT

£
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g. Click OK. )

2) Use the resulting buffer feature class to clip the TIGER® street layer:
a. Add TIGER® street layer to ArcMap®.
b. Open the ArcToolbox® and go to Analysis Tools>Extract>Clip.
c. Complete the dialog box as shown below:

LER

Input Features

| TIGER _Streets

Clip Features

| Columbine_Buffer

QOutput Feature Class

| C:\Working\BroadbandProviderData\Columbing \columbine_TIGER._clip.shp
XY Tolerance (optional)

| Meters

Cancel | Environments...| Show Help == |

d. Click OK.
3) Using ArcCatalog® and within the file geodatabase:
a. Right-click and create a new Feature Dataset.
(i.) For the Feature Dataset settings:

(1) Name the feature dataset accordingly.

(2) Select horizontal coordinate system by importing the coordinate system associated
with the clipped TIGER® street layer by selecting Import and navigating to the
location of that feature class.

(3) No vertical coordinate system needed.

(4) Leave all x,y,z,m values at default.

(5) Click Finish.

4) Import previously created street feature class into new Feature Dataset.
5) Right-click Feature Dataset and create new Network Dataset—accept all default setting for the
Network Dataset.

NOTE:

The Network Analyst extension must be turned on.

6) In ArcMap® turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst.
7) Addthe Network Dataset created in Step 5 to ArcMap.
8) Using the Network Analyst Toolbar dropdown, create New Service Area.

9) Open the Network Analyst Window by selecting the E button. See below.
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|5ervice Area

Facilil:iﬁ ()]
Polygons (0)
Lines (0}
Barriers (0)

10) Right-click Facilities layer, select Load Locations and navigate to the DSLAM/Central Office

facilities feature class.

.

Load Locations

Load From: El columbine_paints
¥ Orly show point layers

r
Sort Field: |

Location Analysis Properties

Property Field Default Value

Name
CurbApproach Either side of vehide
Attr_Length 1]

Breaks_Length

Location Position

* Use Geometry

Search Tolerance: ‘ 5000 Meters

™ Use Metwork Location Fields

Property
SourcelD
SourceQID
PosAlong
SideOfEdge

Advanced... Cancel

11) Click OK.

12) Click the Service Area Properties button .
13) For the following tabs, change the following properties:
a. Polygon Generation tab:
(i.) Select Merge by break value.

(ii.) Also disable the Trim Polygons option.
Analysis Settings tab—using and converting the specified DSLAM buffer distance from feet

to meters—input buffer distance value in meters into the Default Breaks location.
(i.) Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used as

the buffer distance. See below.
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&3

Layer Properties 2 -

Line Generation ] Accumulation ] MNetworlc Locations ]
General ] Layers ] Source Analysis Settings ] Polygon Generation ]

Settings Restrictions

Impedance: | Length (Meters) ﬂ

Defautt Breaks: |54551

Direction:
' Away From Facility
" Towards Facility

Allow U-Tums: | Evenywhere

¥ Ignore Invalid Locations

c. Click OK.

14) On the Network Analyst Toolbar, click the Solve button E to create service area polygons.

15) Right-click on the created service area polygon in the layer list, and select Data>Export Data from
the dropdown list.
16) Export to a feature class in the file geodatabase you created earlier.
17) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created in Step 16 into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:

Version 2.0 September 2011 Author: Kristin Rousseau
Page 27




Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[Provhame [string] <None=
DBAName [string] =None>
|_| FRM [int] =None=
_| GeogUnit [string] <None>
|| GeogUnitiD [=tring] =Nonex
_| TransTech [ghort int] =None=
| MaxAdvDown [ghort inf] <None>
MaxidvUp [=hort int] =Nonex
ARPU [float] <None=
SWHomSpeed [float] =None=

Cancel

e. Click Next, then Next again, then Finish.
18) In ArcToolbox®, go to Data Management Tools>General>Append.
19) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

EEX

-

Input Datasets =
| =l =

C:'\Working'Broadband \ProviderData\Columbine \Columbine. gdb\service _area_bb. .. +

Target Dataset
| C:\Working'Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov

Schema Type (optional)
Field Map (optional)

‘ w

OK | Cancel Environments... | Show Help =

20) Leave the Schema Type as TEST.
21) Click OK.

22) In ArcMap®, open bb_cov for editing and manually input associated attribution.

Version 2.0 September 2011 Author: Kristin Rousseau
Page 28




The Boundaries

I
@ BEW%OADMAP

BROADCAST TOWER LOCATION—ADDRESS DATA

In the event that the provider supplies wireless broadcast tower location address data, the steps are
as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

BROADCAST TOWER LOCATION—XY DATA

In the event that the provider supplies wireless broadcast tower location XY data, the steps are as
follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.
2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

BROADCAST TOWER LOCATION—GIS DATA

In the event that the provider supplies wireless broadcast tower location GIS data, the steps are as

follows:

1) Download the required software (Radio Mobile) from the website:
http://www.cplus.org/rmw/english1.html

2) Install the software according to the standard directions, found here:
http://www.cplus.org/rmw/download/download.php?S=1

3) Open the application.

4) Load the broadcast tower location and elevation information by selecting File>Unit properties.
The following dialog box appears:

F‘! Units properties

a | Mame Elewation [m)
Athena Althea + 2832
Caribou | J
Chipeta .
Frankling Position

Horieon £ AD04'26 6" 105730331
OnzZon-
Horizon W Cory DN7OFE Paste

Littleraven
M anzamalaH I Locked

b ahzanala
M oonzstone Enter LAT LON or QRA Move up
Firata
Tenapin Maove down
Tob ) -
Tartizgo Place unit at cursor pogition

Wl apiti Expart

-~

P

Place curgor at unit position Impart

Style Sart

v Enabled ™ Left @+ Centrz " Right

[~ Transparent
[~ Molabel BackColor ForeColor

Apply style

e

[V Small fart

lcon 16x16 pixels

kil Binn

[ Show only units that are members of a visible network,

e

5) Add the information for all the towers supplied by the WISP data provider, including the
elevation. If provider does not supply elevation, this information can be obtained from Google
Earth.

a. If available, use the Import button to import a Google Earth KML of the tower locations.
Go to the National Map Seamless Server (http://seamless.usgs.gov/) and download elevation
data sufficient to contain the tower locations.
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wl 9  Beyond The Boundaries

a. Atleast the 1/3” NED data is needed. Select this by clicking the Download button in the
upper right of the website and checking the box next to 1/3“ NED.
b. Zoom to the area of interest and use the Download tools to define the area to download:

c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI
GRID, as shown below:

) The National Map Seamless Request Summary Page - Mozilla Firefox E][E|E|

http: ffextract.cr.usgs.gov/\Website fdistreq/RequestSummary.jsp?PR=0&CU=Native 82X =-1.08ZY =-1.08ML=C 7

The National Map Seamless Server
Request Summary Page

You are logged in as Default Seamless User.

Modify Data Request HELP!

Data Extraction Request Pi
Output Parameters Sizf

National Elevation Dataset (NED) 1/3 Arc Second

16INT

EROS Data Center

< #° ™ 4o fankegmail.com

d. Download the data and unzip it.
7) Select File>Map Properties to define the map.
8) Enter a latitude and longitude in the center of the tower locations.
9) Set the size (in pixels) and the size (in kilometers) of the map.
10) Set the directory path leading to the BIL elevation data just downloaded.
11) The dialog box is shown below:
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— Centre — Size [pixel]
AO°DE268.9'N 105°2927 6w Width{pixels) Height [pixels] Extract

ONTOGE [1000 [1000

Latitude Longitude

40,07 |-1DE.491 — Size [km] Cancel

Width{km] Height (k]

| [100.00 [100.00 Top Lef
40°30°29"M
Wworld map | -~ Elewvation data source T0E04447/

Use cursaor position

Drive or path Top layer Top Right

IBIL LI Ic:\geodata\bil\boulder Browse... | AD°3023"N
10475477 %

Enter LAT LON or ORA [More =] | Browse... | Boattom Leit
39°3629"M
- B | 1067 04'44" "
ISeIectaunit j INone —I I [OWs8
Bottom Right
INone LII Browsze. .. | 93529

- _ - 10475471
[~ Adjust units elevation INDnB LI I Browse. .. |

[~ Merge pictures

Select a city name

Resolution
[ Ignore missing files Biottom layer 100.0 m/pisel

IV Farce gray scale Initialize matrix with elevation (m) [0 324 arcsesond

12) Click Extract.
13) The elevation data is rendered as a hill shade, as shown below:

[N ..\default.net - Radio Mobile - [..\default. tif] (=13}
D] File Edit View Tools Options Window Help =}
OCE@XRR €a@es 0w

|

[40°05'34"N 105°17'13"W =673 Y=461 1724.1m

14) Select File>Network properties from the main menu.
15) Create a new network and enter in the frequency range under the Parameters tab, as shown
below:
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e

Default parameters Copy Met | ‘ Cancel ‘ 0K

Ligt of all nets

MHednet
Jade Parameters ‘ Topology | Memberzhip | Systems ‘ Style
COuray

Ot obile

Net name Surface refractivity [M-nitz) W
|Nedemet

Ground conduchivity [5/m]
Minirmurn frequency (MHz) | 2400 0.005

M asirnurn frequency (MHz] [2400 Relative ground permittivity ,15—

Paolarization Clirnate

&+ Vertical " Harizontal Equatarial

Made of variabilty Continental sub-tropical

+ Spat % of lime l_ Maritinie sub-tropical
" Accidental

% of locations Desert
" Mabile

% of situations [70 Continental temperate
(" Broadcast

M aritime temperate over land

Maritime temperate over sea

16) Leave all the other values as they appear, and select the Systems tab.
17) Create enough systems to cover all the varieties of equipment in the provider network. This will
include the antenna type, height and line loss, as shown below:

B8 Networks properties

Default parameters Copy Met ‘ ‘ Cancel ‘

Lizt of all systems

O

Parameters ‘ Topology | kemberzhip ‘ Sysztems ‘

|EI'| j |Se|ec:t fram Fadiozys01.dat

Suystem nane |Dmni

Transmit power [Watt] [100 [dBm] |5U—
Receiver threshold ] 1 dBm) 107
Line loss [dB] l'li [ Cable+cavities+connectors |
Arntenna type - Wiew
brtenna gain (dB) 15 (dBd] [1285
Antenna height [m) |9— [ Above ground |
System Additional cable loss [dB/m) [0 [If antenna height differs |

Add to Badiosys01. dat Remove from Radiozys01.dat
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18) Now click on the Membership tab, and assign the individua

N

The Boundaries

W' ngl}dOADMAP

| towers to their respective systems,

providing the azimuth for non-omnidirectional antennas, as shown below:

I3 Networks properties

Diefault parameters
List of all nets

| Copy Met |

‘ Cancel ‘ 1]

Jade Parameters

M ednet ‘
Ouray

Topology ‘ Membership ‘ Systems ‘

Style

CObobile

Nedernet List of all umits

tember of Hedemet

R

v| Chipeta

| Frankling

| Harizon-E

| Horizon
| Littleraven
v| Manzanala-H
| Manzanalay
v| Moonstone
| Firata

w| Terrapin

| Tobago

W Turtle

| W apiti

19) Click OK.

ole of Athena

| Command

[~

System

0

[~

Antenna height [m)
f* Spstem

" Other

Antenna direction

=l
Eleration angle 7]
[

|Fised )
Azimuth 7]
]

View pattern

20) Select Tools>Radio Coverage>Combined Cartesian from the main menu.

21) Complete the dialog box as shown below, providing the Maximum Range from the highest tower
beam radius supplied by the provider.

22) Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of
granularity), as shown below:

@& Combined cartesian Radio coverage

Fixed unit(s)
W apiti

M obile: urit

Draw

| Althea
W &thena
| Caribou

Antenna pattern
In e

[Aithea

etwork

Cancel

| Chipeta

w| Frankling

w| HorizonE

w| Horizon-
W Littleraven
v Manzanala-H
W Manzanala
! Moonstone
| Pirata

w| Terapin

w| Tobago

‘Na

v

[ Draw pattern

View patten

Antenna height [m]
9

. Backealor

Si
&+ S-Unit
" dBm
o

Link Direction
{* Maohile Rx
" Mobis Tx

Draw size [pivels)

e

dermet

Use network antenna settings

Save raster data to file [TXT]

Save raster data to file [SIG]

Save also units not selected

Comnplete. way

Save coverage pictures in “frames" directory

M awirum range (km]
ol
~

ignal range to draw
I~ Best unit

2

™ Metwork style

" dBpvm

I Rainbow

El
=]

Load settings

Save settings

Load data

Mode

All picture

’7
. Colar

[~ Sold

23) Set the Signal range to draw to S-Unit and type 5 in the From (>=) box.

24) Click on Draw. See below.
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"
I ..\default.net - Radio Mobile - [..\default.tif
[l Fle Edt View Tools Options Window Help

cE@R% eaaes o0

[40°05'53"N 105°1510"W X=702 =455 1627m

25) Save the resulting image as a TIF by selecting File>Save Picture as.
26) Open ArcMap® and load the BIL elevation data you used in Radio Mobile.
27) Load the TIF image you created and georeference it using the corners of the BIL data.
a. The corners of the data can be seen in the TIF image.
28) Follow the georeferencing directions from the Coverage Area—PDF/JPG/Other Image Format
section below.
29) Use the Georeferencing Toolbar to Update the Georeferencing for the TIF dataset.
30) In ArcToolbox®, select Data Transformations>From Raster>Raster to Polygon and input the
georeferenced TIF you just created, as shown below:
31) Open the resulting polygon feature class for editing using the Editing toolbar in ArcMap® and
clean up as necessary.
32) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created above into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
|Prquame |tring] =Monex
DBAMame [ztring] <None>
| FRN [int] <None>
| GeogUnit [string] =Monex
_| GeogUnitiD [string] <None>
| TransTech [short int] <Mone>
| MaxAdvDown [short int] =None=
| MaxAdvUp [zhort int] <None>
ARPU [float] <Mone>
SWNomSpeed [floatl =None=

e. Click Next, then Next again, then Finish.
33) In ArcToolbox®, go to Data Management Tools>General>Append.
34) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

FEX
Input Datasets e

| = @ |

C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\service_area_bb. .. +

Target Dataset

| C:'\Working'Broadband \ProviderData\Columbine\Columbine. gdb\bb_cov
Schema Type (optional)

Field Map {optional)

CK | Cancel Environments...| Show Help == |

35) Leave the Schema Type as TEST.
36) Click OK.
37) In ArcMap®, open bb_cov for editing and manually input associated attribution.
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LINEAR DATA

TIGER® STREET SEGMENTS—LIST, SPREADSHEET OR GIS DATA

In the event that the provider supplies TIGER® street segments in list or spreadsheet format, the
steps are as follows:
1) Join TIGER® road segments to 2000 census blocks feature class using one of two methods based
on how the data is provided:
a. Ifthe TIGER® data is provided with a Census Block ID, then join the segments to the Census
Block geometry based on that ID:
(i.) Load both datasets into ArcMap®;
(ii.) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join;
(iii.) In the dialog box, select the TIGER® road segments data and the proper attribute fields
for joining, as shown below:

-
Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

|J0in attributes from a table

1. Choose the field in this layer that the join will be based on:

|BLkIDRPOD =

2. Choose the table to join to this layer, or load the table from disk:

[ TIGER Streets =] ﬂ

[¥ Show the attribute tables of layers in this list

3. Choose the field in the table to base the join on:
-

Join Options
* Keep all records

All records in the target table are shown in the resulting table.
Unmatched records will contain null values for all fields being
appended into the target table from the join table.

" Keep only matching records

If arecord in the target table doesn't have a match in the join
table, that record is removed from the resulting target table.

About Joining Data Ok | Cancel

(iv.) Click OK.

If the data provided is a list containing TLIDs, then join to the TIGER®/Line data using the

TLID, and use a spatial join to associate the TIGER® segment with the coterminous block

based on the block ID:

(i.) Load both datasets into ArcMap®;

(ii.) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join;

(iii.) Select Join data from another layer based on spatial location from the dropdown
menu;

(iv.) Complete the dialog box, as shown below and click OK.
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Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

1. Choose the layer to join to this layer, or load spatial data from disk:

[€> TIGER Streets | ﬂ

2. You are joining: Lines to Polygons

Select a join feature dass above. You will be given different
options based on geometry types of the source feature dass
and the join feature dass.

{* Each polygon will be given a summary of the numeric
attributes of the lines thatintersect it, and a count field
showing how many lines intersect it.

How do you want the attributes to be summarized?
[ Average [~ Minimum I Standard Deviation
[~ sum ™ Maximum [~ variance

Each polygon will be given all the attributes of the line that is
dosest to its boundary, and a distance field showing how
dose the line is (in the units of the target layer).

MNote: A line faling inside a polygon is treated as being dosest
to the polygon, (i.e. a distance of 0).

3. The result of the join will be saved into a new layer.
Specify output shapefile or feature dass for this new layer:

|C:"-.Working"-.Broadband"-.Temp"-Join_OLﬂput_5.sh|:

About Joining Data

Export joined records into a temporary feature class.

If joined Census Block geometry is confined to one specific area, then dissolve blocks into one
record. If joined Census Block geometry is distributed throughout a particular State, then dissolve
sub-selections of census blocks for each county.

a. Use the County FIPS code to dissolve by county.

b. In ArcToolbox®, select Data Management Tools>Generalization>Dissolve.

c. Complete the Dissolve dialog box, as shown below:
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* Dissolve

Input Features

| blocks_Lrm

Output Feature Class

| C:\Working‘\Broadband\BaseData'blocks_LITM_Dissolve, shp
Dissolve_Field(s) (optional)
OFmo

OstaTerrao
COUNTYFPOO
OracTceDD
OsLockcenn

O sLkIoFron

O rnamenn

Owmrrccon

Mirnn

<

Select All | Unselect Al
Statistics Field(s) (optional)

Statistic Type

v

oK | Cancel | Environments... | Show Help =>

d. Click OK.

4) For each dissolved region, open the feature class for editing using the Editing tool in ArcMap®
and remove unnecessary slivers and other small holes. For general guidance on editing features
in ArcMap®, see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf
In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created above into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click on the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
|Prquame |tring] =Monex
DBAMame [ztring] <None>
| FRN [int] <None>
| GeogUnit [string] =Monex
_| GeogUnitiD [string] <None>
| TransTech [short int] <Mone>
| MaxAdvDown [short int] =None=
| MaxAdvUp [zhort int] <None>
ARPU [float] <Mone>
SWNomSpeed [floatl =None=

e. Click Next, then Next again, then Finish.
6) In ArcToolbox®, go to Data Management Tools>General>Append.
7) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

FEX
Input Datasets e

| = @ |

C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\service_area_bb. .. +

Target Dataset

| C:'\Working'Broadband \ProviderData\Columbine\Columbine. gdb\bb_cov
Schema Type (optional)

Field Map {optional)

CK | Cancel Environments...| Show Help == |

8) Leave the Schema Type as TEST.
9) Click OK.
10) In ArcMap®, open bb_cov for editing and manually input associated attribution if necessary.
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POLYGONAL DATA

COVERAGE AREA—PDF/IPG/OTHER IMAGE FORMAT

In the event that the provider supplies coverage area data in some image format such as PDF or JPG
format, the steps are as follows:
1) Ifin PDF format, open in Adobe Acrobat and Save As... JPG format.
2) Openthe JPG image in ArcMap®.
3) Add the required base map vector data for georeferencing.
a. This generally will be either the CDOT data or TIGER® data.
4) Change the coordinate system of the data frame to the desired end coordinate system.
5) Zoom to the general location of the JPG map image.
a. Thisis the location based on the vector data, not the JPG image itself. For example, if you
know that the JPG image represents an area around the town of Limon, zoom to the town of
Limon in your vector data.
Open the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main
menu bar.
Using the Georeferencing toolbar, select Fit to Display; results are shown below:

aPsitsntegs < 8 B B G 3
R P F L T E I IEET:

=

e Ao -vlmmm
8) Use the Control Point button "Z'- to add control points to the map.
9) Use common points in the base dataset and the JPG image.
a. For example, find major street intersections, county/city boundaries, etc.
b. Try to distribute the points more or less in the four corners on the image for the best
transformation.
10) Click on the location on the image first, then click on the corresponding location on the vector
database map, as shown in the image below:

Version 2.0 September 2011 Author: Kristin Rousseau
Page 40




BROADMAP

Beyond The Boundaries

v
= _provider_data_processing_2.mxd - ArcMap - Arclnfo

Fie Edit View Bookmarks Insert Selecton Tools CHIM Window Help

= =

Georeferencing

30 Analyst ¥

B 2

Commuricomm _Cov_100805_1_Pz =

[1:9.403 Y & O Y K e v
Layer G- A ArcPad Data Manager > 45 3% B | B | @

| B @ | wokpov| | /I EBE-OE ES @ B Y Y

= ~ =l

+

.

<

Drawing ¥ R

11)
12)

= £ Layers
= & bbirless_tmabie

[
= O Columbine
= [ secom_tower_locations
= O communicom_coverage _area
# O nunn_coverage_area
= [ Web Map Service BLM_MAP_PLSS
# [0 Munn Broadband Map w middie mile
# [ web Map Service BLM_PARCELS _wn
& [ NAIP_UTM13
= O columbine
.
= O Big_sandy
.
= O Geocoding Result: Geocoding_Resut
.
= [ Dubois_CORT_paints
.
= O Nedernet_WISP_points
= [ geocode_strests Clip
= O geocode_strests

= M HIGHWAYS

= M FCROADS

Display [ Source | Selection | Catalog

M Iroads

~

|

l

onauﬂ J
|0) Arsl [0~ B s ulAr D~ ¢~

-103.226 40,172 Decimal Degrees

O~ A~

After placing each control point, the image transformation will update automatically.
Repeat until satisfied with the transformation.

The transformation may take up to four points, although sometimes only two are necessary.

NOTE:

13)

14)

15)
16)

17)

18)
19)

When satisfied with the transformation, select Update Georeferencing from the Georeferencing

toolbar dropdown.

a. This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image
file.

In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider

coverage area, which can be found in Appendix D.

Add the shapefile to ArcMap®.

Using the Editor toolbar, select Start Editing. Set the Task to Create New Feature.

Use the Sketch Tool "? Tlto digitize a new coverage polygon using the coverage area outline
from the georeferenced JPG and add the required attributes manually.

Repeat the above steps for all subscriber speed coverage areas provided.

Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—KML/KMZ

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format, the
steps are as follows:

1)
2)
3)
4)

Use a KML to SHP converter to translate file into an Esri® format.
http://arcscripts.esri.com/details.asp?dbid=15603

Download the script and follow the provided instructions for installing it in ArcToolbox®.
Double-click on the script in ArcToolbox® and navigate to the location of the KML file, as shown
below:
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& Convert KML to SHP

| C:\Documents and Settings'forr\Desktop\Google\fHupton. kml

Feature Type

| PoLYGON

Qutput shapefile

| C:\Documents and Settings\forr\DesktopGoogle\fiupton_kml_to_shp.shp

oK | Cancel | Environments...| Show Help == |

5) Add the new shapefile to ArcMap®. Repeat for all KML files provided.
6) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—CAD DATA

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:

1) Transform the CAD dataset into an Esri® format.

2) http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datase
ts

3) It may be necessary to contact the provider first to determine the coordinate system of the CAD
data.

4) If the CAD data is not in a standard coordinate system, it may be necessary first to use ArcMap®
to georeference the CAD data to a known coordinate system.

a) Todo so, follow the instructions provided above in Coverage Area—PDF/JPG/Other Image
Format.

5) In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider
coverage area, which can be found in Appendix D.

6) Add the shapefile to ArcMap®.

7) Using the Editor Toolbar, select Start Editing. Set the Task to Create New Feature.

8) Use the Sketch Tool ‘? Tlto digitize a new coverage polygon using the coverage area outline
from the georeferenced CAD file and add the required attributes manually.
9) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—GIS DATA

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:
1) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class either created above or supplied by the provider into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click on the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
|Prquame |tring] =Monex
DBAMame [ztring] <None>
| FRN [int] <None>
| GeogUnit [string] =Monex
_| GeogUnitiD [string] <None>
| TransTech [short int] <Mone>
| MaxAdvDown [short int] =None=
| MaxAdvUp [zhort int] <None>
ARPU [float] <Mone>
SWNomSpeed [floatl =None=

e. Click Next, then Next again, then Finish.
2) In ArcToolbox®, go to Data Management Tools>General>Append.
3) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

FEX
Input Datasets

| o @

C:\Working\Broadband\ProviderData \Columbine \Columbine gdb\service_area_bb...  ofu

Target Dataset
| C:\Working\Broadband \ProviderData\ColumbineyColumbine .gdb\bb_cov

Schema Type (optional)
Field Map (optional)

oK | Cancel | En\rironments...| Show Help > |

4) Leave the Schema Type as TEST.
5) Click OK.
6) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.

COMPACT POLYGON FROM SUBSCRIBER POINTS

1) Geocode address list using latest State Composite Locator.

2) Verify that your geocoded file has only one TT (Technology Type). If not, export individual
geocoded layers for each Technology Type.

3) For each TT, check for differences in speed values or speed tiers and create separate layers for
each speed value/tier.
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Clean your geocoding results: remove any points that geocode to accuracy levels below ZIP+4
(ZIP centroids, carrier route centroids, etc). Also, verify that outliers with acceptable accuracy
levels are legitimate, i.e., fall in correct city and Zip.
Perform spatial join between county polygons (using stcnyfips field) and the cleaned geocoded
subscriber points in order to carry the county name and stcnty fips.
Summarize the number of subscribers by county and use the subscriber counts by county to
populate the Rate Tier table.
Un-join the county data from the geocode subscribers list.
Create Compact Polygon using cleaned geocoded layer or sub-selection of XtoolsPro—
ConvexHull-DetailedHull option. A sub-selection of geocoded points will be used in areas where
more than one polygon will need to be created for one provider’s service area.
Evaluate output Hull carefully, looking for areas that should not be covered by hull polygon.
a. Ifitis determined that an area or areas should not be represented in coverage area,
manually reshape hull polygon until coverage area is adequate.
When not obvious and as a general rule, manually resolve compact polygon when the
distance between the subscriber points used to define the outer boundary of the compact
polygon exceeds 5 miles . When reshaping the hull polygon, snap to the outermost
geocoded points. See the three figures below for examples.
Compact Hull: Manual Resolution Required

ANe.

CROMSON)
®

),
7))

o

Reshaped
‘Compact Hull =

).
t) @\ \oe "
»

50,

CH0)

Y,

Do

)

Original
Compact Hull

As a general rule if the distance between
the subscriber points used to define the outer
boundary of the compact hull exceeds 5 miles,

manually reshape hull.

o' CIN(
(O0) E O
e &,

!

',
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o> . i = .
Charles Mix County I w Charles Mix County

g;gr —97 ‘m County

Compact Hull needing Compact Hull after
manual resolution - manual resolution -
L

Klngs‘tbnry County] Kingsbury County

& w e

! Bon Homme County [ ) Bon Homme County

10) To attribute the compact polygon, perform a spatial join where your Target Feature Class is the
compact polygon and the Join Feature Class is your geocoded point layer. Export compact hull
with joined attributes and name file appropriately.

11) Append attributed compact polygon to Broadband TT template Feature Class and, if required,
manually input any provider attribution that may not have carried over in the append process.

12) Intersect compact polygon with county boundaries to create unique records by county and use
the state-county-fips field to populate stcty_fips field. Also use the county name field to populate
the BBCov_Name field.

a. Exception: where a provider’s coverage is distributed throughout more than one area of any
given county where the BBcov_Name should be populated using an appropriate city or other
logical name based on geographical location.

13) Export/load into appropriate BB TT model dataset.

CENSUS BLOCKS—LIST OR SPREADSHEET

In the event that the provider supplies census block data in a list or spreadsheet, the steps are as
follows:
1) Ensure block polygons supplied by the provider are 2000 currency.
2) If other currency, convert to 2000 currency before proceeding.
a. Todo this, remove the trailing letter (a, b, etc.) from the block ID.
b. You will now have two blocks that equate to one block in the 2000 block geometry.
c. Delete duplicate block IDs, retaining the higher service tier in each case.
Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells,
colors, borders, etc.
Import the spreadsheet into ArcMap®.
Right-click on the 2000 census block feature class in the layer list in ArcMap® and select Joins
and Relates>Join from the dropdown menu. Join the census block list to the 2000 census blocks
feature class using the block ID and export joined records in a new feature class. The Join dialog
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box and process can be seen above in the TIGER® Street Segments—List, Spreadsheet or GIS
Data subsection.
6) Follow the steps in Census Blocks—GIS Data below.

CENSUS BLOCKS—GIS DATA

In the event that the provider supplies census block GIS data, the steps are as follows:

1) Ensure that the blocks supplied by the provider are in the required data schema and are
complete as far as required attribution.
a. If not, manually enter the required attribution or contact the provider to fill gaps.
If census block geometry is distributed throughout more than one county, then select Data
Management Tools>Generalization>Dissolve in ArcToolbox® and dissolve based on
County/Provider/TT/Speed Tier so that unique records are created for each unique combination.
a. The Dissolve dialog box is shown above in the TIGER® Street Segments—List, Spreadsheet

or GIS Data section.

b. Two examples of undissolved census block polygons are shown below:

YAMHILL COUNTY
Undissolved Census blocks

Y
_?J%Polk County
Provider A= ——7
Srri0 2
Speed Tler 1

Dissolved Census Blocks

will all slivers and holes removed. YAMHILL COUNTY

Yamhill County
Provider A
1710
Speed Tier 1

Polk County
Provider A
TT10
Speed Tier 1

POLK COUNTY

Census block polygons dissolved by county

3) For each dissolved region use the Editing toolbar in ArcMap® to remove unnecessary slivers and
other small holes.
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In ArcToolbox®, select Data Management Tools>General>Merge and merge the processed
polygons into a single layer.
The merged census blocks will need to have the subscriber’s frn field added and populated.
In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class either created above or supplied by the provider into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, the click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:

Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field

[FrovName [string] <None=
DBAMame [string] =None=
| FRN [int] <None>
GeogUnit [string] =Mone>
_| GeogUnitiD [string] =None=
_| TraneTech [zhort int] <None>
| MaxAdvDown [short int] =Monex
| MaxAdvUp [short int] <Nones
| ARPU [fioat] <None>
SWiNomSpeed [float] =None=

e. Click Next, then Next again, then Finish.
7) In ArcToolbox®, go to Data Management Tools>General>Append.
8) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:
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~
Input Datasets

| < & |

C:\Working'Broadband\ProviderData\Columbine\Columbine. gdb\service_area_bb... +

Target Dataset
| C:\Working'Broadband \ProviderDataColumbine\Columbine. gdbbb_cow
Schema Type (optional)

Field Map {optional)

CK | Cancel Environments...| Show Help == |

9) Leave the Schema Type as TEST.
10) Click OK.
11) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.

METADATA TRANSACTIONS

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts
staging environment, the GIS-Analyst runs transactions to compare that fGDB with the one stored on the Core
server to ensure metadata on all changes is recorded.

The steps taken to run transactions on the updated Core database are outlined below:
1) Openacommand line window and run generateTransactions.py:
a. Usage: generateTransactions.py [Core fGDB] [Staging Environment fGDB]
b. Example of command line:
<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb
2) Shown below is an example of the output screen that will be displayed:
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Calculating rec_id field for BBCov_@_BB_POLY_TEMPLATE
value can not he B or less
Troubhle creating the progress meter

Calculating rec_id field for BBCov_18_CenturyLink
K 18 28 3@ 48 LA 6A 78 88 7A@ 188

Merging change: X:“BDIA_BBE_GDEsz~M5_BB_FPOLY_SRU_AREAS _gdbh-~AddPt
Calculating Transaction fields for AddPt

i@ 28 3 48 LA 6A 78 88 7A@ 1848
Goal = 1
W :~BDIA_BB_GDB=“~M5_BE_POLY_SRU_AREAS .gdb~AddPt...changes iz complete.

Your tranzaction FeatureClaszszesz are in:
~smichigan~AllAccess~BDIA_BB_GDB=z_HIST~M5_BE_FPOLY_SEU_AREAS_HIST .gdhb

elapzed time = 2994.4 seconds

3) After the process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb:
a. The transactions scripts records changes at a feature level.

| ArcCatalog - ArcView - MABDIA_BB_GDEs HIST\CO BB _POLY SRV_AREAS HIST.gdb
e—

File Edit View Go Tools Window Help

| E3
Location:

Styleshest:

|M ABDIA_BB_GDBs_HISTNCO_BB_POLY_SRV_AREAS_HIST gdb

5|

b. Shown below is a screenshot supporting the directory structure of the historical fGDB.

— ~

-] AddPt

-[Bl] BBCov_0_POLY_TEMPLATE
BBCov_10_Agate
BBCov_10_BigSandy
BBCov_10_Bijou

/=l BBCov_10_Blanca
BBCov_10_CenturyLink
/=l BBCov_10_Columbine
/=l BBCov_10_Covad
BBCov_10_DuboisTelExchange
.[E BBCov_10_ESRTA
/=] BBCov_10_Farmers
/=l BBCov_10_Glenwood
/=] BBCov_10_HaxtunTele
/=] BBCov_10_Internet_CO
-[Bl BBCov_10_JED

=] BBCov_10_MNunn

/=l BBCov_10_PineDrive
BBCov_10_PlainsCoop
=l BBCov_10_Qwest

/=] BBCov_10_Rico

BBCov_10_Rye
E——

Cortents l Preview ] Metadata ]

MName

Type

Modified

BECov_10_Nunn

[ AddPt
BECov_80_ATT
BBCov_80_Sprint
BBCov_10_DuboisTelExchange
BECov_70_Mobilelnet
BECov_10_Sunflower
BECov_10_Quest
BECov_30_XOComm
BECov_41_Comcast
BBCov_20_XOComm
BBCov_50_Rye
BECov_71_SECOM
BECov_50_Glenwood
BECov_10_Rico
BECov_71_Sanlsabel
BECov_80_Verizon
BBCov_10_Wiggins
BBCov_10_PlainsCoop
BBCov_70_Bijou
BECov_30_Covad
BECov_70_SouthPark

File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class

8/30/2010 &:57:53 AM
11/30/2010 4:49:46 PM
11/30/2010 4:37:35 PM
8/30/2010 9:24:00 AM
8/30/2010 &:21:41 AM
8/30/2010 8:22:48 AM
8/30/2010 8:23:55 AM
8/30/2010 8:25:11 AM
8/30/2010 &:26:18 AM
8/30/2010 &:27:24 AM
8/30/2010 8:28:32 AM
8/30/2010 8:29:39 AM
9/10/2010 10:59:47 AM
8/30/2010 &:32:01 AM
8/30/2010 &:33:21 AM
8/30/2010 9:31:55 AM
8/26/2010 2:33:20 PM
8/30/2010 &:37:43 AM
11/30/2010 4:35:50 PM
11/30/2010 4:36:30 PM
9/10,/2010 11:07:22 AM
8/30/2010 &:42:13 AM

23020010 842,17 AR

Attribution associated with each added/removed/changed feature is tracked, including the

following additional columns appended to the end of each:
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(i.) Commit_by
(1) Records the GIS-Analyst who committed the changes to the historical fGDB.
(ii.) Commit_date
(1) Records the date and time stamp on which the changes were committed.
ii.) Trans_type
(1) This field reflects the type of change recorded;
(2) Categorized by: Adds/Change/Deletes.
(iv.) New_values
(1) Records the new values when a change was completed on a feature. Example:
Name or speed change.
d. MD_Process also is transferred from the edited fGDB to the historical fGDB, which states the
actions completed by the GIS-Analyst.
@Arcfata\ng—Art\ﬁew—‘\BDLA BE_GDBs_HIST\CO_BB POLY SRV ARFAS HIST.gdb\AddPt .

File Edit View Go Tools Window Help

k) x YR =R

Location: ‘M \BDIA_BB_GDBs_HIST\CO_BB_POLY_SRV_AREAS_HIST.gdb‘\AddPt ﬂ
Stylesheet: FGDC ESRI

1.5 CO_BB_POLY_SRV_AREAS_HIST.gdb
[ Addpt md_address md_process ‘commit_date trans_type new_values
BBCov 0. POLY TEMPLATE addBaseBBHetadataFields. py_v1-2, added Jab Mid Mik points back into db per criigen cmabey 872412010 4435 | change
BBCow 10 Agste addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
=0 addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov 10 BigSandy addBaseBBl etadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 22472010 4435 | change
BBCov_10_Bijou e addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
BECov_10_Blanca addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov_10_Centurylink addBaseBBHetadataFields. py_v1-2, added Jab Mid Mik points back into db per criigen cmabey 872412010 4435 | change
BECov_10_Columbine addBaseBEN etadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey @/2472010 4435 | change
BBCov 10 Covad addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov 10 DuboisTelExchange addBaseBBHetadataFields. py_v1-2, added Jab Mid Mik points back into db per criigen cmabey 872412010 4435 | change
BBCow 10 ESRTA 9 addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
S addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov 10 Farmers addBaseBBl etadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 22472010 4435 | change
BBCov 10_Glenwood addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
BBCov_10_HaxtunTele addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov_10_Internet CO addBaseBBHetadataFields. py_v1-2, added Jab Mid Mik points back into db per criigen cmabey 872412010 4435 | change
BECov_10JED addBaseBEN etadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey @/2472010 4435 | change
BECov 10_Nunn L addBaseBBletadataFields. py_v12, added Jab Mid Mik points back into db per critigen cmabey 824210 4435 | change
BBCov 10 PineDrive addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen B2412010 4:43'5 | change
B5Cow 10 PlainsC addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen 8242110 4435 | change
ov.-t_Flainst.aop addBaseBBMetadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen 224720110 4:43.5 | change
BBCov 10 Qwest 200BaseBBH ctadataFields.py_v1.2, added Jab Wid Mie points back into b per criigen B242010 £.43:5 | change
BBCov 10 Rico addBaseBBMetadataFields.py_v1.2, added Jab Mid Mike points back into db per criigen 812412010 4:43:5 | change
BECov 10 Rye addBascBEHctadataFields.py_v1 2, added Jab Mid Wi points back info db per critgen cmabey 872412010 4435 | change
BBCov 10_SandT addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
BBCov_10_Sunflower addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov_10_TDS addBaseBBHetadataFields. py_v1-2, added Jab Mid Mik points back into db per criigen cmabey 872412010 4435 | change
BBCov 10 Wiggins addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
BBCon 20.C ggd addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
ov.al_Lova addBaseBBMetadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey 224720110 4:43.5 | change
BBCov 20 Intemet CO 200BaseBBH ctadataFields.py_v1.2, added Jab Wid Mie points back into b per criigen cmabey B242010 £.43:5 | change
BBCov 20 NewEdge addBaseBE N etadataFields.py_v1.2, added Jab Mid Mie points back info db per critigen cmabey 812412010 4:43:5 | change
BBCov_20 XOComm addBascBEHctadataFields.py_v1 2, added Jab Mid Wi points back info db per critgen cmabey 872412010 4435 | change
BBCov_30_Covad addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
BBCov_30_Intemet CO addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
BBCov_30_NewEdge addBaseBBHetadataFields. py_v1-2, added Jab Mid Mik points back into db per criigen cmabey 872412010 4435 | change
BBCov 30 TWTelecam addBaseBBletadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey B2412010 4:43'5 | change
BBCon 30, X0C addBaseBElistadataFields.py_v1.2, added Jab 1id Mike points back info db per critigen cmabey 8242110 4435 | change
ovatAULomm addBaseBBMetadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey 224720110 4:43.5 | change
BBCov 40_CommComm 200BaseBBH ctadataFields.py_v1.2, added Jab Wid Mie points back into b per criigen cmabey B242010 £.43:5 | change
BBCov 41 Baja aAARas SARLIstarstaFialis mr w19 sAdan lah Wi i nainte hark infn Ak nar ~rinan p—r— APAPMN 447 E | channe
BBCov_41 Bresnan

BBCov 41 Comcast Record: ﬂ j 1 j ﬂ show: [ Al Records (of 29424) Options -
Bacodl begiecom

(i

Conterts Preview | Metadata |

DATA PROCESSING

DATA PROCESSING OVERVIEW

The following subsections detail the steps and layout required to process the service provider data further
to meet NTIA requirements:
e  Weighted Nominal Speed;
e Middle Mile;
Broadband Coverage Template.

Version 2.0 September 2011 Author: Kristin Rousseau
Page 50




gD BROADMAP

t',”' Beyond The Boundaries

WEIGHTED NOMINAL SPEED

The weighted nominal speed is populated in one of the following two ways: subscriber data supplied by
provider or value supplied by provider.

SUBSCRIBER DATA SUPPLIED BY PROVIDER

Where the data provider supplies subscriber speed information, the following formula from the NOFA
is used:
(speed tier-1 in kbps x no. of tier-1 subscribers) + (speed tier-2 in kbps x no. of tier-2 subscribers) + (etc.)
Total average monthly subscribers

Data is initially broken up in the following order:
1) Stcty_fips;

2) Transmission technology type;

3) Subscriber tiers.

VALUE SUPPLIED BY PROVIDER

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be
populated instead of using the NOFA formula. These obtained or calculated values are used to update
the service overview layer.

This can be done manually or by creating a table with the provider’s FRN and average weighted speed

and joining it to the service overview table in ArcMap®.

1) Tojoin, right-click on the layer to join to and select Joins and Relates>Join from the dropdown
menu.

2) Then navigate to the table to join to and select the join fields from the dropdown list.

3) Then open the source table (the table in ArcMap®) and right-click on the header of the Average
Weighted Speed field and select Calculate Field from the dropdown menu.

4) Use the value of the average weighted speed from the joined table.

MIDDLE MILE

Middle mile information generally is provided in spreadsheet or text file format. The process is to take
what is supplied by the provider and translate it into the required data schema.
1) If the data is supplied with address information, follow the process outlined above in Subscriber
Location—Address Data.
2) If the data is supplied with associated XY coordinates, follow the process outlined above in
Subscriber Location—XY Data.
3) Once the datais in GIS format, use the Append (Data Management Tools>General>Append)
command in ArcToolbox® to append the data to the overall middle mile dataset.
4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the
source to the target dataset.
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BROADBAND COVERAGE TEMPLATE

The table below lists descriptions of the fields within the bb_cov layer, which is the interim dataset used

to create the final product deliverable.

NAME

ALIAS

DESCRIPTION

objectid

OBJECTID

Internal Object ID

shape

SHAPE

Internal Shape storage

prov_id

PROVIDER_ID

Unique numeric identifier for each provider

prov_name

PROVIDER_NAME

Unique name for each provider

dba_name

DOING_BUSINESS_AS

An alternative "Doing-Business-As" name for the provider

frn

FCC_REGISTRATION_NUMBER

Provider FCC Registration Number

bbcov_name

BBCOV_NAME

BroadMap Broadband Coverage name

trans_code

TRANSMISSION_CODE

Unique code for the transmission technology type described by
this layer

trans_name

TRANSMISSION_NAME

Name for the transmissions technology type

trans_desc

TRANSMISSION_DESC

Description for the transmissions technology type

spect_code

SPECTRUM_CODE

Unique code for the spectrum [WIRELESS ONLY]

spect_name

SPECTRUM_NAME

Name for the spectrum [WIRELESS ONLY]

spect_desc

SPECTRUM_DESC

Description for the spectrum [WIRELESS ONLY]

mad_dwn_t

MAX_AD_DOWN_TIER

Maximum advertised downstream speed available within given
area (speed tier)

mad_up_t

MAX_AD_UP_TIER

Maximum advertised upstream speed available within given area
(speed tier)

typ_dwn_t

TYPICAL_DOWN_TIER

Typical downstream speed available within given area (speed tier)

typ_up_t

TYPICAL_UP_TIER

Typical upstream speed available within given area (speed tier)

mad_dwn_k

MAX_AD_DOWN_KBPS

Maximum advertised downstream speed available within given
area (kbps)

mad_up_k

MAX_AD_UP_KBPS

Maximum advertised upstream speed available within given area
(kbps)

typ_dwn_k

TYPICAL_DOWN_KBPS

Typical downstream speed available within given area (kbps)

typ_up_k

TYPICAL_UP_KBPS

Typical upstream speed available within given area (kbps)

subs

SUBSCRIBERS

Total average monthly subscribers for this provider for this
technology for this coverage polygon

md_geom

MD_GEOMETRY

Metadata: Comma separated list of source ids from which the
polygon extent was produced

md_exists

MD_EXISTS

Metadata: Comma-separated list of source ids used in
understanding and editing the provider data for this polygon
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DESCRIPTION

MD_WHO Metadata: Name of the editor who last edited this feature at the
time in md_when

MD_WHEN Metadata: Date/time that this feature was last edited

md_process MD_PROCESS Metadata: Comma-separated list of processes used to create
and/or modify this layer

stcty_fips STATE_COUNTY_FIPS State/County FIPS code

rec_id RECORD_ID Compound Key formed from
STCTY_FIPS+"|"+Provider_ID+"|"+Trans_Code+"|"+BBCov_Name

st_area ST_AREA(SHAPE) Area in square decimal degrees
st_length ST_LENGTH(SHAPE) Length in decimal degrees

Provider_Type | Type of Provider Has Subtype (1:Broadband provider as described in the
NOFA,2:Reseller,3:Unknown), default value=1 (New 04/11 Model)

VERIFICATION AND VALIDATION

PROVIDER VALIDATION—PROVIDER PORTAL/PDF MAP REVIEW

Following the collection and aggregation of provider data, the aggregated data is validated by the
provider to ensure it is an accurate representation of their coverage area and supporting broadband
information.

e This validation is completed through the Provider Portal web application, which is a secure
interactive map that displays the provider’s coverage areas and allows the provider to
validate, submit feedback or request changes.

o If changes are requested, then the features on the portal are updated and an automatic
request is sent to the provider to complete the validation process.

Providers that did not use the Provider Portal are asked to validate a PDF map displaying

their coverage area(s). This is accomplished via e-mail notification.

PROVIDER VERIFICATION—THIRD PARTY SOURCE REVIEW

After the provider has validated its coverage areas, a third-party source comparison and analysis is
performed.
e Where anomalies or discrepancies are identified, a “SCAN” point is dropped and descriptive
comments are applied to be reviewed later with the provider.
e During the provider review, the map is displayed along with the “SCAN” points and potential
refinement is completed based on input from the provider.
The table below shows third-party sources used:

THIRD-PARTY SOURCE NAME SOURCE TYPE VERIFICATION TYPE

InfoUSA Consumer and Community Anchor Institutions;

Business Listings Can also be used for demographic information
supporting the State websites.

Pitney Bowes (PBBI) Exchange Info Plus Exchange datasets are used to verify the following
(Central Office Transmission Technologies (TT):

Locations) Asymmetric xDSL (10), Symmetric xDSL (20), Other
Copper Wireline (30), and Optical Carrier/Fiber to the
End User (50).
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THIRD-PARTY SOURCE NAME SOURCE TYPE VERIFICATION TYPE

Media Prints Cable Boundaries Used to verify the following TT:

Cable Modem—DOCSIS 3.0 (40) and Cable Modem—
Other (41).

American Roamer Wireless Coverage Used to verify the following TT:

Patterns (EVDO, Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
GPRS, WISP, HSPA) Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80).

ComSearch Wireless Spectrum Used to verify the following TT:

Holdings and Tower Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Data Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80).

ASSIGNING CONFIDENCE VALUES

All findings and results from the abovementioned validation and verification activities, plus internal
peer quality reviews, are captured and tracked in a Validation table (see example on the following
page) and form the basis of the confidence value assigned for each provider and then each
technology.

CONFIDENCE VALUE | DESCRIPTION

0 Coverage area has not been reviewed.
10 Extremely Low:
Single Source QC.
20 Very Low:
Needs additional validation\verification.
30 Low:
Even with validation\verification, coverage still is suspect.
40 Acceptable:
Confirm with State prior to shipment.
50 Meets requirements to be included in shipment.
60 Moderate:
Meets NTIA/State’s standards, representative of Technology Type (TT).
70 High:
Accurate representation of coverage based upon TT.
80 Very High:
Multiple validation\verification with most third-party sources.
90 Extremely High:
Multiple validation\verification sources.
Perfect:
Multiple validation\verification sources, with complete alignment with
sources and ground truth verification activities.

The Validation table is maintained as updates or changes occur for each provider, down to
technology type, with the overall goal to improve the confidence values and overall map
representation. An example of the Validation table is shown below:
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| COMNDENCE_CODE | PROVIOEA1D | PRER G | PROVIDEA,GE | THIRD_PARTY, VERICATION | Thiko_ PARTY 10 49
0 g 0 %

COMMUNITY ANCHOR INSTITUTION (CAl) DATA

DATA COLLECTION

The CAl data was initially collected from the State to create the baseline inventory. All location
information and broadband coverage data supplied also was ingested into the data deliverable.
Additional collection of CAl information was done via data mining and/or webscraping to build out
the inventory further. For example: Collection of additional CAls and location information.

The State-agency-provided CAl inventory was comprehensive but the challenge is collecting
broadband related data: service provider(s), technology and speed data for each CAI. Availability of
the CAl portal has not significantly increased submission of this data. Additional promotion to CAls to
use the CAl portal will be needed to increase this data for subsequent deliverables.

INSTITUTION DATA

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet
format. The general process for incorporating this data is as follows:
1) If the datais provided in Excel or some similar format:
a. Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.
b. Standardize the address format as defined in the staging CAl database.
c. Ifthe spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY
Data tool in ArcMap® to create a spatial data layer.
If there are only addresses, then follow the geocoding steps outlined above to create spatial
data points for each of the institutions.
(i.) Institutions that do not geocode based on the TIGER® 2009 dataset will have to be
located manually using Google Maps, Google Earth or some other information source.
If the CAl source data is in GIS format, add the Latitude and Longitude fields and use the
Calculate Geometry tool to populate them, using the WGS 84 coordinate system.
Using ArcCatalog®, load the new data into the staging CAl database.
This database is ready for the makeDeliverable.py script to process the information into the final
State and NTIA deliverables.
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COMMUNITY ANCHOR INSTITUTION (CAI) PORTAL UPDATES

A web application has been released to allow for further data collection and validation of anchor
institution location information, broadband coverage and speed test data. Information collected from
the CAl Portal is then ingested into the overall inventory and will be compared later against the
provider coverage areas mapped to locate any potential discrepancies.

PRODUCT EXTRACT

PYTHON SCRIPTS

The following subsections make use of Python scripts. In general, to use a Python script you must have
Python installed on your computer. To download the latest version of Python, go to
http://www.python.org/download/ and download the latest stable version. As of August 2010, this was
version 2.7. Once this is installed, the general way to run a script is to type the following at a command
prompt: C:\Python27\python.exe C:\<location of script>. Many of the scripts provided have environment
variables that must be set before they can be run.

The Python code for BroadMap’s product extract has been incorporated into a Hudson Cl System, which is
detailed in the Process Operation and Monitoring section of this document. This was a process
improvement activity so that all processes can be monitored, controlled and will contain historical
tracking on each process.

PRODUCT EXTRACT PROCESS

NOTE:
Specific Python scripts are called out in red font in the subsections below.

The MapConnectTNI product extract process, makeDeliverable.py, uses the BB_Cov and
BROADMAP_POINTS interim datasets to create the following layers according to the current
specifications:
e BB_Service_Road_Segment
o This layer contains all broadband services associated with specific street segments for census
2000 blocks larger in area than two square miles.
BB_ServiceCensusBlock
o Contains all broadband services associated with census blocks of no greater than two square
miles.
BB_Service_Wireless
o This layer contains all wireless services not associated with specific addresses.
BB_ServiceOverview
o This layer contains subscriber-weighted nominal speed for each provider's service area at a
county level and is meant to act as a summarized view.
BB_ConnectionPoint_MiddleMile
o This layer contains middle-mile and backbone interconnection points.
BB_Service_CAlnstitutions
o Broadband Service at Community Anchor Institutions (CAI).
o Community Anchor Institutions consist of schools, libraries, medical and healthcare
providers, public safety entities, community colleges and other institutions of higher
education as well as other community support organizations and entities.
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Because of a NTIA model change for the October 2010 data deliverable, an addition to this code was
created to support both models in case a comparison is later desired or a request is made to revert to the
original model. This script name is bdia2ntia.py and creates the following layers in addition to the layers
mentioned above, rolled up to NATL_Broadband_Map.
e BB_ConnectionPoint_LastMile
o This layer contains last mile infrastructure points, which is populated only if data cannot be
provided at a more granular level.
BB_Service_Address
o Represents broadband availability for service address points. Address Point availability refers
to those individual addresses at which each facilities-based provider of broadband service
can provide broadband services of minimal characteristics within 7-10 business days.
State_Boundary
o State boundary supporting topological validation of point feature classes.
NATL_Broadband_Topology
o Supports basic topology quality checking. Example: No CAls or Middle Mile points outside of
the State boundary.

The following process flow provides a view of how the Core fGDB is extrapolated to the NTIA final
deliverable via the makeDeliverable.py script. Following that, the bdia2ntia.py script is run, which limits
what is placed in the final layers based on the NTIA modeling standards.

The product scripts and supporting extract were originally created separately per request, in case data
model comparisons were to be completed.

PRODUCT STATISTICS

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py)
extracts the following information supporting that product deliverable.
e  Provider Statistics:
o Collects all provider information, listing by Provider Name.
o Provides output of FRN.
o Counts the number of features supported within the following layers:
Census Block;
Street Segment;
Max Upstream;
Wireless Services;
Infrastructure Points.
o These updates were made to support the Data Package required to accompany every NTIA
product deliverable.
e  Community Anchor Institution (CAl) Statistics:
o Breaks down CAl to the eight categories:
1: School: K through 12;
: Library;
: Medical/Healthcare;
: Public Safety;
: University/College;
: Other Government;
: Other Community non-government;
None: Unknown Category. In cases where this occurs, further investigation is completed
prior to product shipment to ensure all CAls are categorized accurately.
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o Reports out the following counts:
= Total CAls within that category;
=  Total CAls that contain partial BB coverage. Contains any of the following information for a
given CAl: BB Subscriber, Transmission Technology, Speed Down Speed Up;
=  Total CAls that contain full BB coverage. Contains all of the abovementioned BB information
for a given CAL.
The output of this script is two CSV files: AnchorlInstitutions.csv and Providers.csv. These files then can be
inspected to ensure that there are the expected number of CAls and providers for every release.

QUALITY ASSURANCE

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase and
on the final product. For scheduled product releases, a test product extract and subsequent manual and
algorithmic QC run is completed along with a release review. The product specifications, project status reports
and previous product release notes are used as references throughout this review.

The following parameters are tested using the methodology listed below each:
e  Product Deliverable Format:

o Correct names and format of data deliverables.
=  BDIA_QC_SUITES (please see below for details).
Correct Projections/Datum.
=  Manual interaction with product.

Metadata Present and Correct.
=  Manual interaction with product.

Table Structure:

o Allrequired tables included.
= BDIA_QC_SUITES.

o Extraneous tables identified.
=  BDIA_QC_SUITES.

Field Structure:

o Allfields included.
=  BDIA_QC_SUITES.

Extraneous fields identified.
= BDIA_QC_SUITES.

o Correct field names, types and widths.
= BDIA_QC_SUITES.

Field Domains:

o Values in all tables are constrained to the specified values specified:
=  This action is accomplished via BDIA_QC_SUITES and manual review of the product;
=  This tends to identify project completeness issues as fields with a null value are identified.

Geometric Representation:

o Identify if all layers have the correct geometric representation:
=  Manual review of the BB_ServiceOverview layer;
= Dependent on NTIA and client requirements.

Geographic Extent:

o Product includes the necessary Geography associated with Product?
=  Manual Review—ArcGIS®.

o Isthere extraneous geography included in Product?
=  Manual Review—ArcGIS®.

e Completeness:
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Products contain the expected amount of data?

= Manual review of product statistics relative to weekly State reports and defined expectations.
e  Accuracy:
o Product meets the stated accuracy requirements for the deliverable?
= Sampling procedure to manually review source material to resulting product;
= Provider Validation;
= Verification using Third-Party Data;
= Verification against reality, where applicable.
Data Regression:
o Any unexplainable data loss or change?
= This action is accomplished by comparing results within product statistics script
(BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product.
Confidentiality:
o Any unauthorized confidential information included in the delivery?
= Review of NDAs and delivery expectations.
Prior Issues Resolved:
o Have expected internal issues been resolved?
=  Manual review of data against previous product release notes.
o Have agreed-upon customer issues been resolved?
=  Manual review of data against previous product release notes, status report and client feedback.
Delivery Medium:
o Has the product medium been verified?
= Manual review.
All files present.
= Manual review of SFTP site to ensure all files are copied correctly, including file/directory size.
Correct location.
=  Manual review—confirmation of SFTP link, username and password.

QC SUITE

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These
scripts are all run in concert and are called from the test_runner script and the test_ BDIAProductGDB
script.

CONFIGURATION

These scripts establish the configuration for the test_ BDIAProductGDB script, which is the core of the
QC Suite.

update_test_config

active_config

config_ PROCESSO1_automated

config_PROCESSO1_manual

set_active_config

LIBRARIES

These scripts provide additional functionality that is called from with the test BDIAProductGDB
script.

bb_unittest_fixture

bbcov_structure

BC_XmlWriter

file_folder

search_and_replace
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unittst_fixture
validate_BB_DB
validate_BB_GDB
xmlrunner_gui

QC SUITE

This is the core script for performing automated QA/QC on the interim and final data deliverables.
test_BDIAProductGDB

OTHER

These scripts perform other functions detailed below:

test_runner—this is the main script that runs all the other QC scripts and imports all the necessary
scripts and libraries.

which_build—this determines the current build and passes information to the configuration scripts.

PROCESS OPERATION AND MONITORING

Product Extract, makeDeliverable.py and bdia2ntia.py, is run within BroadMap using a platform called Hudson
that has been enhanced to support BDIA product extraction, process monitoring, as well as product validation.
The same platform can be planned for implementation for the State, if desired.

Below are examples of the product create, product validation, product statistics and monitoring processes
that are managed within the BroadMap Hudson CI-System. All of the abovementioned Python scripts, with
the exception of metadata transactions script, are run via this system.

BDIA PRODUCT CREATE

Below is an example of the main page where the type of product build can be selected.

% BROADMAP
L

All | BDIA Product Create | BDIA Product Validation | BDIA_Sourcing | Core Database Validation | FCC Product Validation | MCE Product Validation | Map Connect Enterprise | Mesh Creation | Postal Product Create | Postal Product Prep | WebPortalPrep | + H

ENABLE AUTO REFRESH

(edit description
s w Job | Last Success Last Failure Last Duration
BDIA Build 12 hr (£197) N/A 12 sec \?}
BDIA Product Validation 2 mo 10 days (2157) i in ')
3 mo 22 days (=81) o in [9)
13 days (£271) in \?}
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Selecting based on the type of process that will be initiated is shown below:

Hudson

Hudson = BDIA Product Create » BDIA ProductCreate

4 Back to Dashboard

0, status

[ changes

I workspace

€ ) Build Now

(\J) CElEtE Protect

. confiaure

&% Build History

@ #123 Dec9, 2010 12:30:00 PM
@ #122 Decd, 2010 9:53:37 AM

when Mideo is complete
@ #121 Dec7, 2010 6:09:02 FM

Running for provider portal update

Running for provider portal update - Test will rerun

Project BDIA_ProductCreate

OR on Alaska

F=
@ Last Successful Artifacts

® bdia2ntia.log &=
® makeDeliverable.log &

(trend) ® robocopy.log &

186KB

000008
| =" Recent Changes
179k8

Permalinks
46KB
® Last build (#123), 4 davs 23 hr ago

SD build for portal test
£119 Dec i, 2010 12:41:51 AM 5K ® Last stable build (#123), 4 days 23 hr ago
hd Leses ® Last successful build (#123). 4 davs 23 hr ago

€O Monthly Deliverable w/ Crit Feedback - Round 2 ® Lot failed build (#1210, 6 davs 18 hr ago
ful build (£121), 6 days 18 hr ago

® |ast unsy

@ #118 Nov 30, 2010 4:58:46 PM 50KB
CO Monthly Deliverable w/ Crit Feedback

Hudson

Hudson » BDIA Product Create » BDIA ProductCreate

4 Back to Dashboard

Project BDIA_ProductCreate

),
O status
% build requires parame

& Changes
@ workspace State R v
State or Territory to Process

Build Now

© Delete Project

#, Confiaure

The Console Output can be reviewed to see the progress of product create. Following the completion of
each product creation process, an e-mail notification is automatically sent to the team.

Hudson EETEN
View 05 clin text

0 » BOIA Product Cregto » BOIA ProductCronte » £117

O Console Output

sar sppeacs ©: be sur of ayme. This can rasult in incsnsisant chask cut Bahavir

\ 1 \_B5_CDBs\CO_S5_SOLY_SRV_AREAS.gdb “D:\ldson\3ebs\BDIA Froducst: a"\CO_88_FOLY_SH_AREAS geb /MIR /105:rcbacopy-log

1eg

\Bsdsom\ Jobs\SDIA_PraduceCraesce\uorkspace>if ersorieval 18 eche BOSOCOSY RETURN CODE 3 *44EATAL IRRCHS+S & goro I3ROR
errorievel 15 echo ROBOCOPY AETURN CODE 3 FAIL XTRA COPY & gote ERROR

BDIA_|
\hudsan\ )cbs\EDTA_DraduccCrasce\varkapaces: COPY FETURM CODE 2 FAIL MISM XTHA ¢ gate ERROR

'Y RETURN CODE 3 FAIL MISM COPY & ERROR

\hudsen\ 36b\BDIA_PreductCrescaivarkapaces! ¥ RETURN CODE 3 FAIL : moR

¥ RETURN CODE 3 FATL coPr & goto ERRR

LETRA & goso mRROR

\hudsan\ J6ba\BDTA_roductCrascelworkapaces: 1 S acho R0B0COPY RETURN CODE 3 FAIL COFY & goto ERNOR

5012 | arrorieval @ scho ROBOCOPT ASTURN CODE 3 FAIL & goto ERROR

All processes run via the BroadMap Hudson CI-System are stored for historical reporting. Each process can
be reviewed, including the Console Output and Build Artifacts from that run.
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Hudson
Hudson » BDIA Product Create » BDIA ProductCreate » 161
4 Backto Project
O, status
"= Changes
B console outout
parameters
[ T2 this build
[] pennstream buiid view
8 revious Build

Bp et Build

() Build #161 (Mar 28, 2011 9:44:40 PM)

OR Pre-Release Build

Build Artifacts
- S

© makeDeliverable.log &
© robocopy.leg &

oo
| Revision: 3099
No changes.

=

¢

Started by user anonvmous

Delete this buid
Started 1 day 1 hr ago

Took 3 hr 31 min on Alsska|

(Zedit description|

Version 2.0

September 2011
Page 62

Author: Kristin Rousseau




ma

PRODUCT VALIDATION AND STATISTICS

Once the product creation process is complete, Product Validation and Statistics are then initiated. These
support the BDIA_ReleaseNotesStats.py script and the BDIA_QC_SUITES scripts detailed above.

All statistics and reports are stored for historical review with the capability to place violation criticality on
each quality control check, allowing the identification of errors because of project status/completeness
verses project correctness. Example: Typical Speeds populated.

Below is an example of the report provided based on various control points running over a specified
period:

Hudson B seareh

Hudson » BOIA Product Validation » BDIA Product Validation €O ENABLE AUTO REFRESH

4 Backto

0 status

"2 Changes

Dashboard

Project BDIA_Product_Validation_CO

This job checks db integrity on file GeoDatabase.

[l workspace Record Error Monitor

() Build Now 250,000
O Delete protect

., Configure

B Blots

Build History (trend)

#271

2270
=260
268
2267

266
2265

200,000

150,000

100,000

Total Record Eror Gount

50,000

Dec 1, 2010 8:16:58 AM 55MB
Final QC on SOW monthly CO product
Nov 18, 2010 9:56:35 AM 55MB

|

(Aug 20
(Aug 21
(Aug 22
(Aug 23
(Aug 27)
(Aug 30
Mov 18)

Nou 18, 2010 8:49:08 AM 79k8

#244 (Aug 10)

g

<
g8

#2385

254
w258
w250
w257
#20s
200
200
#2s8
#270

Nov 18, 2010 9:22:49 AM 79KB ¥ W W
Bui

Nov 18, 2010 9:08:05 AM 77k8

QC on SOW monthly CO product -4 BB_Senvice_CAlnstitutions Error -+ BB_Senice_Wireles Error ~+-BB_Senice_CensusBlock Error

Sep 29, 2010 11:12:09 pM "
< are ~4-BB_Senice_Road_Segment Eror - BB_Sewice_Overview Error

Sep 26, 3010 11:17:56 BM 50KB
€0 validation build Latest Stats Regression: Link
Sep 24, 2010 12:22:26 PM 78KB Latest Provider Regression: Link
Aug 31, 2010 1:29:41 PM 48KB Latest Error Regression: Link
Aug 31, 2010 1:17:05 M 65K (Zedit description

edit description
Auq 31, 2010 12:22:02 PM 102M8

®Disk Usage: Workspace 23948, Builds 1GB
Aug 30, 2010 8:25:39 AM 110MB r =
(B orkspace
Aug 27, 2010 1:33:49 AM 110MB Test Result Trend

Aug 24, 2010 5:00:41 AM 108MB

Aug 23, 2010 5:00:41 AM 108MB @

Last Successful Artifacts

* BDIA STRUCTURE OC.log &
® SB QC OUTPUT.7z &=
Aug 22, 2010 5:00:41 AM 108MB ‘@ SBDD TRANSFER counts.csv -
Aug 21, 2010 5:00:41 AM 108MB ® SBDD TRANSFER counts diff.html &=

‘® SBDD TRANSFERAnchorlnstitutions.csv &=
Aug 20, 2010 5:00:41 AM
41920, 2010 2:00:21 AN rosme + SBDD TRANSFERAnchor] diff.html &=
Aug 19, 2010 5:00:41 AM 108MB ® SBDD TRANSFERProviders.csy 4-
@ SBDD TRANSFERProviders diff.html =

Aua 18, 2010 5:00:41 AM 108MB
1ul'5, 2010 1:47:28 PM a1k8 — §EE 8

) for all F for failures |=#" Recent Changes st show failures) enlarge

Similar to the Product Create process, all results from the process are maintained:

Hudson o)

Hudson » BDIA Proguct validation » BIA_Product Validation CO » £270 ENABLE AUTO REFRESH

# Back iz Proie | Kaap tis budd formver
Status Build #270 (Nov 18, 2010 9:56:35 AM) | oo s |
o Started 26 days ago

(Srad deserpeon 19%% min on master

Started by user anonvmeus

Test Resylt (2 failures / +1)
Dudstntest sutes test BOIAP ProutGDBETorSummary Cinss BD1A STRUCTURE OC SUMMARY.
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Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA
data model or project completion statements. Any errors of concern are communicated ahead of product
delivery and included within the product release notes. Further detail on the Hudson-ClI System
environment can be found by navigating to the following link:
http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson

Hudson

Hudson » BDIA Product Validation CO

4 Back to Dashboard Project name BDIA_Product_Validation_CO
O, status Description <p>This job checks db integrity on file GeoDatahass.
ey <img src=http://vermont: 8080/job/BDIA_Product_Validation_CO/p
= Changes <p>Latest Stats Regression: <a href="http://vermont:8080/job/BDIA_Product_Validation_C0/lastSuccessfulBuild/artifact/SBDD_TRANSFER _t counts diff.html" >Lmk</a><D>
<p>Latest Provider Regression: <a href="http://vermont: 8080/job/BG1A_roduct_validation_Co, DD_Ts _diff.html"> Link p
& worksosce <p>Latest Error Regression: <a href="http://vermont:8080/job/BDIA_Product_validation_CO)/lastSuccessfuluild/artifact/CO_error_summary_diff.htm|
Horsspace ">Link=/az<p>

©) puid now <p>Latest CAI Regression: <a href="http://vermont:8080/job/BD1A_Product_Validation_CO, DD_T! Tnstitutions_diff.html">Link

© Delete Project
7. confiqure Discard old Builds
Days to keep builds

g Bl
&% Build History (trend) Max # of builds to keep 20

if not empty, build records are only kept up to this number of days

#2860  Dec22,20109: ME i not empty, only up to this number of build records are kept

#279 Dec 21, 2010 11
#272  Dec 17,201 12pM MB This build is parameterized
CO SOW deliverable validation
#271 Dec 1, 2010 8:16:58 AM
Final QC on SOW monthly CO product
£270 N 18, 2010 9:56:35

String Parameter

Name TestMethodPrefix

Default Value ppra_sTRUCTURE
=269

268 Description

#267  Nov 18, 20109:
QC on SOW monthly CO product
#266  Sep 29,2010 11:12:00 PM
#265  Sep 26, 2010 11:17:56 PM
€O validation build
264 Sep 24,201012:22:38 P
String Parameter
#263  Aug 3L, 20101:20:41 PM
- N Name GDBLocation
#262  Aug 3L, 2010 1:17:05 PM
#261  Aug 31,2010 12:22:02 PM Default Value //alaska/ReleaseCandidates/CO_20101117-1947
#260  Aug 30, 2010 8:25:39 AM Description

Parent path for the release candidate GDE.

PRODUCT EXTRACT DATA DELIVERY

Product delivery for MapConnectWI Broadband is handled two ways, depending on client requirements:
1) State Submittal:
a. Datais submitted via SFTP site;
b. Product Release Notes and QC Test Report accompany the delivery.
2) NTIA Submittal:
a. Directions for using the NTIA State Broadband Data file submission tool:
(i.) Go to the following website: https://esupport.fcc.gov/statedata;
(ii.) Enter your username and password as provided to you from the NTIA program
administrator;

FCC SUPPORT CENTER
State Data

Broadband State Data Management Tool

Login

Username:* e
LOGIN

(iii.) Click in Upload a file field;
(iv.) Browse to local file for submission using the Browse button. Select file, then select
ATTACH FILE. See example below.
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http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson
https://esupport.fcc.gov/statedata

BROADMAP
Beyond

The Boundaries

FCC SUPPORT CENTER
Broadband State Data Management Tool Alaska (jgeorge@denali.gov) Logout

Upload File | View Files

UPLOAD NEW FILE

* denotes required field

Upload File

Upload File*

[C\Users|20100323142745 _offer20100323 polf | (Brouse..

(v.) Logout/Receipt using the Logout button in the top right of the screen;
(vi.) A receipt of submission is e-mailed to username e-mail address.
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