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1 Overview

The following describes the Data Gathering, Data Integration, Data Validation and Verification and Quality Control
processes utilized to create the Broadband Mapping Project’s April 1%, 2011 data submission.

To support various levels of technical and program knowledge, this white paper supplies both a high level
summary and a detailed process review.

2 High Level Review

2.1 Data Gathering - Providers

Broadband Service Area, Middle Mile Aggregation Points and Broadband Service Overview
The collection of Broadband Service areas, Middle Mile Aggregation points and Broadband Service Overview
information is handled through the following Provider Outreach Process:

e  Build and Maintain an Inventory of Broadband Providers through research and State inputs.

e Update Provider Material that describes the data requirements and logistics for data transfer.

e Update NDA for use in project, where applicable

e Maintain multiple protocols for the provider to submit data, including SFTP technology when desired.

e Conduct one-on-one informational discussions with each provider to communicate the following:
Requirements of this project

o Broadband data required to support the product data model
o Submission protocols available
o Capability to validate how the supplied data is aggregated

e Download/receive Provider Data
e  Establish a repeatable process with Provider. Maintain Provider communication, transaction and data
handling records throughout the project (dates contacted, data received, etc.)
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2.2 Data Gathering - Community Anchor Institution (CAl)

The collection of CAl information is handled through the following CAI Collection Process:

Collect and maintain inventory of CAls through Data Mining, research, and State inputs.
Maintain web-based CAl portal for institutions to add or confirm attribution, location and enter
broadband-specific information.

Upload web-based data to Core Database for standardization.

Perform internal cleansing, such as removing duplicate records, identifying gaps in broadband attribution
and verifying category.

Geocode CAl locations.

Translate Core Database data to deliverable ready format.

Continue engagement with non-responsive institutions.

2.3 Data Integration Process

The data integration and processing mechanisms currently utilized allow for multiple types of inputs and results in

a standardized output that meets the NTIA deliverable requirements. This process is flexible to support data model

changes and project requested enhancements.

Receive inputs from Providers via submission protocols, upload into Sourcing Database and catalog with
provider information.
Review Provider supplied data for completeness and for potential discrepancies that require resolution
prior to processing and flag as necessary.
Categorize input into data type category (addresses, block lists, paper maps, etc.).
Standardize input based on data type within Staging Database.
Create Compact Polygons (CP)—(internal methodology for generating area based feature for coverage in
Staging Database).
Apply broadband attribution to CP, Apply metadata to CP
Perform quality analysis of the CP against the source supplied to identify any completeness or accuracy
issues.
Request additional information from the provider if elements of coverage are missing or contain
discrepancies. This is a second manual quality check to ensure data is complete. Following completion of
CP creation, process steps within Data Validation & Verification occur

o Process coverage area to build the required NTIA data model layers

Process CAl data input into internal standardized format, as mentioned above under CAl Create Product
Deliverable based on NTIA and State-level requirements.
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e Following the creation of the product, process steps within Data Validation & Verification occur

2.4 Data Validation & Verification

To ensure the data collected and processed is as accurate and comprehensive and possible, provider validation and
internal verification activities are utilized. Following the initial mapping of providers’ coverage area and
serviceability claims, additional reviews are performed using the following methods:

e  Third-Party Data Verification: Visually and programmatically compare the coverage against third-party
data.
Pitney Bowes and American Roamer data are used in cases where a coverage area is questionable. All
anomalies identified during this analysis are reviewed with the providers.

e Broadband Provider Validation — Provider Portal Application: Providers are trained on and requested to
use a secure interactive web application to review their current coverage area(s) and supporting
broadband attribution and validate their data or submit change requests to update their data.

All provider change requests go through the Data Integration Process and a review with the provider to
complete validation.

e Confidence Values: All Verification, Validation, and manual quality review results are tracked by provider
/ technology type and stored and maintained within a “Validation” table. A confidence value is assigned,
based on internal assessments of the collected information, to highlight the provider coverage areas
and/or attributions that would benefit from further investigation and/or enhancements.

2.5 Quality Control

Following collection, processing and analysis of the provider and CAl data, the product is checked manually and
algorithmically against the NTIA data model. Some of the items included within these checks are as follows:

e  Format Correctness

e Table & Field Structure
Valid Values

o Including default values, where applicable

Geographic Extent and Topology Errors
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Prior to data submission, another quality control script supplied by NTIA is run. This script,
SBDD_CheckSubmission.py, creates an output in text form that is required to be submitted along with the final
deliverable. All errors must come up clean, unless otherwise specified from NTIA.

Exceptions to the script as noted by NTIA on the SBDD Workspace on 03/25/11 at the following link:
https://sbdd-granteeworkspace.pbworks.com/w/page/38218329/CheckSubmissionExceptions

- Longitude values for States outside the lower 48 (any table)

- CAl results for Transtech, MaxAdUp, MaxAdDown if BBService is ‘No’ or ‘Unknown’

- Overview MaxAdDown, MaxAdUp if 100% of record level data has MaxAdDown or MaxAdUp
populated



https://sbdd-granteeworkspace.pbworks.com/w/page/38218329/CheckSubmissionExceptions
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3 Detailed Process Review

Below is a detailed review of the data collection, integration and quality control points along the broadband data
gathering and mapping process.

Diagram of overall process:
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3.1 Provider Outreach

For the April 2011 data submission, an e-mail notification was sent to all providers with supporting deliverable
dates. The Provider Portal web application was released and training webinars held so providers could use this
application to submit changes to and/or validate their current coverage area(s).

Data was also collected from the providers via e-mail and SFTP, depending on their comfort level to submit data in
time for the April 1 deadline.
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In support the data collection effort, providers that did not timely respond to the outreach were contacted by
phone.

3.2 Outreach Materials

The original provider packet sent via email to the providers included the following documents and files:
1) Letter from the State inviting them to participate in the program
2) Copy of the non-disclosure agreement (NDA)
3) Copy of the Mapping NOFA from the NTIA
4) Copy of the NOFA Clarification from the NTIA
5) Broadband service address example file in CSV format
6) Word document describing service address example file
7) Broadband service block example file in CSV format
8) Word document describing service block example file
9) Broadband service street example file in CSV format
10) Word document describing service street example file
11) Broadband subscriber example file in CSV format
12) Word document describing subscriber example file
13) Broadband wireless coverage area sample shapefile
14) Word document describing wireless coverage area sample shapefile
15) Instructions for downloading, installing, and using the WinSCP secure FTP application

3.3 Outreach Process
The provider outreach process is comprised of the following general steps:

1) Send the provider package and introduction letter to the main point of contact for the provider

2) Follow up with email and call to verify that the main point of contact is correct.

3) If necessary, discuss the NDA further and resolve any redlines.

4) Once the correct primary contact is established, set up a call, if necessary, to learn more about the
provider’s offerings and direct them to the appropriate outreach materials.

5) If providers are unable to be contacted (non-responsive) or indicate that they are not interested in
participating (non-cooperative) mark them as such on the provider tracking sheet. These providers will be
escalated to the state for further action.

6) Asthe providers are collecting the required data, provide instruction on downloading, installing, and using
the WinSCP secure FTP application, if required.

7) Arrange with the providers to transfer the data in whatever way they are comfortable. Some providers
will find regular email acceptable. Others will want to use the secure FTP application.
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8) After data is received and reviewed, it may be necessary to contact a provider for clarification or to
address incomplete data sets. In the interest of building and maintaining relationships, care is given not to
push the provider but to work with it to obtain accurate data in the best possible format.

3.4 Data Collection

3.4.1 Data Transfer Procedures

There are three primary ways data is collected from providers. These are:
1) Secure FTP using the WinSCP application

2) Regular email

3) Mail

3.4.2 Initial Data Review and Quality Assurance

The initial data review and quality assurance process consists of the following general steps:
1) Access the data from the secure FTP site or email

a. If emailed, place copy of original data set in the appropriate provider folder on the secure FTP
site

2) Place copy of raw data on local computer in a working directory.
3) Review data and determine course of action based on type of data received.
4) Ensure data is complete and contact provider to address any gaps.

Note: The goal is to get as many providers as possible to provide subscriber address data in the correct format.
Obviously, this will not be possible with all providers so we will continue to have to process various types of
provider-supplied data.
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3.5 Data Ingestion

3.5.1 Data Ingestion Overview

The following outlines the process steps taken based on the type of input supplied by the data provider:
Point Data

e Subscriber location

e DSLAM location

e  Central Office location

e Broadcast Tower location

Linear Information
o TIGER street segments

Polygonal Information
e Census Blocks
e Coverage Area

Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to append to
the bb_cov feature class. The bb_cov feature class is the interim data set that is then processed using the
makeDeliverable.py Python scrip to create the MapConnect data layers that will be delivered to the state and,
ultimately, to the NTIA. Following are the detailed instructions used in this process.

3.5.2 Point Data
3.5.2.1 Subscriber Location — Address Data

In the event that the data provider supplies subscriber address data the following actions occur:

1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data format.
a) Usually, this has the following columns: street address (number, pre-directional, pre-modifier, street
name, street type, post-directional, and post-modifier concatenated together), city, state, ZIP.
2) Configure the ArcGIS geocoding tool to use the TIGER 2009 streets dataset
a) In ArcCatalog, create a new Address Locater by right-clicking in the white space of the appropriate
directory and selecting New>Address Locater from the dropdown menu.
b) Select “US Streets with Zone” and press OK.
i)  Note: It is likely that multiple Address Locators will have to set up to handle the variety of
provider address data received.
c) Navigate to the TIGER Streets 2009 file and press OK.
d) Fillin the dialog box as seen below:




New US Streets with Zone Address Locator
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Name: [ cO_Geocode_TIGER_2009] Input Address Fields
Besmrio | US Streets with Zone The field containing: is recognized if itis named:
Primary table ] Zone ggdr : auli
ee
Reference data: Delete
| C:\Working\Broadband\Baselata {TIGER _Streets.shp =
%
|v Store relative path names J J
Fields
Matching Options
House From Left: |LFROMADD j
Flace Mame Alias Table... | <None
House To Left: |LTOADD ﬂ
House From Right: |RFROM.-'-\DD j Spelling sensitivity: 80 ————— I)T
- Minimum candidate score: mw —p——
House To Right: |RTOADD ﬂ T
Mini tch = =]
Prefix Direction: |<None> ﬂ SRR s [ 'JT
Prefix Type: | <None> j Intersections
Connectors: &|@ Separate connectors by a
Street Name: [FuLLNAME | l space, e.0. B @, [
Street Type: | <None> ﬂ Output Options
EL: EEE |‘:N°“E> ﬂ Side offset: | 20 in |Feet ﬂ
Left Zone: [z1pL | End offset: 3 % - f————
Right Zone: |ZIPR ﬂ v Match if candidates tie
Qutput Fields
[ Xand Y coordinates [ standardized address
™ Reference data ID [~ Percent along
Help | Advanced... CK | Cancel
e) Click OK.

3) Open up ArcMap, and add the Excel spreadsheet with the address information.
4) Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.

5) Select the appropriate address locator by clicking Add.... then OK.




qi'@m

tl"“'q.

. Choose an Address Locator to use...

Marne | Description | Add...
l C0_Geocode_TIGER_2009 LS Streets with Zone

Cancel

6) Fill out the Geocode Addresses dialog box as shown below:

Geocode Addresses: CO_Geocode TIGER_2009 2
Address table:
|Fiber5 j =
Address Input Fields
Street or Intersection: FULL_ADDR -
Zone: 7IP_CODE -
Output
% Create static snapshot of table inside new feature dass
-~
Output shapeﬁle or feamre dass:

| J

Advanced Geometry Options. .. |

Geocoding Options. ..
Help oK | Cancel |

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all the default
parameters.

8) Review results.




9)
10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.

Geocoding Options... I Zoom to Candidates | @ Pick Address from Map |

Search I Match | Ur;atchl Save Edits

Show results: IA\I Addresses j Manage result sets... Refresh Rematch Automatically |
Matched: 97 (88%)
FID Shape | Status | Score | Match_type | Side Al | [ e 5 (5%)
3 0] Point [ 81 /A L 201 CENTENNIAL DR, 81601 =
1 |Point [0 81 A L 201 CENTENMIAL DR, 81601 = Unmatched: 8 (7%)
2|Paint " B L 201 CENTENNIAL DR, 81601
3|Point I 100 A L 210 CENTER DR, 81601 =
4|Point " B1[A L 15 MARKET DR, 81601
5 |Point " B R 40 MARKET DR, 81501
6| Point u oA
7| Point T 51[A L |58527 SOCCER FELD RD, 81801
| Point " 100 A L 125 STORM KING RD, 81601
9| Point I 60/A L 52800 TWO RIVERS PLAZA RD, 81601
10/ Point u oA
11/ Point " 81 R 40 MARKET DR, 81601
12| Paint T 63[A R 2698 GILSTRAP CT, 81601 v
< il | El N
Record: ﬂ j 1 j ﬂ Records (of 110)
+ Address: 1Candidate 1 Candidate details:
Strector Intersecion [201 CENTENTA Score v | Side | Match addr [ LeftFrom [ LefiTo [ RightFrom [ RightTe | | From 201 | 200
81 L 201 CENTENNIAL DR, 81601 201 293 200 298 To 299 298
Zone IElGU]
PreDir
PreType
StreetName | CENTEMNIAL
StreetType DR
Sufdir
Zone 81501 | 81601
Score 81
Side L
Match_addr [201 CENTENNIAL T
# Standardized Address:
201 | | CENTEMMIAL | ST | | 81601 < ] >

Close

Adjust geocoding parameters accordingly and repeat batch to resolve issues.

11) Visually inspect the data as seen below:




BROADNMAP

Beyond The Boundaries

% provider_data_QAQC.mxd - ArcMap - Arclnfo ‘Z”E‘El

Fle Edit View Bookmarks Insert Selecton Tools CH2M Window Help
== = iz} o + 152,481 o 2| & @ D 3o | n2 | Editor v v
Georeferancing - ArcPad Data Manager v | 4] 4% | G Spatial Anal
3D Analyst ~
@ [
SE=]
= Geocoding Result: glenwood_try1 Q *
. ae
an
= [J TIGER Streets oo
- ol
= B COUNTIES Ly
= O BB_ConnectionPeint_MiddleMile O
* ‘
= HIGHWAYS
= FCROADS = ~
= [0 BB_service_Road_Seament X
=] CITIES [i]
- O B8_Sservice_CensusBlock L
o Bl
= O BB_Service_Overview A,
F==4
= [0 BB_Service_Wireless
O
= [ communicomm_coverage_area
o &l
=l [J wired_coverage_sample_wgs84
O
~ / ﬂ
_Display [ Seure | Selection a0 1 o
Drawing ~ R O~ A~ 0] Aral [0~ BT U Av A Fv ¢~
-107.326 38,557 Decimal Degrees

12) Follow the steps detailed in Subscriber Location — GIS Data below

3.5.2.2 Subscriber Location — XY Data

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and longitude, the
steps are as follows:
1) Refine the format in Excel so that the data can easily be opened using ArcMap.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and make
sure there are no merged cells.

b. Make sure that XY locations are in decimal degrees.

i. To convert from degrees, minutes, seconds (392 26’ 45.67”) to decimal degrees us the
following formula: DD + (MM/60) + (SS.555/3600).

ii. Note: if XY locations from some other coordinate system are provided, you can use
those in the process below but you must know what the coordinate system is.

2) Open up the Excel worksheet in ArcMap.

3) From the menu bar, select Tools>Add XY Data...
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Add XY Data

Atable cortaining X and Y coordinate data can be added to the
map as a layer

Choose a table from the map or browse for another table:

| ForImports j g
Specify the fields forthe X and Y coordinates:
X Field: |LONG j
Y Field: ||_,'.\T j

Coordinate System of Input Coordinates

Description:

Geoagraphic Coordinate System:
MName: GCS_WGS_1584

[~ Show Details

[+ Wam me if the resulting layer will have restricted functionality

oK | Cancsl |

4) Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate system and
press OK.

5) Results are an event layer, not a true spatial layer. Export the data by right-clicking the event layer and
selecting Data>Export Data... from the dropdown menu.

6) Follow the steps detailed in Subscriber Location — GIS Data below.

3.5.2.3 Subscriber Location — GIS Data

If the provider supplies subscriber location in GIS format, the only process step is to load that data into the
appropriate data schema and it will be ready for processing.
1) First, load the data into the Point Address database schema (please see Appendix D for an example of the
Point Address database schema.) using an empty feature class in that schema.
2) In ArcCatalog, right-click on the empty feature class and select Load from the dropdown menu.

3) Navigate to the provider address GIS data set and then map the attribute fields accordingly, as seen in
general below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field ~
| =treet_id [int] <Mone= =
| =side [ztring] =Mone>
|| feature_id [in] <Mone>
| point_type [=hort int] <Mone=
| | 2dd_house_num fstring] |BLoG_Num stringl __[Rd|
| add_pre_dir [string] PRE_DIR [=tring]
| add_pre_type [string] <Mone=
| add_name_body [string] STREET_NM [=tring]
| add_suf_type [string] SUF_TPE [=tring]

add =uf dir [2tring] SUF TYPE [=tringl b’

Reset

< Back | Mext = | Cancel

4) Once you have successfully loaded the provider address data into the temporary database with the
correct schema, you will now append that data to the overall Point Address database.

5) In ArcToolbox, use the Append command (Data Management Tools>General> Append) to add the
features into the overall Point Address database, as seen in general below:
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Input Datasets

C:\Working'Broadband\Provider_Data_Example.gdb{Temp_Address

l& 21X |+ |&

Target Dataset

| C:\Waorking\Broadband\Provider_Data_Example.gdb\Address_Database
Schema Type (optional)

[TesT

Field Map (optional)

le |2 IX |+ 1 |&

v

OK | Cancel | Environments. .. | {Show Help > |

6) Since the data is already in the Point Address database schema, there is no n need to alter the Field Map
in the Append tool.
7) After appending, calculate metadata reflecting geometry source and representation values.
8) Break provider-specific points into separate county feature classes and perform the following steps per
county feature class:
a. Within ArcGIS
i. Summarize download and upload speeds [first,last] to determine all speeds available for
county.
1. This will save as a DBF table. Keep track of location for future reference.
ii. Buffer county address point featureclass to 150’.
1. During buffer command, dissolve on “ad_down”; "ad_up”; ”"provider”; “dba”;
“frn”; “tt”; ‘all metadata fields’; “stctyfips”. Save as....
county_fastestdown_fastestup.
2. (Example using Qwest data: boulder_40128 20128, where boulder=county;
40128=ad_down; 20128=ad_up)
3. Note: these attribute fields are specific to the Point Address database.
iii. Select the features that represent the lowest speeds
b. Using XtoolsPro (http.//www.xtoolspro.com/)
i. Inthe XTools Pro toolbar, select XTools Pro>Layer Operations>Erase Features
ii. Use the same feature class for Input and Overlay

iii. Check Use selected features on the Input feature, as seen below.



http://www.xtoolspro.com/
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iv. Repeat and erase slowest speeds one speed at a time. Saving each new feature class as
the next slowest speed, using the same naming convention as above. A general example
is seen below:

Erase Features

Input feature layer:

[ boulder_12128_836 |
v Use selected features
(12 feature selected)
Qutput storage:
| C:\Working\Broadband\ProviderDat.. . \boulder _71658_896

v Add output feature dass to current map
¥ Create spatial index

Qverlay layer:

|[E bouider_12128_896 |

| Use selected features (1 feature is selected)

Help Ok | Cancel

c. Within ArcGIS
i. Edit/delete speeds from the attribution table of each feature class, so each remaining
feature class has only one speed value.
ii. Merge individual speed feature classes together using the Merge command in
ArcToolbox (Data Management Tools>General>Merge). The dialog box is seen below:
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EEX
@ Input Datasets 2

l& [+ % |+ &

& Output Dataset

Field Map {optional)

3|
|
x|

OK | Cancel | Environmems...|

iii. Merge individual county feature classes together using the Merge command in
ArcToolbox (Data Management Tools>General>Merge).

iv. Since the county files are all in the same schema, do NOT alter the Field Map portion of
the command interface.

v. When all the county files are merged together into one dataset, use the Append
command in ArcToolbox (Data Management Tools>General>Append) to add the
features to the bb_cov interim data set. Use the Field Map portion of the Append tool to
map the appropriate field values to their corresponding fields in the bb_cov feature

class.

3.5.2.4 DSLAM or Central Office Location — Address Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office address

data please follow the steps below:

1) Follow the process for geocoding points in Subscriber Location — Address Data, above.
2) Follow the steps detailed in DSLAM or Central Office Location — GIS Data below.

3.5.2.5 DSLAM or Central Office Location — XY Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office XY data

please follow the steps below:

1) Follow the process for creating points from XY data in Subscriber Location — XY Data, above.
2) Follow the steps detailed in DSLAM or Central Office Location — GIS Data below.
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3.5.2.6 DSLAM or Central Office Location — GIS Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office GIS data
please follow the steps below:

1) Buffer the DSLAM/Central Office points feature class
a) Add the point feature class to ArcMap
b) Open up ArcToolbox and go to Analysis Tools>Proximity>Buffer
c) Set the buffer distance to 5 miles
d) Set the dissolve type to ALL
e) Name the output feature class
f)  Typical Buffer tool is seen below:

EBX

Input Features
| Columbine ﬂ ﬂ
Qutput Feature Class

| C:\Working'Broadband\ProviderData‘\Columbine \Columbine_Buffer_2.shp

Distance [value or field]
(¢ Linear unit

~u

%

L

[ 5 |miles -
" Field

Side Type (optional)

End Type (optional)

L L L L

Dissolve Type (optional)

Dissolve Field(s) (optional)
Ormo

O company

Ooea

Orrn —
O excHANGE

Ostate

OrrovIDER

Ocui_cooe

MecorT bt
<

| >

oK | Cancel Environments... | Show Help == |

g) Press OK
2) Use the resulting buffer feature class to clip the TIGER street layer (as described earlier):
a) Add TIGER street layer to ArcMap
b) Open up ArcToolbox and go to Analysis Tools>Extract>Clip
c¢) Complete the dialog box as seen below:




3)

4)
5)

6)
7)
8)

9)

Input Features
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[TIGER _Streets
Clip Features

| Columbine_Buffer
Output Feature Class

| C:\Working'\Broadband\ProviderData\Columbine\columbine _TIGER _dip.shp
XY Tolerance (optional)

| Meters

oK Cancel | Environments...| Show Help == |

d) Press OK.

Using ArcCatalog and within the file geodatabase:

a) Right Click and create a new Feature Dataset
i)  For the Feature Dataset settings:

(1)
(2)

(3)
(4)
(5)

Import previously created street feature class into new Feature Dataset

Name the feature dataset accordingly

Select horizontal coordinate system by importing the coordinate system associated with the
clipped TIGER street layer by selecting Import and navigating to the location of that feature class

No vertical coordinate system needed
Leave all x,y,z,m values at default.
Press Finish

Right-click Feature Dataset and create new Network Dataset — accept all default setting for the Network

Dataset

a) Note: the Network Analyst extension must be turned on

In ArcMap Turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst
Add the Network Dataset created in Step 5 to ArcMap

Using Network Analyst Toolbar drop down — create “New Service Area”

Open up the Network Analyst Window by selecting the E button.
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|Servil:e Area ﬂ
Facilil:iﬁ (1))

Polygons (0}
Lines (0}
Barriers (0)

10) Right click Facilities layer, select Load Locations, and navigate to the DSLAM/Central Office facilities feature

class.
Load Locations |E|E‘

= &

Load From: El columbine_points
¥ Orly show point layers

| =]

Location Analysis Properties

-
Sort Field:

Property Field Default Value
MName

CurbApproach Either side of vehicle
Attr_Length 1]

Breaks_Length

Location Position

* se Geometry

Search Tolerance: | 5000 Meters j

™ Use Network Location Fields

Property Field

SourcelD
SourceQID
PosAlong
SideOfEdge

Advanced... Cancel

11) Press OK.
12) Click the Service Area Properties button
13) For the following tabs change the following properties:
a) “Polygon Generation” tab
i) Select “Merge by break value”
ii) Also disable the Trim Polygons option
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b) “Analysis Settings” tab — using and converting the specified DSLAM buffer distance from feet to meters —
input buffer distance value in meters into the “Default Breaks” location
i) Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used as the buffer
distance

Layer Properties

Line Generation ] Accumulation ] Network Locations ]
General ] Layers ] Source Analysis Settings l Polygon Generation ]
Settings Restrictions
Impedance: |Length (Meters) j
Default Breaks: |54351
Direction:

* Away From Facility
" Towards Facility

Allow U-Tums: |Everywhere j

v lgnore Invalid Locations

QK | Cancel Apply

c) Click OK.

On the Network Analyst Toolbar click the “Solve” button ﬁ to create service area polygons.

Right-click on the created service are polygon in the layer list, and select Data>Export Data from the dropdown

list.

Export to a feature class in the file geodatabase you created earlier

In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the feature

class created in Step 16 into it.

a) Right-click on the empty feature class, select Load>Load data from the dropdown menu and navigate to
the location of the service area feature class

b) Press the Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:
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Simple Data Loader

For each target field, select the source field that should be loaded inta it.

Target Field Matching Source Field =

[ProvName [string] <Nones= =
_| DBAName [string] =None=
_| FRN [int] <None>
| GeogUnit [string] =MNone»
_| GeogUnitiD [string] =None=
_| TraneTech [zhort int] <None>
| MaxAdvDown [ghort int] =MNonex
| MaxAdvUp [short int] <Nones
| ARPU [float] <None>

SWNomSpeed [float] <None= b

Reset

< Back | MNext > | Cancel

e) Press Next, then Next again, then Finish.
18) In ArcToolBox, go to Data Management Tools>General>Append
19) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets =

| = @

Target Dataset

| C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\bb_cov ﬂ
Schema Type {optional)

=]
=]
#|

Field Map (optional)

oK | Cancel Environments. .. | Show Help ==

b




BROADMAP

Beyond The Boundaries

20) Leave the Schema Type as TEST
21) Press OK.
22) In ArcMap, open up bb_cov for editing and manually input associated attribution.

3.5.2.7 Broadcast Tower Location — Address Data

In the event that the provider supplies wireless broadcast tower location address data please follow the steps
below:

1) Follow the process for geocoding points in Subscriber Location — Address Data, above.
2) Follow the steps detailed in Broadcast Tower Location — GIS Data below.

3.5.2.8 Broadcast Tower Location — XY Data

In the event that the provider supplies wireless broadcast tower location XY data please follow the steps below:

1) Follow the process for creating points from XY data in Subscriber Location — XY Data, above.
2) Follow the steps detailed in Broadcast Tower Location — GIS Data below.

3.5.2.8.1 Broadcast Tower Location — GIS Data

In the event that the provider supplies wireless broadcast tower location GIS data please follow the steps below:

1) Download the required software (Radio Mobile) from the website:
http://www.cplus.org/rmw/english1.html

2) Install the software according to the standard directions, found here:
http://www.cplus.org/rmw/download/download.php?S=1

3) Open up the application
4) Load the broadcast tower location and elevation information by selecting File>Unit properties. The
following dialog box appears:



http://www.cplus.org/rmw/english1.html
http://www.cplus.org/rmw/download/download.php?S=1
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¥a Units properties Kol
MName Elewvation [m]
Athena T |Althea + 2832
Caribiou | J
Chipeta -
: Pozition Clear
EarﬁkhnsE A D4'26.6"M 105°30°33.1"w
orizon-
Horizonw ﬂ DN7OFE M
Littleraven
M atzanala-H I Locked
b amzanala-f
Mmonetone Erter LAT LON or DR Move up
Firata
Terapin Move down
Eﬁﬁfo Place unit at cursor position
W apiti Export
Place cursor at unit position Irnpart ‘
Syle Sart
v Enabled ™ Left * Centre " Right
Aipply style

[ Transparent

™ Nolabel B ackColor ‘ ForeColor o Sl fant

lcon 16216 pixels

Al o] [=]

— [™ Show only urits that are members of a visible network,

5) Add in the information for all the towers supplied by the WISP data provider, including the elevation. If
provider does not supply elevation, this information can be obtained from Google Earth.
a. |Ifavailable, use the Import button to import a Google Earth KML of the tower locations.
6) Go to the National Map Seamless Server (http://seamless.usgs.gov/) and download elevation data

sufficient to contain the tower locations.
a. Atleast the 1/3” NED data is needed. Select this by clicking the Download button in the upper
right of the web site and checking the box nect to 1/3 “ NED.
b. Zoom to the area of interest and use the Download tools:

IDuvmluads
T [l [ e
=

to define the area to download.
c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI GRID, as
seen below:
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http: fextract.cr .usgs.gov /Miebsite fdistreq/RequestSummary  jsp?PR =0&CU =Native 82X =-1,087Y =-1.08ML=C 5 7

The National Map Seamless Server
Request Summary Page
You are Iogged in as Default Seamless User

Data Request HELP!

Data Extraction Request Pieces:
Output Parameters Size (MB) | Download Links
National Elevation Dataset (NED) 1/3 Arc Second

2ZUSGS
=z
=

EROS Data Center

Dong @ *'- ™ 4 orr. frank@gmail.com

d. Download the data and unzip it.
7) Select File>Map Properties to define the map
8) Enter in a latitude and longitude in the center of the tower locations
9) Set the size (in pixels) and the size (in kilometers) of the map
10) Set the directory path leading to the BIL elevation data just downloaded
11) The dialog box is seen below:

"\ Properties of ..\default.map

Centre Size [pixel]
ATI328.8°N 10572927 6% Wwidth(pisels] Height [pixels] Extract
DN70GE 1000 1000
Latitude Longitude
40.053 -105.491 Size [km] Cancel
wfidth(krn) Height (k] _—
|lee cursor pogition ‘ 100.00 Top Left
A0°30° 29"
World map ‘ Elevation data source 1060444/
Drive or path Tap laper Top Right
Select a city name ‘ |BIL j |c:'\geodata‘\bil‘\bnulder Browse. .. 4030729
10475477
Enter LAT LON or ORA, ‘ None =] | Browse.. Battam Left

39736 29"N

|Select a unit ﬂ |N°”'3 j | Browse... 10E704'44'
Nore ]| IR gsoftaosr'nzg'l'ﬂht

[~ Adjust units elevatian |N0ne j | - 1047541
M ict P B | Fiesalution
enge pictures [ Ignore mizsing files ottom layer | 1o mpisel

[ Force gray scale Initilize matriz with elevation [m] |0 324 arcsecond
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12) Hit Extract.
13) The elevation data is render as a hill shade, as seen below:

4 \default.net - Radio Mobile - [..\default.tif]
E[IFlle Edit View Tools Optons Window Help ZStop

Dﬁﬁﬂ*&l@ﬁ@ﬁ-ﬂ\tﬂliﬂlé\@aﬁﬂl -%|ELEIW©®.

’.¢,’,

| | ﬁeadv [40°05'34"N 105"17'13"W =673 Y=4611724.1m A

14) Select File>Network properties from the main menu
15) Create a new network and enter in the frequency range under the Parameters tab, as seen below:




List of all rets

Default parameters

Copy Met ‘
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(]

Cancel |

Mednet
Jade
Oluray
COkobile

MHet B
Met 7
MHet 8
Het 9
MHet 10
MHet 11
Met 12
Met 13
Met 14
Met 15
Met 16
Met 17
Met 18
Met 19
Met 20
Het 21
Het 22
Met 23
Met 24
Met 25

Parameters ‘ Topalogy ‘ tembership ‘ Syzterms | Style |

Met name

|Nedemet

Minimum frequency (MHz) | 2400
t auimumn frequency [(MHz] | 2400

Paolarization
* Vertical ™ Harizontal

Mode of variability

(v Spot i of time
™~ Accidental

% of locations
"~ Maobile

% of situations |70

(" Broadcast

Surface refractivity [M-Unitg] W

Ground conductivity (S /m) I—
0.005

Relative ground permittivity l_
15

Clirnate

" Equatorial

-

Continertal sub-tropical
Faritime sub-tropical

Desert

DR e

Continertal termperate
Faritime termperate over land

Faritime temperate over zea

16) Leave all the other values as they appear, and select the Systems tab

17) Create enough systems to cover all the varieties of equipment in the provider network. This will include

the antenna type, height, and line loss, as seen below:

BROADNMAP
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Default parameters ‘ Copy Met | ‘ Cancel |

List of all systems
Orori |
B0 Parameters | Topology | Memberzhip ‘ Systems ‘ Style |
120
Systemn 4
Syztem B
Sﬁstem E |D'I j |Select from Radiozys01.dat j
Systern 7
System 8 System name | Omni
Systern 9
Spster 10
S_ﬂit:m 1 Transrit power [Watt] 100 [dBrm] |50
System 12
g.'r'Sth 13 Recaiver threshold [pt) |1 (dBm] |-107
ystem
System 18 Line logs [dB) |1 [ Cable+cavities+connectars |
System 16
System 17 -
System 18 Anterina ype hd View
System 19
Syatem 21 Artenna gain (d8i) |15 By 128
Systerm 22
System 23 Antenna height [m] |3 [ Abowe ground |
System 24
System 25 Additional cable lass (dB/m) |0 (115 et i dlfiers | _

Add to R adiosys01.dat Remone from Fadiosyz01.dat

18) Now click on the Membership tab, and assign the individual towers to their respective systems, providing
the azimuth for non-omnidirectional antennas, as seen below:
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Default parameters | Copy Met ‘ ‘ Cancel |
List of all nets
hedret
Jade Parameters ‘ Topology | Membership ‘ Systems ‘ Style
COuray
Ok obile e e T
. . ember of Medemet
Met B st 56 € urils Rale of Athena
H:: g |C0mmand ﬂ
Het 190 Syztem
et v Chipeta

0 -
HEH; W Frankling | J
Net 13 w| Horizor-E Antenna height [m)
Met 14 | Horizores
Met15 v Littleraven fe Spstem g
et 16 | tanzanala-H
Net17 | Manzanalay & Wi
Hz:::g | Moonstone
Net 20 | Pirata Antenna direction
Met 21 W T ermapin —
et 22 | Tobago |F'”Ed[ 1 ﬂ
He: %3 v \T\?[tl?_ Azimuth [ Elevation angle [*]

2
Net 25 v ep |30 o
3 Yiew pattern |

19) Press OK.

20) Select Tools>Radio Coverage>Combined Cartesian from the main menu

21) Complete the dialog box as seen below, providing the Maximum Range from the highest tower beam
radius supplied by the provider.

22) Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of granularity) as
seen below:




Maohile: unit

[ \Wapit Diraw
L] |4thea Bl
Anterna pattemn I
= In network. Cancel
Chipeta omri.ant o J
Franklins I edemet A
HorizorE v Use network antenna settings s szl |
Haorizan-w s p e (TT)

i ave raster data ta file |
Littleraven ) Save settings
Manzanala-H I~ Save raster data to file [SI1G)

Manzanala = 3 .
ave also urits nat selected |

Moonstone L Load data

[~ Draw pattemn I~ Complete.way

I~ Save coverage pictures in “frames" directory
Vit | W Maximumn range (k) I”32
Antenna height (] i~ Link. Direction Mods
El  Mobile Rx 4l picture

" Mobile T  Selection
. Backealor

~ Signal range ta dra
& Slini ™ Best unit From [>=]
El

i dBm 5 I -
| Ta(<)

o -

 dBpv/im

Diraw size [pivels) I Hetwark styie . Color

L 5 I Rainbaw I Solid

OoOo0oOo0ooOoOoOoooog

23) Set the signal range to draw to S-Unit and type 5 in the From (>=) box.
24) Press Draw.

i |Ready [40°05'53"N 105°15'10™W X=702 Y=455 1627m A

25) Save the resulting image as a TIF by selecting File>Save Picture as.
26) Open ArcMap and load the BIL elevation data you used in Radio Mobile.
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Load the TIF image you created and georeference it using the corners of the BIL data.

a. The corners of the data can be seen in the TIF image.
Follow the georeferencing directions from the Coverage Area — PDF/JPG/Other Image Format section
below.
Use the Georeferencing Toolbar to Update the Georeferencing for the TIF data set.
In ArcToolbox, select Data Transformations>From Raster>Raster to Polygon and input the georeferenced
TIF you just created as seen below:

Open the resulting polygon feature class up for editing using the Editing toolbar in ArcMap and clean up
as necessary.
In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the
feature class created above into it.

a. Right-click on the empty feature class, select Load>Load data from the dropdown menu and

navigate to the location of the service area feature class

b. Press the Add button, hit Next

c. Accept the defaults and hit Next

d. Do NOT attempt to map any fields, as seen below:

%)

Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field ”~

|Prquame [string] <Nones =
| DBAName [string] <None>
| FRM [int] =Monex
_| GeegUnit [string] <Nones
| GeogUnitiD [string] <MNone>
| TransTech [short int] =Monex
_| MaxAdvDown [ghort inf] <None>
| MaxAdvUp [short int] <MNone>
| ARPU [float] =None=

SWHNomSpeed [float] =Nongs= b

Reset

< Back | Mext = | Cancel

e. Press Next, then Next again, then Finish.

33) In ArcToolBox, go to Data Management Tools>General>Append
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Input Datasets

t
| = @
C:\Working'Broadband\ProviderData\Columbine\Columbine. gdb\service _area_bb... ﬂ
x|
ki
3

Target Dataset
| C:\Working'\Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov ﬂ
Schema Type (optional)

Field Map {optional)

|+ L %

| b

QK | Cancel Environments... | Show Help == |

35) Leave the Schema Type as TEST
36) Press OK.
37) In ArcMap, open up bb_cov for editing and manually input associated attribution.

3.5.3 Linear Data
3.5.3.1 TIGER Street Segments — List, Spreadsheet, or GIS Data

In the event that the provider supplies TIGER street segments in list or spreadsheet format please follow the steps
below:

1) Join TIGER road segments to 2000 census blocks feature class using one of two methods based on how
the data is provided:
a) Ifthe TIGER data is provided with a Census Block ID, then join the segments to the Census Block
geometry based on that ID
i) Load both data sets into ArcMap
i) Inthe layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join
iii) In the dialog box, select the TIGER road segments data and the proper attribute fields for joining,
as seen below:
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Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?
|J0in attributes from a table ﬂ

1. Choose the field in this layer that the join will be based on:

|BLKIDFPOD ~|

2. Choose the table to join to this layer, or load the table from disk:

(% TIGER_Streets [=] E

[+ Show the attribute tables of layers in this list

3. Choose the field in the table to base the join on:
-

Join Options
 Keep all records

All records in the target table are shown in the resulting table.
Unmatched records will contain null values for all fields being
appended into the target table from the join table.

" Keep only matching records

If a record in the target table doesn't have a match in the join
table, that record is remaved from the resulting target table.

About Joining Data 0K | Cancel

iv) Press OK
b) If the data provided is a list containing TLIDs, then join to the TIGER line data using the TLID, and use
a spatial join to associate the TIGER segment with the coterminous block based on the block ID
i) Load both data sets into ArcMap
ii) Inthe layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join
iii) Select “Join data from another layer based on spatial location” from the dropdown menu
iv) Complete the dialog box as seen below and press OK.
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Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

1. Choose the layer to join to this layer, or load spatial data from disk:

[ TIGER Streets -] g

2. You are joining: Lines to Polygons

Select a join feature dass abave. You will be given different
options based on geometry types of the source feature dass
and the join feature dass.

{* Each polygon will be given a summary of the numeric
attributes of the lines thatintersectit, and a count field
showing how many lines intersect it.

How do you want the attributes to be summarized?
[~ Average [~ Minimum [~ standard Deviation
[ Sum ™ Maximum [~ Variance

™ Each polygon will be given all the attributes of the line thatis
dosest to its boundary, and a distance field showing how
dose the line is (in the units of the target layer).

Mote: A line faling inside a polygon is treated as being dosest
to the polygon, (j.e. a distance of 0).
3. The result of the join will be saved into a new layer.
Specify output shapefile or feature class for this new layer:

|C:"-.‘.‘\u'orking"-.Broadband"-.Temp"-Join_OutpLrt_5.shp =

About Joining Data 0K | Cancel |

2) Export joined records into a temporary feature class.

3) If joined Census Block geometry is confined to one specific area then dissolve blocks into one record. If
joined Census Block geometry is distributed throughout a particular state then dissolve sub-selections of
census blocks for each county.

a) Use the County FIPS code to dissolve by county.
b) In ArcToolbox, select Data Management Tools>Generalization>Dissolve
c) Complete the Dissolve dialog box as seen below:




4)

5)
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* Dissolve

Input Features —

| blocks_Lm | ﬂ
2|

Output Feature Class

| C:\Working\Broadband \BaseDatablocks_UTM_Dissolve,shp =
Dissolve_Field(s) (optional)
OrFmo

Ostaterrao
COUNTYFPOO

O racTceon
OsLockceno
[eLkioFrPo0

O nameon

Owmrrccoo

Murnn ]
<

Select All | Unselect All
Statistics Field(s) (optional)

Field Statistic Type

h

OK | Cancel Environments. .. | Show Help ==

d) Press OK.

For each dissolved region, open up the feature class for editing using the Editing tool in ArcMap and
remove unnecessary slivers and other small holes. For general guidance on editing features in ArcMap,
see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf

In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the
feature class created above into it.

a) Right-click on the empty feature class, select Load>Load data from the dropdown menu and navigate
to the location of the service area feature class

b) Press the Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:



http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf
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Simple Data Loader

For each target field, select the source field that should be loaded inta it.

Target Field Matching Source Field =

[ProvName [string] <Nones= =
_| DBAName [string] =None=
_| FRN [int] <None>
| GeogUnit [string] =MNone»
_| GeogUnitiD [string] =None=
_| TraneTech [zhort int] <None>
| MaxAdvDown [ghort int] =MNonex
| MaxAdvUp [short int] <Nones
| ARPU [float] <None>

SWNomSpeed [float] <None= b

Reset

< Back | MNext > | Cancel

a) Press Next, then Next again, then Finish.
6) In ArcToolBox, go to Data Management Tools>General>Append
7) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets =

| = @

Target Dataset
| C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\bb_cov ﬂ

Schema Type {optional)

=]
=]
#|

Field Map (optional)

oK | Cancel Environments. .. | Show Help ==

b
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8) Leave the Schema Type as TEST
9) Press OK.
10) In ArcMap, open up bb_cov for editing and manually input associated attribution if necessary.

3.5.4 Polygonal Data
3.5.4.1 Coverage Area — PDF/JPG/Other Image Format

In the event that the provider supplies coverage area data in some image format such as PDF or JPG format please

follow the steps below:

1)
2)
3)

4)
5)

6)
7)

8)
9)

If in PDF format, open in Adobe Acrobat and Save As... JPG format.

Open up the JPG image in ArcMap.

Add the required basemap vector data for georeferencing.

a) This will generally be either the CDOT data or TIGER data

Change the coordinate system of the data frame to the desired end coordinate system

Zoom to the general location of the JPG map image

a) Thisis the location based on the vector data, not the JPG image itself. For example, if you know that
the JPG image represents an area around the town of Limon, zoom to the town of Limon in your
vector data.

Open up the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main menu bar.

Using the Georeferencing toolbar, select Fit to Display, results seen below:

2 8 WD - |
B LE I IE] |
e P VI T ENIEEY

SR
LS

EIRER R IS A
55 4 88t

Use the Control Point button "Z'- to add control points to the map

Use common points in the base data set and the JPG image

a) For example, find major street intersections, county/city boundaries, etc.

b) Try to distribute the points more or less in the four corners on the image for the best transformation
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10) Click on the location on the image first, then click on the corresponding location on the vector data base
map, as in the image below:

= proyider_data_processing_2.mxd - ArcMap - Arclnfo

File Edit View Bookmarks Insert Selecton Tools CH2M Window Help
(=== B2 2l + 15403 v i & O 3 K2 Editor v -
Georeferencng = | Layer [Communicomm_Cov_100805_1_Pz | (%}|~| |+ & ArcPad Data Manager ~| 42 % B | G Spa
30 Analyst = @ xoospo~v & H R EE-OEEXE Y Y
x @ &
= £ Layers -~ - O
= B bbwireless_tmobie & e
O e
EH
= O Columbine o
. b
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11) After placing each control point, the image transformation will update automatically.
12) Repeat until satisfied with the transformation.
a) Note: The transformation may take up to four points, although sometimes only two are necessary.
13) When satisfied with the transformation, select Update Georeferencing from the Georeferencing toolbar
dropdown.
a) This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image file.
14) In ArcCatalog, create a new polygon shapefile with the appropriate data schema for a provider coverage
area, which can be found in Appendix D.
Add the shapefile to ArcMap.
Using the Editor Toolbar, select Start Editing. Set the Task: to “Create New Feature.”

15
16

— -

17) Use the Sketch Tool ‘? bl to digitize a new coverage polygon using the coverage area outline from the

~

georeferenced JPG and add the required attributes manually.
18
19

~

Repeat the above steps for all subscriber speed coverage areas provided.

-

Follow the steps detailed in Coverage Area — GIS Data below.
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3.5.4.2 Coverage Area — KML/KMZ

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format please follow the

steps below:
1) Use a KML to SHP converter to translate file into an ESRI format
2) http://arcscripts.esri.com/details.asp?dbid=15603
3) Download the script and follow the provided instructions for installing it in ArcToolbox.
4) Double-click on the script in ArcToolbox and navigate to the location of the KML file, as seen below:
£ Convert KML to SHP =3
KML File
| C:'\Documents and Settings\forr \Desktop\Google \fiupton. kml
Feature Type
| PoLYGON =l
Qutput shapefile
| C:\Documents and Settings\forr \Desktop\Google \flupton_kml_to_shp.shp g
OK | Cancel | Environments... | Show Help »> |
5) Add the new shapefile to ArcMap. Repeat for all KML files provided.
6) Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.3 Coverage Area — CAD Data

In the event that the provider supplies coverage area data in GIS format please follow the steps below:

1)
2)
3)
4)

5)

6)
7)

8)

9)

Transform the CAD dataset into an ESRI format
http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming CAD datasets
It may be necessary to contact the provider first to determine the coordinate system of the CAD data.

If the CAD data is not in a standard coordinate system, it may be necessary to use ArcMap to
georeference the CAD data to a known coordinate system first.

a) Todo so, follow the instructions provided above in “Coverage Area — PDF/JPG/Other Image Format.”
In ArcCatalog, create a new polygon shapefile with the appropriate data schema for a provider coverage
area, which can be found in Appendix D.

Add the shapefile to ArcMap.

Using the Editor Toolbar, select Start Editing. Set the Task: to “Create New Feature.”

Use the Sketch Tool ‘? bl to digitize a new coverage polygon using the coverage area outline from the
georeferenced CAD file and add the required attributes manually.
Follow the steps detailed in Coverage Area — GIS Data below.



http://arcscripts.esri.com/details.asp?dbid=15603
http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datasets
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3.5.4.4 Coverage Area — GIS Data

In the event that the provider supplies coverage area data in GIS format please follow the steps below:

1) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the GIS
feature class either created above or supplied by the provider into it.
a) Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate
to the location of the service area feature class
b) Press the Add button, hit Next
c) Accept the defaults and hit Next
d) Do NOT attempt to map any fields, as seen below:

X)

Simple Data Loader

For each target field, select the source field that should be loaded inta it.

Target Field Matching Source Field ~

[ProvName [string] <Nones= =
_| DBAName [string] =None=
_| FRN [in] <None=
| GeogUnit [string] =MNonex
_| GeogUnitiD [string] <Nones
| TraneTech [zhort int] <None>
| MaxAdvDown [ghort int] =MNonex
| MaxAdvUp [short int] <Nones
| ARPU [fioat] <MNone>

SWNomSpeed [float] =None= b’

Reset

< Back | Mext = | Cancel

e) Press Next, then Next again, then Finish.
2) In ArcToolBox, go to Data Management Tools>General>Append
3) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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Input Datasets

| < &

C:\Working \Broadband \ProviderData\Columbine \Columbine gdb\service_area_bb...  wju

x|
il
3

Target Dataset
| C:\Working'\Broadband \ProviderData\Columbine\Columbine. gdbbb_cov ﬂ

Schema Type (optional)
Field Map (optional)

‘ A/
QK | Cancel | Environments...| Show Help == |

l+ L [e

4) Leave the Schema Type as TEST
5) Press OK.
6) In ArcMap, open up bb_cov for editing and manually input associated attribution, if necessary.

3.5.4.5 Compact Polygon From Subscriber Points

e Geo-code address list using latest state “Composite Locator”

e  Verify that your geo-coded file has only one TT (Technology Type). If not export individual geo-coded
layers for each Technology Type.

e For each TT check for differences in speed values or speed tiers and create separate layers for each speed
value/tier.

e (Clean your geo-coding results - remove any points that geo-code to accuracy levels below ZIP+4 (ZIP
centroids, carrier route centroids, etc). Also, verify that outliers with acceptable accuracy levels are
legitimate, i.e. fall in correct City and Zip.

o Perform spatial join between county polygons (using stcnyfips field) and the cleaned geo-coded subscriber
points, in order to carry the county name and stcnty fips.




e Summarize the number of subscribers by county and use the subscriber counts by county to populate the
Rate Tier table.

e Un-join the county data from the geo-code subscribers list.
e Create Compact Polygon using cleaned geo-coded layer or sub-selection of using — XtoolsPro —

ConvexHull-DetailedHull option. A sub-selection of geo-coded points will be used in areas where more
than one polygon will need to be created for one provider’s service area.

e  Evaluate output Hull carefully —looking for areas that should not be covered by hull polygon.

o Ifitis determined that an area or areas should not be represented in coverage area, manually
reshape hull polygon until coverage area is adequate.

o When not obvious and as a general rule, manually resolve compact polygon when the distance
between the subscriber points used to define the outer boundary of the compact polygon
exceeds 5 miles. When reshaping the hull polygon, snap to the outermost geo-coded points.
See figure 2 and 3 for an example.

FIGURE 2- Compact Hull: Manual Resolution Required

Original
Compact Hull

As a general rule if the distance between
the subscriber points used to define the outer
boundary of the compact hull exceeds 5 miles,

manually reshape hull.
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FIGURE 3a- Compact Hull: Manual Resolution Required FIGURE 3b- Compact Hull: After Manual Resolution
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e To attribute the compact polygon - Perform a “Spatial Join” where your Target Feature Class is the
compact polygon and the Join Feature Class is your geo-coded point layer. Export compact hull with
joined attributes and name file appropriately.

e Append attributed compact polygon to BroadBand TT template Feature Class and if required manually
input any provider attribution that may not have carried over in the append process.

e Intersect compact polygon with county boundaries to create unique records by county and use the state-
county-fips field to populate “stcty_fips” field. Also use the county name field to populate the
“BBCov_Name” field.

o Exceptions is where a provider’s coverage is distributed throughout more than one area of any
given county where the “BBcov_Name” should be populated using an appropriate city or other

logical name based on geographical location.

e Export/Load into appropriate BB TT model Dataset.




BROADMAP

Beyond The Boundaries

3.5.4.6 Census Blocks — List or Spreadsheet

In the event that the provider supplies census block data in a list or spreadsheet, please follow the steps below:

1) Ensure block polygons supplied by the provider are 2000 currency

2) If other currency, convert to 2000 currency before proceeding
a. Todo this, remove the trailing letter (a, b, etc.) from the block ID
b. You will now have two blocks that equate to one block in the 2000 block geometry
c. Delete duplicate block IDs, retaining the higher service tier in each case

3) Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells, colors,
borders, etc.

4) Import the spreadsheet into ArcMap.

5) Right-click on the 2000 census block feature class in the layer list in ArcMap and select Joins and
Relates>Join from the drop down menu. Join the census block list to the 2000 census blocks feature class
using the block ID and export joined records in a new feature class. The Join dialog box and process can be
seen above in the TIGER Street Segments — List, Spreadsheet, or GIS Data section.

6) Follow the steps in Census Blocks — GIS Data below.

3.5.4.7 Census Blocks — GIS Data

In the event that the provider supplies census block GIS data please follow the steps below:

1) Ensure that the blocks supplied by the provider are in the required data schema and are complete as far
as require attribution.

a. If not, manually enter the required attribution or contact the provider to fill gaps.

2) If census block geometry is distributed throughout more than one county then select Data Management
Tools>Generalization>Dissolve in ArcToolbox and dissolve based on County/Provider/TT/Speed Tier so
that unique records are created for each unique combination.

a. The dissolve dialog box can be seen above in the TIGER Street Segments — List, Spreadsheet, or
GIS Data section.
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Figure 2: Census block polygons dissolved by county

For each dissolved region use the Editing toolbar in ArcMap to remove unnecessary slivers and other

small holes.

In ArcToolbox, select Data Management Tools>General>Merge and merge the processed polygons

together into single layer.
The merged census blocks will need to have the subscriber’s “frn” field added

and populated.

In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the GIS

feature class either created above or supplied by the provider into it.
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a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class

b. Pressthe Add button, hit Next

c. Accept the defaults and hit Next
Do NOT attempt to map any fields, as seen below:

%)

Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field IMatching Source Field ”~

|Prquame [string] <Nones =
| DBAName [string] <MNone>
| FRM [int] =Monex
_| GeegUnit [string] <None>
| GeogUnitiD [string] <MNone>
| TransTech [short int] =None=
_| MaxAdvDown [ghort inf] <None>
| MaxAdvUp [short int] <MNone>
| ARPU [float] =None=

SWHomSpeed [float] <None= b

Reset

< Back | Mext = | Cancel

e. Press Next, then Next again, then Finish.
6) In ArcToolBox, go to Data Management Tools>General>Append
7) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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~
Input Datasets =
I = =
C:\Working'Broadband\ProviderData\Columbine\Columbine. gdb\service _area_bb... +
X
Target Dataset
|C: \Working\Broadband'\ProviderData\Columbine\Calumbine. gdbbb_cov j G
Schema Type {optional)
-
Field Map {optional)
| LA
OK | Cancel Environments. .. | Show Help => |

8) Leave the Schema Type as TEST
9) Press OK.
10) In ArcMap, open up bb_cov for editing and manually input associated attribution, if necessary.

3.6 Metadata Transactions

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts staging
environment, the GIS-Analyst runs transactions to compare that f{GDB with the one stored on the Core server to
ensure metadata on all changes are recorded.

Below outlines the steps taken to run transactions on the updated Core database:

1. Openacommand line window and run generateTransactions.py
a. Usage: generateTransactions.py [Core fGDB] [Staging Environment fGDB]

b. Example of command line:
<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb

2. Below is an example of the output screen that will be displayed:
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Calculating rec_id field for BBCov_W_BBE_FPOLY_TEMPLATE
value can not be B or less
Troubhle creating the progress meter

Calculating rec_id field for BBCov_18_CenturyLink

Merging change: X:~BDIA_BE_GDBE=-MS_BB_POLY_SRU_AREAS .gdb~AddPt
Calculating Tranzaction fields for AddPt

# :~BDIA_BB_GDB=~MHM5_BB_FPOLY_SRU_AREAS .gdb~AddPt...changes is complete.

Your transaction FeatureClasses are in:
~smichigan~fAllAiccess~BDIA_BB_GDBs_HIST-~MS_BE_POLY_SRU_AREAS_HIST .gdh

elapsed time = 2994.4 seconds

3. After process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb
a. The transactions scripts records changes at a feature level.
b. Below is a screen shot supporting the directory structure of the historical fGDB.
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c. Attribution associated with each added/removed/changed features is tracked, including the
following additional columns appended to the end of each:
i. Commit_by
1. Records the GIS-Analyst that committed the changes to the historical f{GDB.

ii. Commit_date
1. Records the date and time stamp that the changes were committed.

iii. Trans_type
1. This field reflects the type of change recorded.
2. Categorized by:
a. Adds/Change/Deletes

iv. New_values
1. Records the new values when a change was completed on a feature. Example:
Name or speed change
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d.

MD_Process is also transferred from the edited fGDB to the historical f{GDB, which states the
actions completed by the GIS-Analyst.
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00BaseBBMetadataFields.py_v1.2, added Jab Wid Hie points back into ab per criigen cmabey 82472010 £:435 | change [5803]
addBaseBBMetadataFields.py_v1.2, added Jab Mid Hie points back info db per criigen cmabey 82472010 4:43:5 | change 15804]
addBaseBBMetadataFields py_v1.2, added Jab Mid Hie points back into db per critigen cmabey 82472010 4435 | change 5805
addBaseBBMetadataFields.py_v1.2, added Jab Mid Hie points back info db per criigen cmabey 82472010 4:43:5 | change 5806]
ariARae BB atarataFiakie mi A3 addad lah Wi Mia nints harl infn Ah nar ~réinan ek 2APAAR 442 E | rhanna 1eanm
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3.7 Data Processing

3.7.1 Data Processing Overview

The following items outline the actions required to process the service provider data further to meet the NTIA
requirements.

e Weighted Nominal Speed

e Middle Mile

e Broadband Coverage Template

3.7.2 Weighted Nominal Speed

The weighted nominal speed is populated one of the following two ways:
3.7.2.1 Subscriber Data Supplied by Provider

Where the data provider supplies subscriber speed information , the following formula from the NOFA is used:
(speed tier-1 in kbps x no. of tier-1 subscribers) + (speed tier-2 in kbps x no. of tier-2 subscribers) + (etc.)

Total average monthly subscribers

Data is initially broken up in the following order:
1) Stcty_fips
2) Transmission technology type
3) Subscriber tiers

3.7.2.2 Value Supplied by Provider

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be populated
instead of using the NOFA formula.

These obtained or calculated values are used to update the service overview layer. This can be done manually or
by creating a table with the provider’s FRN and average weighted speed and joining it to the service overview table
in ArcMap. To Join, right-click on the layer to join to and select Joins and Relates>Join... from the dropdown menu.
Then navigate to the table to join to and select the join fields from the drop down list. Then open up the source
table (the table in ArcMap) and right-click on the header of the Average Weighted Speed field and select Calculate
Field from the drop down menu. Use the value of the average weighted speed from the joined table.

3.7.3 Middle Mile

Middle mile information is generally provided in spreadsheet or text file format. The process is to take what is
supplied by the provider and translate it into the required data schema.
1) If the data is supplied with address information, follow the process outlined above in Subscriber Location
— Address Data.
2) If the data is supplied with associated XY coordinates, follow the process outlined above in Subscriber
Location — XY Data.
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3) Once the datais in GIS format, use the Append (Data Management Tools>General>Append) command in
ArcToolbox to append the data to the overall middle mile dataset.

4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the source to the
target dataset.

3.7.4 Broadband Coverage Template

Below is the description of the fields within the BB_Cov layer, which is the interim data set that is used to create
the final product deliverable.

Name Alias ‘ Description

objectid OBJECTID Internal Object ID

shape SHAPE Internal Shape storage

prov_id PROVIDER_ID Unique numeric identifier for each provider

prov_name PROVIDER_NAME Unique name for each provider

dba_name DOING_BUSINESS_AS An alternative "Doing-Business-As" name for the provider
FCC_REGISTRATION_NUMBE X . X

frn R - - Provider FCC Registration Number

bbcov_name BBCOV_NAME BroadMap Broadband Coverage name

trans_code

TRANSMISSION_CODE

Unique code for the transmission technology type described by
this layer

trans_name

TRANSMISSION_NAME

Name for the transmissions technology type

trans_desc

TRANSMISSION_DESC

Description for the transmissions technology type

spect_code

SPECTRUM_CODE

Unique code for the spectrum [WIRELESS ONLY]

spect_name

SPECTRUM_NAME

Name for the spectrum [WIRELESS ONLY]

spect_desc SPECTRUM_DESC Description for the spectrum [WIRELESS ONLY]

Maximum advertised downstream speed available within given
mad_dwn_t MAX_AD_DOWN_TIER .

area (speed tier)

Maximum advertised upstream speed available within given
mad_up_t MAX_AD_UP_TIER .

area (speed tier)

Typical downstream speed available within given area (speed
typ_dwn_t TYPICAL_DOWN_TIER ,

tier)
typ_up_t TYPICAL_UP_TIER Typical upstream speed available within given area (speed tier)

Maximum advertised downstream speed available within given
mad_dwn_k MAX_AD_DOWN_KBPS

area (kbps)

Maximum advertised upstream speed available within given
mad_up_k MAX_AD_UP_KBPS

area (kbps)
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Description
typ_dwn_k TYPICAL_DOWN_KBPS Typical downstream speed available within given area (kbps)
typ_up_k TYPICAL_UP_KBPS Typical upstream speed available within given area (kbps)
Total average monthly subscribers for this provider for this
subs SUBSCRIBERS .
technology for this coverage polygon
Metadata: Comma separated list of source id's from which the
md_geom MD_GEOMETRY
polygon extent was produced
. Metadata: Comma separated list of source id's used in
md_exists MD_EXISTS . . . .
understanding and editing the provider data for this polygon
Metadata: Name of the editor who last edited this feature at
md_who MD_WHO L
the time in md_when
md_when MD_WHEN Metadata: Date/timethat this feature was last edited
Metadata: Comma separated list of processed used to create
md_process MD_PROCESS . .
and/or modify this layer
stcty_fips STATE_COUNTY_FIPS State/County FIPS code
Compound Key formed from
rec_id RECORD_ID STCTY_FIPS+"|"+Provider_ID+"|"+Trans_Code+"|"+BBCov_Nam
e
st_area ST_AREA(SHAPE) Area in square decimal degrees
st_length ST_LENGTH(SHAPE) Length in decimal degrees
. Has Subtype (1:Broadband provider as described in the
Provider_Typ .
Type of Provider NOFA,2:Reseller,3:Unknown), default value =1 (New 04/11
e
Model)

3.7.5 Verification and Validation

3.7.5.1 Provider Validation — Provider Portal/PDF Map Review

Following the collection and aggregation of provider data, the aggregated data is validated by the provider to

ensure it is an accurate representation of their coverage area and supporting broadband information.

This validation is completed through the Provider Portal web application, which is a secure interactive map that

displays the provider’s coverage areas and allows the provider to validate, submit feedback or request changes. If

changes are requested, then the features on the portal are updated and an automatic request is sent to the

provider to complete the validation process.
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Providers that did not use the Provider Portal are asked to validate a PDF map displaying their coverage area(s).

this is accomplished via e-mail notification.

3.7.5.2 Provider Verification — 3™ Party Source Review

After the provider has validated its coverage areas, a 3™ party source comparison and analysis is performed.

Where anomalies or discrepancies are identified, a ‘SCAN’ point is dropped and descriptive comments are applied

to be reviewed later with the provider.

During the provider review, the map is displayed along with the ‘SCAN’ points and potential refinement is

completed based on input from the Provider.

3" Party Sources Utilized

3" Party Source Name | Source Type

Verification Type

InfoUSA Consumer and Business Community Anchor Institutions
Listings Can also be used for demographic information supporting
the State websites
Pitney Bowes (PBBI) Exchange Info Plus Exchange datasets are used to verify the following

(Central Office Locations)

Transmission Technologies (TT):

Asymmetric xDSL (10), Symmetric xDSL (20), Other Copper
Wireline (30), and Optical Carrier/Fiber to the End User
(50).

Media Prints Cable Boundaries Used to verify the following TT:
Cable Modem—DOCSIS 3.0 (40) and Cable Modem—Other
(41)
American Roamer Wireless Coverage Used to verify the following TT:
Patterns (EVDO, GPRS, Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
WISP, HSPA) Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80)
ComSearch Wireless Spectrum Used to verify the following TT:

Holdings and Tower Data

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80)
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3.7.5.3 Assigning Confidence Values

All findings and results from the above-mentioned validation and verification activities, plus internal peer quality

reviews are captured and tracked in a Validation table and form the basis of the confidence value assigned for

each provider and then each technology.

The confidence values are as follows:

0 = Coverage area has not been reviewed

10 = Extremely Low. Single Source QC.

20 =Very Low. Needs Additional Validation\Verification

30 =Llow. Even with Validation\Verification, Coverage is still suspect.

40 = Acceptable, confirm with State prior to shipment.

50 = Meets requirements to be included in shipment.

60 = Moderate. Meets NTIA/State’s standards, representative of Technology Type (TT)
70 =High. Accurate representation of coverage based upon TT.

80 =Very High. Multiple validation\verification with most 3™ party sources

90 = Extremely High. Multiple validation\verification sources

100 = Perfect. Multiple validation\verification sources, with complete alighment with sources and ground
truth verification activities

This Validation table is maintained as updates or changes occur for each provider, down to technology type, with
the overall goal to improve the confidence values and overall map representation.

Example of the Validation table:

| N I N N O

Cortocts Provew | Metadut |

et vartated v portal

ame._BBCOV AIN0 S0 1 Two Gr PO BXchange aress

d atrbuton are ok

and atrbuton o

 alrbution are ok

Toln|  som[W Recth (o122 ootrs
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3.7.6 Community Anchor Institution (CAl) Data

3.7.6.1 Data Collection

The CAl data was initially collected from the State to create the baseline inventory. All location information and
broadband coverage data supplied was also ingested into the data deliverable.

Additional collection of CAl information was done via data mining and/or webscraping to build out the inventory
further. For example: Collection of additional CAls and location information.

The state-agency-provided CAl inventory was comprehensive but the challenge is collecting broadband related
data; service provider(s), technology and speed data for each CAI. Availability of the CAl portal has not significantly
increase submission of this data. Additional promotion to CAls to utilize the CAl portal will be needed to increase
this data for subsequent deliverables.

3.7.6.2 Institution Data

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet format. The
general process for incorporating this data is below:
1) If the datais provided in Excel or some similar format:

a. Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.
b. Standardize the address format as defined in the staging CAl database

c. Ifthe spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY Data
tool in ArcMap to create a spatial data layer.

d. Ifthere are only addresses, then follow the geocoding steps outlined above to create spatial data
points for each of the institutions.

i. Institutions that do not geocode based on the TIGER 2009 data set will have to be
manually located using Google Maps, Google Earth, or some other information source.

2) If the CAl source data is in GIS format, add the Latitude and Longitude fields and use the Calculate
Geometry tool to populate them, using the WGS 84 coordinate system.

3) Using ArcCatalog, load the new data into the staging CAl database.

4) This database is ready for the makeDeliverable.py script to process the information into the final state
and NTIA deliverables.
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3.7.6.3 Community Anchor Institution (CAl) Portal Updates

A web application has been released to allow for further data collection and validation of anchor institution
location information, broadband coverage, and speed test data.

Information collected from the CAl Portal is then ingested into the overall inventory and will later be compared
against the provider coverage areas mapped for any potential discrepancies.
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3.8 Product Extract

3.8.1 Python Scripts

The following sections make use of Python scripts. In general, to use a Python scrip, you must have Python
installed on your computer. To download the latest version of Python, go to http://www.python.org/download/

and download the latest stable version. As of August 2010, this was version 2.7. Once this is installed, the general
way to run a script is to type the following at a command prompt: C:\Python27\python.exe C:\<location of script>.
Many of the scripts provided have environment variables that must be set before they can be run.

The python code for BroadMap’s product extract has been incorporated into a Hudson Cl System, which is detailed
in the Process Operation and Monitoring section of this document. This was a process improvement activity so all
processes can be monitored, controlled and contain historical tracking on each process.

3.8.2 Product Extract Process

Note: specific Python scripts are called out in red font in the sections below.
The MapConnect product extract process, makeDeliverable.py, uses the BB_Cov and BROADMAP_POINTS interim
data sets to create the following layers according to the current specifications:
e BB_Service_Road_Segment
- This layer contains all broadband services associated with specific street segments for census 2000
blocks larger in area than two square miles
e BB_ServiceCensusBlock
- Contains all broadband services associated with census blocks of no greater than two square miles.
e BB_Service_Wireless
- This layer contains all wireless services not associated with specific addresses.
e  BB_ServiceOverview
- This layer contains subscriber-weighted nominal speed for each provider's service area at a county
level and is meant to act as a summarized view.
e BB_ConnectionPoint_MiddleMile
- This layer contains middle-mile and backbone interconnection points
e  BB_Service_CAlnstitutions
- Broadband Service at Community Anchor Institutions (CAl)
=  Community Anchor Institutions consist of schools, libraries, medical and healthcare providers,
public safety entities, community colleges and other institutions of higher education, and other
community support organizations and entities.

Due to a NTIA model change for the October 2010 data deliverable, an addition to this code was created to
support both models in the case a comparison is later desired or a request is made to revert back to the original
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model. This script name is bdia2ntia.py and creates the following layers in addition to the layers mentioned above,
rolled up to NATL_Broadband_Map.

e BB_ConnectionPoint_LastMile
- This layer contains last mile infrastructure points, which is only populated if data cannot be provided
at a more granular level.
e BB_Service_Address
- Represents broadband availability for service address points. Address Point availability refers to
those individual addresses at which each facilities-based provider of broadband service can provide
broadband services of minimal characteristics within 7 - 10 business days.
e State_Boundary
- State boundary supporting topological validation of point feature classes.
e NATL_Broadband_Topology
- Supports basic topology quality checking. Example: No CAl’s or Middle Mile points outside of the
state boundary

The following process flow provides a view of how the Core fGDB is extrapolated to the NTIA final deliverable via
the makeDeliverable.py script. Following that, the bdia2ntia.py script is run, which limits what’s placed in the final
layers based on the NTIA modeling standards.

The product scripts and supporting extract were originally created separately per request, in case data model
comparisons were to be completed.

3.8.3 Product Statistics

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py) extracts
the following information supporting that product deliverable.
e Provider Statistics
- Collects all provider information, listing by Provider Name
- Provides output of FRN
- Counts the number of features supported within the following layers:
= Census Block
= Street Segment
=  Max Upstream
= Wireless Services
= Infrastructure Points
- These updates were made to support the Data Package required to accompany every NTIA product
deliverable.
e Community Anchor Institution (CAl) Statistics
- Breaks CAl down to the 8 categories
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1: School: K through 12
2: Library
3: Medical/Healthcare
= 4. Public Safety
5: University/College
6: Other Government
7: Other Community non-government
=  None: Unknown Category
e In cases where this occurs, further investigation is completed prior to product shipment to
ensure all CAl’s are categorized accurately
- Reports out the following counts
= Total CAls within that category
=  Total CAls that contain partial BB coverage
e Contains any of the following information for given CAl:
¢ BB Subscriber, Transmission Technology, Speed Down Speed Up
=  Total CAls that contain full BB coverage
e Contains all of the above-mentioned BB information for given CAI.

The output of this script is two CSV files: AnchorlInstitutions.csv and Providers.csv. These files can then be
inspected to ensure that there are the expected number of CAls and providers for every release.

3.9 Quality Assurance

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase, and on
the final product. For scheduled product releases, a test product extract and subsequent manual and algorithmic
QC run is completed along with a release review. The product specifications, project status reports, previous
product release notes are used as references throughout this review.

The following parameters are tested using the methodology listed below each:

e  Product Deliverable Format
- Correct names and format of data deliverables
=  BDIA_QC_SUITES (please see below for details)
- Correct Projections/Datum
=  Manual interaction with product
- Metadata Present and Correct
=  Manual interaction with product
e Table Structure
- All required tables included
= BDIA_QC_SUITES
- Extraneous tables identified
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= BDIA_QC_SUITES
Field Structure
- Allfields included
» BDIA_QC_SUITES
- Extraneous fields identified
» BDIA_QC_SUITES
- Correct field names, types and widths
» BDIA_QC_SUITES
Field Domains
- Values in all tables are constrained to the specified values specified
=  This action is accomplished via BDIA_QC_SUITES and manual review of the product
= This tends to identify project completeness issues as fields with a null value are identified.
Geometric Representation
- Identify if all layers have the correct geometric representation
=  Manual review of the BB_ServiceOverview layer
=  Dependent on NTIA and client requirements
Geographic Extent
- Product includes the necessary Geography associated with Product?
=  Manual Review - ArcGIS
- Isthere extraneous geography included in Product?
=  Manual Review - ArcGIS
Completeness
- Products contain the expected amount of data?
=  Manual review of product stats relative to weekly State reports and defined expectations.
Accuracy
- Product meets the stated accuracy requirements for the deliverable?
=  Sampling procedure to manually review source material to resulting product
=  Provider Validation
=  Verification using 3" Party Data
= Verification against reality, where applicable
Data Regression
- Any unexplainable data loss or change?
= This action is accomplished by comparing results within product statistics script
(BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product
Confidentiality
- Any unauthorized confidential information included in the delivery?
= Review of NDAs and delivery expectations
Prior Issues Resolved
- Have expected internal issues been resolved?
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=  Manual review of data against previous product release notes
- Have agreed upon customer issues been resolved?
=  Manual review of data against previous product release notes, status report and client feedback
e Delivery Medium
- Has the product medium been verified?
= Manual review
- Allfiles present
= Manual review of SFTP site to ensure all files are copied correctly, including file/directory size
- Correct location
= Manual review — confirmation of SFTP link, username and password

3.9.1 QC Suite

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These scripts are all
run in concert and are called from the test_runner script and the test_BDIAProductGDB script.

3.9.1.1 Configuration
These scripts establish the configuration for the test_BDIAProductGDB script which is the core of the QC Suite.

- update_test_config

- active_config

- config_PROCESSO1_automated
- config_PROCESS01_manual

- set_active_config

3.9.1.2 Libraries
These scripts provide additional functionality that is called from with the test_ BDIAProductGDB script.

- bb_unittest_fixture
- bbcov_structure

- BC_XmlWriter

- file_folder

- search_and_replace
- unittst_fixture

- validate_BB_DB

- validate_BB_GDB

- xmlrunner_gui

3.9.1.3 QC Suite

This is the core script for performing automated QA/QC on the interim and final data deliverables.

- test_BDIAProductGDB




"> Build History

Build Queue

No builds in the que:

Build Executor Status 0

BROADNMAP

Beyond The Boundaries

3.9.1.4 Other

These scripts perform other functions detailed below:

- test_runner —this is the main script that runs all the other QC scripts and imports all the necessary scripts
and libraries

- which_build —this determines the current build and passes information to the configuration scripts

3.10 Process Operation and Monitoring

Product Extract, makeDeliverable.py and bdia2ntia.py, is run within BroadMap using a platform called Hudson that
has been enhanced to support BDIA product extraction, process monitoring, as well as product validation. The
same platform can be planned for implementation for the State, if desired.

Below are examples of the product create, product validation, product statistics and monitoring processes which

are managed within the BroadMap Hudson CI-System. All of the above-mentioned python scripts, with the
exception of metadata transactions script, are run via this system.

3.10.1 BDIA Product Create

Below is an example of the main page where the type of product build can be selected.

= iew Jot
- % BROADMAP

(et description

All | BDIA Product Create | BDIA Product Validation | BDIA_Sourcin g | Core Database Validation FCC Product Validation | MCE Product validation  Map Connect Enterprise | Mesh Creation | Postal Product Create | Postal Product Prep | WebPortalPrep  +

ue. s w Job | Last Success Last Failure Last Duration

BDIA Build 12 hr (£197) A 12 sec
BDIA Product Validation AS 2 me 10 days (2157) WA & min 10 sec
BDIA Product Validation CNMI 2 mo 22 days (281) 3 mo 23 days (280) 2 min 16 sec

BDIA Product Validation €O 13 days (2271) A 37 min

PR OB
BoB D

Selecting based on the type of process that will be initiated.




Hudson » BDIA Product Create » BDIA ProductCreate

4 Back to Dashboard

Project BDIA_ProductCreate

), status
"> Changes OR on Alaska
kspace -
[« Build How Waorkspace

Delete Project Last Successful Artifacts

* makeDeliverable.log &=

#, Configure @ ® bdia2ntia.log &
@
9
N

Build History (trend) # robocopy.log &=
#123 Dec 9, 2010 12:30:00 PM 186KB . Hudson » BDIA Product Create » BDIA ProduciCreate
Running for provider portal update | = Recent Changes & Back o Dashboare
#122 Dec9, 2010 9:53:37 AM 179KB sl Project BDIA_ProductCreate
O status —
Running for provider portal update - Test will rerun A
- - Tis build requires parameDh
o sias o .  Permalinks B m i
ec : 46KB 1 workspace state oR ¥
SD build for portal test ® Last build (#123), 4 days 23 hr ago State or Terrtory to Process
a1, - #® Last stable build (£123), 4 days 23 hr aqo Build Now
#119 Dec1, 2010 12:41;51 AM <
° =c 1asee ® Last successful bulld (#123),  days 25 hr aqo
CO Monthly Deliverable w/ Crit Feedback - Round 2 & Last failed build (£121), 6 days 18 hr ago © oelete eroject
@ #118 Now 30, 2010 4:58:46 PM SO0KB ® Last build (£121), 6 davs 18 hr ago #C Confiawre
CO Monthly Deliverable w/ Crit Feedback

The Console Output can be reviewed to see the progress of product create. Following the completion of each
product creation process, an e-mail notification is automatically sent to the team.

Hudson

Hudzan » BOIA Product Creats = BOIA ProductCreate » £117

2 Bakion
Q, s () Console Output

B chanoss

Started by user anonymsus

B console output

[ = P

v
[5] oounstream buid view ien sezver appears ta be cut of sync. This can rasult in incsnsistens chack cur behaviar
o eravious puild ’

> —— _BB_CI\CO_B_POLY_SAV_AREAS. gl *D:\hudese)jcbe\BDIA_ProductCrasca\vazkepace™\CO_EB_DOLY_SAU_AREAE.qéb /MIR /LOC: ssbecopy.log
W tiex suid

Leg Fila : D:\hudsee\jeba\EDIA PreduecC:

e\ weskapace\ sobacepy. 1og

D:\nudsom\3ebs\BDIA_ProsuctCreate\usrk 4t arrorlevel 16 scho FGBOCOFY RETUSN CODE 3 =+-FATAL ZRROR®=* & gomo ERROR

D:\hadson\ 3obr\BDIA_Produss

if wrzorlevel 1§ wcho RONOSOPY RETURN CEOE 3 FAIL MISM XTRA COFY & goto ERROR

. \BDIA, arzarleval 14 wche GOBOCOPY RETURN CODE 3 FAIL MIS XT7A & gese ERROD

D:\RuSaGE\3EBE\BDIA_PEoustCraata\usTESpACEAE arrorlaval 13 acho ROSOCOPY RETURN CODE 3 FAIL MISM CORY & gomo ERROR

D \hadsom\3cbs\BDIA_ProdusiCreate\workspacesif ercorlevel 11 scho ROBOCOFY RETURN CODE 3 FAIL MISM & guvo ZRROR

D \Rudnan $cba\BIIA_PradustCreate\wsrkepaceraf srcorlevel 11 mche ROBOCOPY RETUMI COOE 3 FAIL KTZA COPY & goss EABGR

D:\RisSaGE\36Ba\BOIA_PEodustCraste\wsEkpacarit areorlaval 10 achs ROSOCOPY RETURN CODE 3 FAIL XTWA & gota SREOR

D:\hadaos\cba\BIIA_TraduetCreate\workspaceif ercorlevel 3 echo AOBOCOPY AETURM CODE 3 FAIL COFY & goue ERROR

o 801A, arrorievel 8 scho AGBOGOPY ASTURN COGS 3 FAIL & goto BRAOR

All processes run via the BroadMap Hudson CI-System are stored for historical reporting. Each process can be
reviewed, including the Console Output and Build Artifacts from that run.
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Hudson » BDIA Product Create » BDIA ProductCreate » £161 ENABLE AUTO REFRESH

4 Backto Project

Q status () Build #161 (Mar 28, 2011 9:44:40 PM)
"> Changes

p— OR Pre-Release Build

B console output

|| Parameters Build Artifacts

Tag this build @

|j Downstream buid view »

4 previous Build

f Revision: 3099
B Nextauid 7 No changss.
=

<> Sterted by user anonvmous

3.10.2 Product Validation and Statistics

Once the product creation process is complete, Product Validation and Statistics are then initiated. These support
the BDIA_ReleaseNotesStats.py script and the BDIA_QC_SUITES scripts detailed above.

All statistics and reports are stored for historical review with the capability to place violation criticality on each
quality control check allowing the identification of errors due to project status/completeness verses project
correctness. Example: Typical Speeds populated.




Hudson &, search

Hugson » BDIA Product Validation » BDIA Product Validatien CO ENABLE AUTO REFRESH
4 Back to Dashboard
0. status Project BDIA_Product_Validation_CO
), Status
B2} Changes This job checks db integrity on file GeoDatabase.
@ workspace Record Error Monitor
Build Now _ 250000 /r\v
@ Delete Project & e
. connre B
g o s
5 100,000
= o
Build History (trend) 2 s00m0
#271  Decl,20108:16:58 AM 55MB =
———
Final QC on SOW menthly CO product % = & 5 & ® £ ©® &858 6 © 8 58 ¢ F & © &5 & ©
#270  MNov 18, 2010 9:56:35 AM ssme 2 22 2 2 £ 2R & 4R & a8 s
El £ £ 2 2 2 3 3 3 3 3 £ I I £ e
#269  Nov 18, 2010 9:49:09 AM s | 000 £ 2 &2 5 & £ £ & 2 & 1 2 £ & £ 2 s =
- 3 2 2 &5 8 B 5 @ B % 8 B L B B B F OB E G
#268  Nov 18, 2010 9:22:49 AM 79KB @ @ ¥ & @ & ¥ & € @ € @ & @& & ¥ ¥ € = °
#267  Nov 18, 2010 9:08:05 AM 77%8 Build
QC on SOW monthly CO product |+~ BB_Sewice_CAmnstitutions Error - BB_Service_Wireles Error - BB_Service_CensusBlock Emor
#266  Sep 29,2010 11:12:03 BM sams
. < |+ BB_Senice_Road_Segment Error < BB_Senica_Ovenizw Ermor
#265  Sep 26, 2010 11:17:56 BM 50KB
€O validation build Latest Stats Regression: Link
#264  Sep 24, 2010 12:22:26 PM 78K8 Latest Provider Regression: Link
. #263 Aug 31,2010 1:28:41 PN 48K8 Latest Error Regression: Link
£262  Aua 31,2010 1:17:05 BM 65KB (Bedit description
edit description
#261  Aug 31, 2010 12:22:02 BM 102M8
P (®Disk Usage: Workspace 233M8, Builds 1GB
Auq 30, 2010 8:25:39 AM
#2595 Aug 27, 2010 1:33:49 AM 110M8 Test Result Trend
2 S
#258  Aug 24, 2010 5:00:41 AM 108MB Lest Suctessful Artifacts
#257  Aug 23, 2010 5:00:41 AM 108MB @ * BDIA STRUCTURE OC.log &
® 5B OC OUTRUT.7z 5
#256  AuQ 22, 2010 5:00:41 AM 108MB * SBOD TRANSFER counts.cov B €
#1255 Aug 21, 2010 5:00:41 AM 108MB ® SBDD TRANSFER counts diff.htm| a= g1
® SBDD TRANSFERAnchorInstitutions.csv &
Aug 20, 2010 5:00:41 AM
J #254  Aua20.2010 5:00:41 AM 1osms ® SBDD TRANSFERAnchorInstitutions diff.htm &=
#253  Aug 19, 2010 5:00:41 AM 108MB ® SBDD TRANSFERProviders.
#252 Aug 18, 2010 5:00:41 AM 108MB * SE00 TRANsPEReroviders diffhim] & )
@ #151  ul9 20101:47:88M a1i8 ooy g
[ for oll ) for failures |=#" Recent Changes st show failures) enlarge
———
e

Similar to the Product Create process, all results from the process are maintained:

Hudson » BOIA Progudt validation » BDIA Product \ n CO » 5270 EMARLE AUTO REFAERH
# caskio Proiedt Kok thes b fovever
_ Build #270 (Nov 18, 2010 9:56:35 AM) [T
Staried 26 days age

add deseripion T 2min on master

Mo changes.

Started by user anonymaus

1=
P
¢
‘st Rasult (2 fulores / 41)
e, 558 BO1APr i GDR T Simmary, ARIAP s DR e SummarClass B0IA_STRUCTURE GG SUMMARY

Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA data model
or project completion statements. Any errors of concern are communicated ahead of product delivery and
included within the product release notes.

Further detail on the Hudson CI System environment can be found by navigating to the following link:
http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson
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Hudson

Hudson » BDIA Product Validation CO

4 Back to Dashboard
O status

“2 Changes

@ workspace

D) uild tiow

© Delete Project

Vs Configure

Iig o=

@5 Build History (trend)

£280  Dec 22, 2010 0:47:08 AM

£279  Dec21, 2010 11:41:46 AM

#272  Dec17,20109:41:12 PN
CO S0W deliverable validation

Dec 1, 2010 8:16:58 AM

Final QC on SOW monthly CO product
Nov 18, 2010 9:56:35 AM

2271

2270

2260  Nov 18, 2010 0:49:09 AM

#268  Nov 18, 2010 9:22:49 AM
#267  Nov 18, 2010 9:08:05 AM
QC on S0W monthly CO product
#266  Sep 29,201011:12:08 PM
#265  Sep 26,2010 1L:17:56 PM
€O validation build

#264  Sep 24, 201012:22:28 PM
#263  Aug 31,2010 1:29:41 PN
#262  Aug 31,2010 1:17:05PM

#261  Aug 31, 201012:22:02 PM

£260  Aug 30,2010 8:25:39 AM

Project name

Description

Discard Old Builds
Days to keep builds

Max # of builds to keep 20

This build is parameterized

BDIA_Product_validation_CO

<p=This job checks db integrity on file GeoDaiabass. </p>
<img sre=http://vermont:8080/job/SDIA_Product_validation_CO/plot/getPlotzindex=08uwidth=650a height=350>
" g D

<p>Latest Stats Reg <a href="htip: 14_Product_Validation_CO/lastSuccessfulBuild/artifact/SEDD_TRANSFER_counts_diff html">Link</a><p>
<p>Latest Provider Reg <a href="http: : D1A_Product_Validation_cO, - _dhiff.html">Link

<p>Latest Error Reg <3 href="http: : DIA_Product_Validation_CO/lastSuccessfulBuild/artifact/CO_error_summary_diff.htrml

"zLink</a=<p>

<peLatest CAL Reg : <a href="http: DIA_Product_Validation_CO) DD_TRANSFERAchorInstitutions_diff.htmi" Link o

ifnot empty, build records are only kept up to this number of days

i not ematy, only up to this number of build records are kept

String Parameter
Name TestMethodPrefix
Default Value Bp1a_STRUCTURE

Description

®® 006

String Parameter
Name GDBLocation
Default Value //3jaska/ReleaseCandidates/C0_20101117-1947

Description

®® e

Parent path for the release candidate GDE

3.11 Product Extract Data Delivery

Product delivery for MapConnect Broadband is handled two ways, depending on client requirements:
1) State Submittal

Data is submitted via SFTP site

Product Release Notes and QC Test Report accompanies the delivery

a)
b)

2) NTIA Submittal

a) Directions for using the NTIA State Broadband Data file submission tool
b)

c) Enter your username and password as provided to you from the NTIA program administrator.

Go to the following WWW web site: https://esupport.fcc.gov/statedata

FCC SUPPORT CENTER

Broadband State Data Management Tool

Broadband State Data Management Tool

Login
Pasaworis®

d) Clickin Upload afile field
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FCC Federsl
das .

FCC SUPPORT CENTER
Broadband State Data Management Tool Alaska (jgeorge@denali.gov) Logout

Upload File| | View Files

UPLOAD NEW FILE

* denotes required field

Upload File

Upload File* R
? C\Users|20100323142745 _offer20100323 pdf | Browse ATTACH FILE

f)  Logout/ Receipt using the Logout button in the Top Right of the screen
g) A receipt of submission is emailed to username e-mail address




