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1 Overview

The following describes the Data Gathering, Data Integration, Data Validation and Verification and Quality Control
processes utilized to create the Broadband Mapping Project’s April 1%, 2011 data submission.

To support various levels of technical and program knowledge, this white paper supplies both a high level
summary and a detailed process review.

2 High Level Review

2.1 Data Gathering - Providers

Broadband Service Area, Middle Mile Aggregation Points and Broadband Service Overview
The collection of Broadband Service areas, Middle Mile Aggregation points and Broadband Service Overview
information is handled through the following Provider Outreach Process:

e  Build and Maintain an Inventory of Broadband Providers through research and State inputs.
e Update Provider Material that describes the data requirements and logistics for data transfer.
e Update NDA for use in project, where applicable
e Maintain multiple protocols for the provider to submit data, including SFTP technology when desired.
e  Conduct one-on-one informational discussions with each provider to communicate the following:
o Requirements of this project
o Broadband data required to support the product data model
o Submission protocols available
o Capability to validate how the supplied data is aggregated

e Download/receive Provider Data
e  Establish a repeatable process with Provider. Maintain Provider communication, transaction and data
handling records throughout the project (dates contacted, data received, etc.)
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2.2 Data Gathering - Community Anchor Institution (CAl)

The collection of CAl information is handled through the following CAI Collection Process:

Collect and maintain inventory of CAls through Data Mining, research, and State inputs.
Maintain web-based CAIl portal for institutions to add or confirm attribution, location and enter
broadband-specific information.

Upload web-based data to Core Database for standardization.

Perform internal cleansing, such as removing duplicate records, identifying gaps in broadband attribution
and verifying category.

Geocode CAl locations.

Translate Core Database data to deliverable ready format.

Continue engagement with non-responsive institutions.

2.3 Data Integration Process

The data integration and processing mechanisms currently utilized allow for multiple types of inputs and results in

a standardized output that meets the NTIA deliverable requirements. This process is flexible to support data model

changes and project requested enhancements.

Receive inputs from Providers via submission protocols, upload into Sourcing Database and catalog with
provider information.
Review Provider supplied data for completeness and for potential discrepancies that require resolution
prior to processing and flag as necessary.
Categorize input into data type category (addresses, block lists, paper maps, etc.).
Standardize input based on data type within Staging Database.
Create Compact Polygons (CP)—(internal methodology for generating area based feature for coverage in
Staging Database).
Apply broadband attribution to CP, Apply metadata to CP
Perform quality analysis of the CP against the source supplied to identify any completeness or accuracy
issues.
Request additional information from the provider if elements of coverage are missing or contain
discrepancies. This is a second manual quality check to ensure data is complete. Following completion of
CP creation, process steps within Data Validation & Verification occur

o Process coverage area to build the required NTIA data model layers

Process CAl data input into internal standardized format, as mentioned above under CAl Create Product
Deliverable based on NTIA and State-level requirements.
Following the creation of the product, process steps within Data Validation & Verification occur
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2.4 Data Validation & Verification

To ensure the data collected and processed is as accurate and comprehensive and possible, provider validation and
internal verification activities are utilized. Following the initial mapping of providers’ coverage area and
serviceability claims, additional reviews are performed using the following methods:

e  Third-Party Data Verification: Visually and programmatically compare the coverage against third-party
data.
Pitney Bowes and American Roamer data are used in cases where a coverage area is questionable. All
anomalies identified during this analysis are reviewed with the providers.

e Broadband Provider Validation — Provider Portal Application: Providers are trained on and requested to
use a secure interactive web application to review their current coverage area(s) and supporting
broadband attribution and validate their data or submit change requests to update their data.

All provider change requests go through the Data Integration Process and a review with the provider to
complete validation.

e Confidence Values: All Verification, Validation, and manual quality review results are tracked by provider
/ technology type and stored and maintained within a “Validation” table. A confidence value is assigned,
based on internal assessments of the collected information, to highlight the provider coverage areas
and/or attributions that would benefit from further investigation and/or enhancements.

2.5 Quality Control

Following collection, processing and analysis of the provider and CAl data, the product is checked manually and
algorithmically against the NTIA data model. Some of the items included within these checks are as follows:
e Format Correctness
e Table & Field Structure
e Valid Values
o Including default values, where applicable

Geographic Extent and Topology Errors

Prior to data submission, another quality control script supplied by NTIA is run. This script,
SBDD_CheckSubmission.py, creates an output in text form that is required to be submitted along with the final
deliverable. All errors must come up clean, unless otherwise specified from NTIA.
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Exceptions to the script as noted by NTIA on the SBDD Workspace on 03/25/11 at the following link:
https://sbdd-granteeworkspace.pbworks.com/w/page/38218329/CheckSubmissionExceptions

- Longitude values for States outside the lower 48 (any table)
- CAl results for Transtech, MaxAdUp, MaxAdDown if BBService is ‘No’ or ‘Unknown’
- Overview MaxAdDown, MaxAdUp if 100% of record level data has MaxAdDown or MaxAdUp

populated
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3 Detailed Process Review

Below is a detailed review of the data collection, integration and quality control points along the broadband data
gathering and mapping process.

Diagram of overall process:
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3.1 Provider Outreach

For the April 2011 data submission, an e-mail notification was sent to all providers with supporting deliverable
dates. The Provider Portal web application was released and training webinars held so providers could use this
application to submit changes to and/or validate their current coverage area(s).

Data was also collected from the providers via e-mail and SFTP, depending on their comfort level to submit data in
time for the April 1* deadline.
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In support the data collection effort, providers that did not timely respond to the outreach were contacted by
phone.

3.2 Outreach Materials

The original provider packet sent via email to the providers included the following documents and files:
1) Letter from the State inviting them to participate in the program
2) Copy of the non-disclosure agreement (NDA)
3) Copy of the Mapping NOFA from the NTIA
4) Copy of the NOFA Clarification from the NTIA
5) Broadband service address example file in CSV format
6) Word document describing service address example file
7) Broadband service block example file in CSV format
8) Word document describing service block example file
9) Broadband service street example file in CSV format
10) Word document describing service street example file
11) Broadband subscriber example file in CSV format
12) Word document describing subscriber example file
13) Broadband wireless coverage area sample shapefile
14) Word document describing wireless coverage area sample shapefile
15) Instructions for downloading, installing, and using the WinSCP secure FTP application

3.3 Outreach Process

The provider outreach process is comprised of the following general steps:

1) Send the provider package and introduction letter to the main point of contact for the provider

2) Follow up with email and call to verify that the main point of contact is correct.

3) If necessary, discuss the NDA further and resolve any redlines.

4) Once the correct primary contact is established, set up a call, if necessary, to learn more about the
provider’s offerings and direct them to the appropriate outreach materials.

5) If providers are unable to be contacted (non-responsive) or indicate that they are not interested in
participating (non-cooperative) mark them as such on the provider tracking sheet. These providers will be
escalated to the state for further action.

6) As the providers are collecting the required data, provide instruction on downloading, installing, and using
the WinSCP secure FTP application, if required.

7) Arrange with the providers to transfer the data in whatever way they are comfortable. Some providers
will find regular email acceptable. Others will want to use the secure FTP application.

8) After data is received and reviewed, it may be necessary to contact a provider for clarification or to
address incomplete data sets. In the interest of building and maintaining relationships, care is given not to
push the provider but to work with it to obtain accurate data in the best possible format.
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3.4 Data Collection

3.4.1 Data Transfer Procedures

There are three primary ways data is collected from providers. These are:
1) Secure FTP using the WinSCP application

2) Regular email

3) Mail

3.4.2 Initial Data Review and Quality Assurance

The initial data review and quality assurance process consists of the following general steps:
1) Access the data from the secure FTP site or email

a. If emailed, place copy of original data set in the appropriate provider folder on the secure FTP
site

2) Place copy of raw data on local computer in a working directory.
3) Review data and determine course of action based on type of data received.
4) Ensure data is complete and contact provider to address any gaps.

Note: The goal is to get as many providers as possible to provide subscriber address data in the correct format.
Obviously, this will not be possible with all providers so we will continue to have to process various types of
provider-supplied data.
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3.5 Data Ingestion

3.5.1 Data Ingestion Overview

The following outlines the process steps taken based on the type of input supplied by the data provider:
Point Data

e  Subscriber location

e DSLAM location

e  Central Office location

e Broadcast Tower location

Linear Information
e TIGER street segments

Polygonal Information
e  Census Blocks
e Coverage Area

Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to append to
the bb_cov feature class. The bb_cov feature class is the interim data set that is then processed using the
makeDeliverable.py Python scrip to create the MapConnect data layers that will be delivered to the state and,
ultimately, to the NTIA. Following are the detailed instructions used in this process.

3.5.2 Point Data
3.5.2.1 Subscriber Location — Address Data

In the event that the data provider supplies subscriber address data the following actions occur:

1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data format.
a) Usually, this has the following columns: street address (number, pre-directional, pre-modifier, street
name, street type, post-directional, and post-modifier concatenated together), city, state, ZIP.
2) Configure the ArcGIS geocoding tool to use the TIGER 2009 streets dataset
a) In ArcCatalog, create a new Address Locater by right-clicking in the white space of the appropriate
directory and selecting New>Address Locater from the dropdown menu.
b) Select “US Streets with Zone” and press OK.
i)  Note: It is likely that multiple Address Locators will have to set up to handle the variety of
provider address data received.
c) Navigate to the TIGER Streets 2009 file and press OK.
d) Fillin the dialog box as seen below:




New US Streets with Zone Address Locator
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Name: [ cO_Geacode_TIGER _2009] Input Address Fields
Besorio | US Strests with Zone The field containing: is recognized if itis named:
Primary table ] Zone ggd" . S
ee
Reference data: Delete
| Ci\Working'\Broadband \BaseData \TIGER.,_Streets.shp =
&
[v Store relative path names J J
Fields
Matching Options
House From Left: |LFROMADD ﬂ
Place Mame Alias Table... | <Monex
House To Left: |LTOADD ﬂ
House From Right: |RFROMADD ﬂ Spelling sensitivity: 80— ..
- Minimum candidate score: e
House To Right: |RTOADD ﬂ = o 8 o 0 0 0 0 0 o 0 o
e |<None:> ﬂ Minimum match score: 8 . .JT
Prefix Type: | <None> j Intersections
Connectors: &|@ Separate connectors by &
Street Name: [FULLNAME ~| l space, e.0. "B @, [°
SRR | <None: j Qutput Options
BRI |<N°“E> j Side offset: [20 in |Feet j
Left Zone: |zipL | End offset: |3_ % ~fp—
Right Zone: |ZIF‘R j ¥ Match if candidates tie
Cutput Fields
[~ ¥and Y coordinates [ Standardized address
[ Reference data ID [ Percent along
Help | Advanced. .. OK. | Cancel
e) Click OK.

3) Open up ArcMap, and add the Excel spreadsheet with the address information.

4) Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.
5) Select the appropriate address locator by clicking Add.... then OK.




% Choose an Address Locator to use...

Mame | Description | Add...
& CO_Geocode_TIGER_2009 L5 Streets with Zone

Cancel

6) Fill out the Geocode Addresses dialog box as shown below:

Geocode Addresses: CO_Geacode_TIGER 2009 RPIx
Address table:
|Fiber5 j =
Address Input Fields
Street or Intersection: FULL_ADDR -
Zone: 7IP_CODE -
Output
(¥ Create static snapshot of table inside new feature dass
~
QOutput shapefile or feature dass:

C:\Working"Broadband\ProviderData\Glenwood Springs glenwooc

Advanced Geometry Options. .. |

Geocoding Options. ..
Help oK | Cancel |

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all the default
parameters.
8) Review results.
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Shaow results: |A\I Addresses j Manage result sets... | Refresh Rematch Automatically ‘
B Matched: 97(88%)

| FID | Shape | Status | Score | Match type | Side | 2 | [ Tied: 5 (5%)

» 0] Point [ 81 A L 201 CENTENNIAL DR, 81601
N 1 |Point W 81 A L 201 CENTENNIAL DR, 81601 — | W Urmatched: 8 (7%)
H 2|Point " 81 A L 201 CENTENNIAL DR, 81601 -
H 3Point " 100 [A L 210 CENTER DR, 81801
B 4|Foint " 81 A L 15 MARKET DR, 81601
H 5 Point " 81 A R 40 MARKET DR, 81601
6| Point u 0 A
] 7|Foint T 51]A L 58627 SOCCER FELD RD, 81601
H 8|Point " 100 A L 125 STORM KING RD, 81601
B 9| Point " 60 /A L 52800 TWO RIVERS PLAZA RD, 81601
L 10| Paint u oA
H 11 Point " 81 A R 40 MARKET DR, 81601
B 12| Point T 63/ R 2698 GILSTRAP CT, 81601 -
< | 3
Record: ﬂj 1 jﬂ Records (of 110)

Address: 1 Candidate Candidate details:
Strestor Intersecton 01 e | |2 v | side | Match_addr LeftFrom | LefiTo | RightFrom | RightTo Frm [201 [ 200
one TETeE— 81 L 201 CENTENMIALDR, 81601 201 29 0 28 To [0 [ 28

PreDir
PreType
Streetiame | CENTEMMIAL
StreetType DR
Sufbir
Zone 81601 | 81601
Score 81
Side L
Match_addr [201 CENTENNIAL T

Standardized Address:

201 | | CENTENNIAL | ST | |31601 < kd
Geocoding Options... | Zoom to Candidetes | <. pid Address from Map | Search | | unmatch | | oo |

9) Adjust geocoding parameters accordingly and repeat batch to resolve issues.
10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.
11) Visually inspect the data as seen below:
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. provider_data_QAQC.mxd - ArcMap - Arcinfo

Flle Edit View Bookmarks Insert Selecton Tools CH2M Window Help
Leds B ) + 1:52.481 < || & @ B 3| %2 | sditor ~ - [Ceaenenreae 7]
Geareferencing ~ ArcPad Data Manager ~ | 42 4% 48 | Gi Spatial Anal
30 Analyst ¥
& [
= ] Geocoding Result: glenwood_tryl @ *
. wx
ax
= [0 TIGER Streets .
— %
- B COUNTIES M
[} )
= O B8_ConnectionPeint_MiddleMile
. -
= HIGHWAYS
= B FCROADS 18 |
= [ EB_Service_Road_Segment X
= CITIES [i]
= [0 BB_Service_CensusBlock I’:
= POt
- O B8_service_Overview N
f==1
= [ BB_Service_Wireless
[}
= O communicomm_coverage_area
o &l
=l [ wired_coverage_sample_was§4
O
" N /ﬂ
Display | Source | Selection @0 ”ﬂ J j
Draving ~ K O~ A~ @) Anal -0 -] B U A By Fx o~
-107.326 39.557 Decimal Degrees

12) Follow the steps detailed in Subscriber Location — GIS Data below

3.5.2.2 Subscriber Location — XY Data

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and longitude, the
steps are as follows:
1) Refine the format in Excel so that the data can easily be opened using ArcMap.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and make
sure there are no merged cells.

b. Make sure that XY locations are in decimal degrees.

i. To convert from degrees, minutes, seconds (392 26’ 45.67”) to decimal degrees us the
following formula: DD + (MM/60) + (SS.5SS/3600).

ii. Note: if XY locations from some other coordinate system are provided, you can use
those in the process below but you must know what the coordinate system is.

2) Open up the Excel worksheet in ArcMap.

3) From the menu bar, select Tools>Add XY Data...
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Add XY Data

Atable containing X and Y coordinate data can be added to the
map as a layer

Choose a table from the map or browse for another table:

| Forlmports j g

Specify the fields forthe X and Y coondinates:

¥ Field: | LONG

[~
=

Y Field: ||_,'.\T

Coordingte System of Input Coordinates

Description:

Geographic Coordinate System:
MName: GCS_WGS_1584

[ Show Details

W Wam me if the resulting layer will have restricted functionality

0K | Cancel |

4) Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate system and
press OK.

5) Results are an event layer, not a true spatial layer. Export the data by right-clicking the event layer and
selecting Data>Export Data... from the dropdown menu.

6) Follow the steps detailed in Subscriber Location — GIS Data below.

3.5.2.3 Subscriber Location — GIS Data

If the provider supplies subscriber location in GIS format, the only process step is to load that data into the
appropriate data schema and it will be ready for processing.
1) First, load the data into the Point Address database schema (please see Appendix D for an example of the
Point Address database schema.) using an empty feature class in that schema.
2) In ArcCatalog, right-click on the empty feature class and select Load from the dropdown menu.

3) Navigate to the provider address GIS data set and then map the attribute fields accordingly, as seen in
general below:




5 1:..‘.”&\‘(,/%"
S

4)

5)
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field ~
| =treet_id [int] <Mone= =
| =side [ztring] =Mone>
|| feature_id [in] <Mone>
| point_type [=hort int] <Mone=
| | 2dd_house_num fstring] |BLoG_Num stringl __[Rd|
| add_pre_dir [3tring] PRE_DIR [=tring]
| add_pre_type [tring] =Mone=
| add_nams_body [string] STREET_NM [=tring]
| add_suf_type [string] SUF_TPE [=tring]

add =uf dir [2tring] SUF TYPE [=tringl b’

Reset

< Back | Mext = | Cancel

Once you have successfully loaded the provider address data into the temporary database with the
correct schema, you will now append that data to the overall Point Address database.

In ArcToolbox, use the Append command (Data Management Tools>General> Append) to add the
features into the overall Point Address database, as seen in general below:
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CEX
~
Input Datasets

C:\Working'Broadband\Provider_Data_Example.gdb{Temp_Address

l& [2 [X |+ &

Target Dataset
| C:\Working'\Broadband\Provider_Data_Example.gdb\Address_Database

Schema Type (optional)
| TEsT
Field Map {optional)

le 2 X |+ 1 |&

v

oK | Cancel | Environments. .. | Show Felp =%

6) Since the data is already in the Point Address database schema, there is no n need to alter the Field Map
in the Append tool.
7) After appending, calculate metadata reflecting geometry source and representation values.
8) Break provider-specific points into separate county feature classes and perform the following steps per
county feature class:
a. Within ArcGIS
i. Summarize download and upload speeds [first,last] to determine all speeds available for
county.
1. This will save as a DBF table. Keep track of location for future reference.
ii. Buffer county address point featureclass to 150’.
1. During buffer command, dissolve on “ad_down”; "ad_up”; ”provider”; “dba”;
“frn”; “tt”; ‘all metadata fields’; “stctyfips”. Save as....
county_fastestdown_fastestup.
2. (Example using Qwest data: boulder_40128_20128, where boulder=county;
40128=ad_down; 20128=ad_up)
3. Note: these attribute fields are specific to the Point Address database.
iii. Select the features that represent the lowest speeds
b. Using XtoolsPro (http.//www.xtoolspro.com/)

i. Inthe XTools Pro toolbar, select XTools Pro>Layer Operations>Erase Features
ii. Use the same feature class for Input and Overlay
iii. Check Use selected features on the Input feature, as seen below.



http://www.xtoolspro.com/
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Repeat and erase slowest speeds one speed at a time. Saving each new feature class as
the next slowest speed, using the same naming convention as above. A general example

is seen below:

Erase Features

Input feature layer:

|[E boulder_12128_896 |
¥ Use selected features
(1/2 feature selected)
Qutput storage:
| Ci\Working\Broadband\ProviderDat.. . \boulder_7168 896

¥ Add output feature dass to current map
¥ Create spatial index

Qverlay layer:

|[E boulder_12128 896 |
[ Use selected features (1 feature is selected)

Help OK | Cancel

c. Within ArcGIS
i. Edit/delete speeds from the attribution table of each feature class, so each remaining

feature class has only one speed value.

Merge individual speed feature classes together using the Merge command in
ArcToolbox (Data Management Tools>General>Merge). The dialog box is seen below:
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4 Input Datasets

4 Output Dataset

Field Map {optional)

X [+ & |e]2 2]+ &

b

OK | Cancel | Environments... | CERow Help =R

iii. Merge individual county feature classes together using the Merge command in
ArcToolbox (Data Management Tools>General>Merge).

iv. Since the county files are all in the same schema, do NOT alter the Field Map portion of
the command interface.

v. When all the county files are merged together into one dataset, use the Append
command in ArcToolbox (Data Management Tools>General>Append) to add the
features to the bb_cov interim data set. Use the Field Map portion of the Append tool to
map the appropriate field values to their corresponding fields in the bb_cov feature
class.

3.5.2.4 DSLAM or Central Office Location — Address Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office address
data please follow the steps below:

1) Follow the process for geocoding points in Subscriber Location — Address Data, above.
2) Follow the steps detailed in DSLAM or Central Office Location — GIS Data below.

3.5.2.5 DSLAM or Central Office Location — XY Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office XY data
please follow the steps below:

1) Follow the process for creating points from XY data in Subscriber Location — XY Data, above.
2) Follow the steps detailed in DSLAM or Central Office Location — GIS Data below.
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3.5.2.6 DSLAM or Central Office Location — GIS Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office GIS data
please follow the steps below:

1) Buffer the DSLAM/Central Office points feature class
a) Add the point feature class to ArcMap
b) Open up ArcToolbox and go to Analysis Tools>Proximity>Buffer
c) Set the buffer distance to 5 miles
d) Set the dissolve type to ALL
e) Name the output feature class
f)  Typical Buffer tool is seen below:

Input Features

| Columbine
Qutput Feature Class

@

| C:\Working'Broadband\ProviderData‘\Columbine \Columbine_Buffer_2.shp ﬂ
[~

I~

[~

[~

[~

A

Distance [value or field]
(+ Linear unit

[ 5 |miles
" Field

Side Type (optional)

End Type (optional)

Dissolve Type (optional)

Dissolve Field(s) (optional)
Ormo

O company

Ooea

Orrn

O excHANGE

Ostate

OrrovIDER
Ocui_cooe

MecorT bt
£

oK | Cancel Environments... | Show Help == |

g) Press OK
2) Use the resulting buffer feature class to clip the TIGER street layer (as described earlier):
a) Add TIGER street layer to ArcMap
b) Open up ArcToolbox and go to Analysis Tools>Extract>Clip
c¢) Complete the dialog box as seen below:




3)

4)
5)

6)
7)
8)

9)

Input Features
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| TIGER _Streets
Clip Features

| Columbine_Buffer
Output Feature Class

| C:\Working\Broadband\ProviderData\Columbine\columbine_TIGER _dip.shp
¥Y Tolerance {optional)

Meters

oK Cancel | Environments. ..

| Show Help => |

d) Press OK.
Using ArcCatalog and within the file geodatabase:

a) Right Click and create a new Feature Dataset

i)  For the Feature Dataset settings:

(1)
(2)

(3)
(4)
(5)

Name the feature dataset accordingly

Select horizontal coordinate system by importing the coordinate system associated with the
clipped TIGER street layer by selecting Import and navigating to the location of that feature class

No vertical coordinate system needed
Leave all x,y,z,m values at default.
Press Finish

Import previously created street feature class into new Feature Dataset

Right-click Feature Dataset and create new Network Dataset — accept all default setting for the Network

Dataset

a) Note: the Network Analyst extension must be turned on

In ArcMap Turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst
Add the Network Dataset created in Step 5 to ArcMap
Using Network Analyst Toolbar drop down — create “New Service Area”

Open up the Network Analyst Window by selecting the E button.
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|Service Area j
Facilil:iﬁ (1))

Polygons (0)

Lines (D)

Barriers (0)

10) Right click Facilities layer, select Load Locations, and navigate to the DSLAM/Central Office facilities feature

class.

Load Locations. Elfg\

Load From: El columbine_paints j W

¥ Only show point layers

-

Sort Field: | j

Location Analysis Properties

Property Field Default Value

Mame
CurbApproach Either side of vehicle

Attr_Length o
Breaks_Length

Location Position

% Use Geometry
Search Tolerance: | 5000 Meters j

" Use Metwork Location Fields

Property Field
SourcelD

Source0ID

PosAlong

SideOfEdge

Advanced... Cancel

11) Press OK.

12) Click the Service Area Properties button

13) For the following tabs change the following properties:
a) “Polygon Generation” tab
i) Select “Merge by break value”

ii) Also disable the Trim Polygons option
b) “Analysis Settings” tab — using and converting the specified DSLAM buffer distance from feet to meters —

input buffer distance value in meters into the “Default Breaks” location




14
15

16
17

—_— —

~— —
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i)  Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used as the buffer
distance

Layer Properties

Line Generation ] Accumulation ] Network Locations ]
General ] Layers ] Source Analysis Settings l Polygon Generation ]
Settings Restrictions
Impedance: |Length (Meters) ﬂ
Default Breaks: |54351
Direction;

v Away From Facility
" Towards Facility

Allow U-Tums: |Everywhere ﬂ

v lgnore Invalid Locations

QK | Cancel Apphy

c) Click OK.

On the Network Analyst Toolbar click the “Solve” button ﬁ to create service area polygons.

Right-click on the created service are polygon in the layer list, and select Data>Export Data from the dropdown

list.

Export to a feature class in the file geodatabase you created earlier

In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the feature

class created in Step 16 into it.

a) Right-click on the empty feature class, select Load>Load data from the dropdown menu and navigate to
the location of the service area feature class

b) Pressthe Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field IMatching Source Field ”~

|Prquame [string] <Nones =
| DBAName [string] <MNone>
| FRM [int] =Monex
_| GeegUnit [string] <None>
| GeogUnitiD [string] <MNone>
| TransTech [short int] =None=
_| MaxAdvDown [ghort inf] <None>
| MaxAdvUp [short int] <MNone>
| ARPU [float] =None=

SWHomSpeed [float] <None= b

Reset

< Back | Mext = | Cancel

e) Press Next, then Next again, then Finish.
18) In ArcToolBox, go to Data Management Tools>General>Append
19) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets =

| = @

Target Dataset
| C:\Working'Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov ﬂ

Schema Type (optional)

=
=]
#|

Field Map {optional)

QK | Cancel Environments... | Show Help == |
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20) Leave the Schema Type as TEST
21) Press OK.
22) In ArcMap, open up bb_cov for editing and manually input associated attribution.

3.5.2.7 Broadcast Tower Location — Address Data

In the event that the provider supplies wireless broadcast tower location address data please follow the steps
below:

1) Follow the process for geocoding points in Subscriber Location — Address Data, above.
2) Follow the steps detailed in Broadcast Tower Location — GIS Data below.

3.5.2.8 Broadcast Tower Location — XY Data

In the event that the provider supplies wireless broadcast tower location XY data please follow the steps below:

1) Follow the process for creating points from XY data in Subscriber Location — XY Data, above.
2) Follow the steps detailed in Broadcast Tower Location — GIS Data below.

3.5.2.8.1 Broadcast Tower Location — GIS Data

In the event that the provider supplies wireless broadcast tower location GIS data please follow the steps below:

1) Download the required software (Radio Mobile) from the website:
http://www.cplus.org/rmw/english1.html

2) Install the software according to the standard directions, found here:
http://www.cplus.org/rmw/download/download.php?S=1

3) Open up the application
4) Load the broadcast tower location and elevation information by selecting File>Unit properties. The
following dialog box appears:



http://www.cplus.org/rmw/english1.html
http://www.cplus.org/rmw/download/download.php?S=1

BROADNMAP

Beyond The Boundaries

?"\ Units properties

Marne Elewvation [m)
Athena y Althea + 2832
Caribiou | J
Chipeta "

: Pozition Clear
Efgﬁ:;':% A0°D4ZEEH 105°3033.1 W Q
Herizon Loz DN7OFE Faste
Littlerawen
M anzanala-H [ Locked
M anzanalaf
Moohstone Enter LAT LOM or QRA Move up
Firata
Temapin Maove down
REE’D Place unit at cursor position
Wapit %

Place cursar at unit position Import ‘

Shyle Sart
[v¥ Enabled " Left * Centre " Right

Apply style
[ Transparent
™ Mo label B ackColor ‘ ForeColor W Sl fort
lcon 16x16 pikels
Al I

I~ Show only urits that are members of a visible network

5) Add in the information for all the towers supplied by the WISP data provider, including the elevation. If
provider does not supply elevation, this information can be obtained from Google Earth.
a. |Ifavailable, use the Import button to import a Google Earth KML of the tower locations.
6) Go tothe National Map Seamless Server (http://seamless.usgs.gov/) and download elevation data

sufficient to contain the tower locations.
a. Atleast the 1/3” NED data is needed. Select this by clicking the Download button in the upper
right of the web site and checking the box nect to 1/3 “ NED.
b. Zoom to the area of interest and use the Download tools:

IDuvmluads
T[] [ e
=

to define the area to download.
c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI GRID, as
seen below:



http://seamless.usgs.gov/
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) The National Map Seamless Request Summary Page - Mozilla Firefox

http:fextract.cr.usgs. gov Website fdistreq/RequestSummary. jsp?PR =0&CU=Native 87X =-1.087Y =-1.08ML=C 5

The National Map Seamless Server

Request Summary Page
You are logged in as Default Seamless User.

ify Data Request HELP!

Data Exiraction Requesi Piece:
National Elevation Dataset (NED) 1/3 Arc Second

< USGS

EROS Data Center

Done @ %" M 4o frank@gmail.com

d. Download the data and unzip it.
7) Select File>Map Properties to define the map
8) Enterin a latitude and longitude in the center of the tower locations
9) Set the size (in pixels) and the size (in kilometers) of the map
10) Set the directory path leading to the BIL elevation data just downloaded
11) The dialog box is seen below:

Properties of ..\default.map

Centre Size [pixel]
4003288 10572927 6w widthipixels) Height (pixes) Estract
DM7OGE 1000 1000
Latitude Longitude
40,058 -105 451 Size (k] Cancel
Wwidth(km] Height [km] —_—
|Jse cursor position ‘ 100.00 Top Left
4073029
‘Waorld map ‘ Elevation data source T0E04447/
Drive or path Top layer Tap Right
Select a city name ‘ |B|L ﬂ |c:\geodata\bil\b0ulder Browse... AD°3023"N
10475477 %

Enter LAT LON or GRA, Nore  ~| | Browse... Battam Left
39°36°29"N
v B 1067 04'44" "
|Selectaunit ﬂ |Nc-ne J | owse
Bottom Right
|Nc-ne ﬂ | Browse. . I IETTN

[~ Adjust units elevation |None ﬂ | Browee 10475477
M ict Resolution
| [tz pisies [~ lgnore mizsing files Botton laper 100.0 mpixel

Iv Force gray scale Initialize matriz with elevation (m) |0 3.24 aicsecond




12) Hit Extract.
13) The elevation data is render as a hill shade, as seen below:

\default.net - Radio Mobil
E]Flle Edit View Tools Optons Window Help ZStop

Dﬁﬁﬁ*&l@ﬁ@@*\[ﬂ[‘ﬂrﬁ@|§\

| | ﬁeady [40°05'34"N 105"17'13"W =673 Y=4611724.1m /‘I

14) Select File>Network properties from the main menu
15) Create a new network and enter in the frequency range under the Parameters tab, as seen below:




Networks properties
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Minimurn frequency [MHz] | 2400
M azimum frequency (MHz) |2400

Pelarization
f* Wertical " Horizantal

Mode of wariability

f+ Spot % of time
("~ Accidental
% of locations
™ Mobile
% of zituations
(" Broadcast 7

Default parameters Copy Met Cancel ]
List of all nets
MHedret
Jade Parameters Topology tembership Sustems | Style
Qluray
0 b ol
et Net name Surface refractivity [M-Units] W
|Nedemet

Ground conductivit [5 /) e

Fielative ground permittivity l—
15

Clirnate:
" Equatonial

" Continental sub-tropical
" Maritime sub-tropical

Desert

DI

Continental temperate
td aritime temperate aver land

td aritime temperate over zea

16) Leave all the other values as they appear, and select the Systems tab

17) Create enough systems to cover all the varieties of equipment in the provider network. This will include

the antenna type, height, and line loss, as seen below:




Networks properties

Default parameters Copy het Cancel ak
List of all zpstems
O |
g0 Parameters | Topology | tembership ‘ Systems ‘ Style |
120
Syztem 4
Spstemn 5
Sﬁstem E |D1 ﬂ |Select from Fladiosys 0. dat ﬂ
System 7
Jystem 8 System name | Omiri
Systemn 9
System 10
Sﬁztgm 1 Tranzmit power (watt] |100 [dBm] |50
System 12
gystem:lli Receiver threshald [pv] |1 [dBm) |-107
ystenn
gﬁz:zm 12 Line lozs [(dB) |1 [ Cable+cavitiez+connectars |
System 17 -
System 18 aenape [P -] Ve
System 19
e Antenna gain (dBi) [15 [ded) [12.85
System 22
System 23 Antenna height [m] |3 [ &bove ground |
System 24
System 25 Additional cable loss (d8/m) [0 [ IF anterina height difers —

Add to Badiozys01.dat Remove from B adiozys01 dat

18) Now click on the Membership tab, and assign the individual towers to their respective systems, providing
the azimuth for non-omnidirectional antennas, as seen below:




19)
20)
21)

22)

Networks properties

Default parameters | Copy Met ‘ ‘ Cancel | 0K
List of all nets
Wednet
Jade Parameters ‘ Topology | Memberzhip ‘ Spstems ‘ Style
COuray
COkobile
I edernet List of all unit Member of Medermet
Met B = ;It}? Lnts Ruole of &thena
Met 7 W 23 A
Met 8 ™l thena - |C°"“"“E""":| ﬂ
Hel 'ISD | Caribou System

et v Chipeta
5] -
Met 11 | Frankling | J
Met12 HorizoreE .
et 13 4 arizar Antenna height [m)
Met1d W Horizor-
Met15 v Littleraven — (" System g
Met 18 | ManzanalaH
Net 17 | tanzanala £ Other
H:::‘Ig | Moonstone
Net 20 v Firata Antenna direction
et 21 w' T ermapin —
Met 22 v| Tohago |F'HBE|[ ! j
Net 23 L TL”H'_E_ Azimuth [ Elevation angle [*]
Met 24 | W apiti
Net 25 |50 o
7 Wiew pattern |
Press OK.

Select Tools>Radio Coverage>Combined Cartesian from the main menu

Complete the dialog box as seen below, providing the Maximum Range from the highest tower beam

radius supplied by the provider.

Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of granularity) as

seen below:




] |Athea =
Antenna patten
P~ = In netwark, Cancel I
INedemel ;I
¥ Use netwark antenna seftings e i |
I~ Save raster data to file [T=T)
) Save settings
I~ Save raster data to file [SIG)
= I~ Save also units not selected Load data |
[~ Draw patten I~ Complete.way
I~ Save coverage pictures in “frames" directory
WiEr (T | v Mazimum range [km] I”52
Antenna height [m) i~ Link Direction b ol
E 9 * Mobie Fx &l picture
0 .
o . Backeolor | " Mobile Tx 1 Selection
S i~ Signal range to dra
I} & S-Unit ™ Bestunit From[>=]
E  dBm 5 i r
| To(<]
O o |4U—
= o B
] I~ Network style . Color
] Diaw size [pixels)
| L 5 I Rainbow I Soid

23) Set the signal range to draw to S-Unit and type 5 in the From (>=) box.
24) Press Draw.

[ Fle Edt View Tools

T ey

i |Ready [40°05'53"N 105*1510™ X=702 Y=455 1627m 4

25) Save the resulting image as a TIF by selecting File>Save Picture as.
26) Open ArcMap and load the BIL elevation data you used in Radio Mobile.
27) Load the TIF image you created and georeference it using the corners of the BIL data.




BROADNMAP

Beyond The Boundaries

a. The corners of the data can be seen in the TIF image.
28) Follow the georeferencing directions from the Coverage Area — PDF/JPG/Other Image Format section
below.
29
30

-

Use the Georeferencing Toolbar to Update the Georeferencing for the TIF data set.

-

In ArcToolbox, select Data Transformations>From Raster>Raster to Polygon and input the georeferenced
TIF you just created as seen below:

31

~

Open the resulting polygon feature class up for editing using the Editing toolbar in ArcMap and clean up
as necessary.

32) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the

~

feature class created above into it.
a. Right-click on the empty feature class, select Load>Load data from the dropdown menu and
navigate to the location of the service area feature class
b. Press the Add button, hit Next
c. Accept the defaults and hit Next
d. Do NOT attempt to map any fields, as seen below:

X

Simple Data Loader

For each target field, select the source field that should be loaded into it,

Target Field Matching Source Field L
|Pru'.fr-lame [string] <None>
| DBAName [string] <MNone>
| FRM [int] =None=
_| GeegUnit [string] <None>
| GeogUnitiD [string] <MNone>
| TransTech [short int] =None=
_| MaxAdvDown [ghort inf] <None>
| MaxAdvUp [short int] <MNone>
| ARPU [float] =None=

SWHomSpeed [floaf] <None= b

Reset

< Back | Mext = | Cancel

e. Press Next, then Next again, then Finish.
33) In ArcToolBox, go to Data Management Tools>General>Append
34) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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BX
-
Input Datasets

| Rl
C:\Warking'\Broadband'\ProviderData\Columbine\Columbine. gdb\service _area_bb... +
X

Target Dataset

| C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\bb_cov ﬂ
Schema Type {optional)

Field Map (optional)

Ey

| w

QK | Cancel Environments... | Show Help == |

35) Leave the Schema Type as TEST
36) Press OK.
37) In ArcMap, open up bb_cov for editing and manually input associated attribution.

3.5.3 Linear Data
3.5.3.1 TIGER Street Segments — List, Spreadsheet, or GIS Data

In the event that the provider supplies TIGER street segments in list or spreadsheet format please follow the steps
below:

1) Join TIGER road segments to 2000 census blocks feature class using one of two methods based on how
the data is provided:
a) Ifthe TIGER data is provided with a Census Block ID, then join the segments to the Census Block
geometry based on that ID
i) Load both data sets into ArcMap
ii) Inthe layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join
iii) In the dialog box, select the TIGER road segments data and the proper attribute fields for joining,
as seen below:
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Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?
|J0in attributes from a table ﬂ

=

. Choose the field in this layer that the join will be based on:

|BLKIDFPOD ~|

2. Choose the table to join to this layer, or load the table from disk:

(%> TIGER Streets =] =

[+ Shaow the attribute tables of layers in this list

3. Choose the field in the table to base the join on:
-

Join Options
+ Keep all records

All records in the target table are shown in the resulting table.
Unmatched records will contain null values for all fields being
appended into the target table from the join table.

" Keep only matching records

If a record in the target table doesn't have a match in the join
table, that record is removed from the resulting target table.

About Joining Data 0K | Cancel

iv) Press OK
b) If the data provided is a list containing TLIDs, then join to the TIGER line data using the TLID, and use
a spatial join to associate the TIGER segment with the coterminous block based on the block ID
i) Load both data sets into ArcMap
ii) Inthe layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join
iii) Select “Join data from another layer based on spatial location” from the dropdown menu
iv) Complete the dialog box as seen below and press OK.
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Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

1. Choose the layer to join to this layer, or load spatial data from disk:

[€ TIGER_Streets | =
2. You are joining: Lines to Polygons

Select a join feature dass above. You will be given different
options based on geometry types of the source feature dass
and the join feature dlass.

{+ Each polygon will be given a summary of the numeric
attributes of the lines that intersect it, and a count field
showing how many lines intersect it.

How do you want the attributes to be summarized?
[~ Average [~ Minimum [ Standard Deviation
™ sum [~ Maximum [~ variance

" Each polygon will be given all the attributes of the line that is
dosest to its boundary, and a distance field showing how
dose the line iz (in the units of the target layer).

Mote: A line falling inside a polygon is treated as being dosest
to the palygon, {i.e. a distance of 0).

3. The result of the join will be saved into a new layer.
Specify output shapefile or feature dass for this new layer:

|C:"-.‘.“.l'orking"-.Broadband"-.Temp"-Join_OutpLrt_5.shp =

About Joining Data oK | Cancel |

2) Export joined records into a temporary feature class.

3) If joined Census Block geometry is confined to one specific area then dissolve blocks into one record. If
joined Census Block geometry is distributed throughout a particular state then dissolve sub-selections of
census blocks for each county.

a) Use the County FIPS code to dissolve by county.
b) In ArcToolbox, select Data Management Tools>Generalization>Dissolve
c) Complete the Dissolve dialog box as seen below:




* Dissolve o [5__<
4

Input Features

| blocks_uTM x| =

Qutput Feature Class

| C:\Working'\Broadband\BaseData'blocks_UTM_Dissolve.shp =
A~

Dissolve_Field(s) (optional)
Orm

O staterroo
COUNTYFPOD
OTracTcenn
OeLockcenn
OsLxIoFron
Onaveoo

Owrrccon

Mirnn ¥
<

Select All | Unselect All
Statistics Field{s) (optional)

Field Statistic Type

P

oK | Cancel Environments... | Show Help ==

d) Press OK.

4) For each dissolved region, open up the feature class for editing using the Editing tool in ArcMap and
remove unnecessary slivers and other small holes. For general guidance on editing features in ArcMap,
see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing Tutorial.pdf

5) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the

feature class created above into it.

a) Right-click on the empty feature class, select Load>Load data from the dropdown menu and navigate
to the location of the service area feature class

b) Pressthe Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:



http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field IMatching Source Field ”~

|Prquame [string] <Nones =
| DBAName [string] <MNone>
| FRM [int] =Monex
_| GeegUnit [string] <None>
| GeogUnitiD [string] <MNone>
| TransTech [short int] =None=
_| MaxAdvDown [ghort inf] <None>
| MaxAdvUp [short int] <MNone>
| ARPU [float] =None=

SWHomSpeed [float] <None= b

Reset

< Back | Mext = | Cancel

a) Press Next, then Next again, then Finish.
6) In ArcToolBox, go to Data Management Tools>General>Append
7) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets =

| = @

Target Dataset
| C:\Working'Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov ﬂ

Schema Type (optional)

=
=]
#|

Field Map {optional)

b

QK | Cancel Environments... | Show Help ==
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8) Leave the Schema Type as TEST
9) Press OK.
10) In ArcMap, open up bb_cov for editing and manually input associated attribution if necessary.

3.5.4 Polygonal Data
3.5.4.1 Coverage Area — PDF/JPG/Other Image Format

In the event that the provider supplies coverage area data in some image format such as PDF or JPG format please
follow the steps below:

1) Ifin PDF format, open in Adobe Acrobat and Save As... JPG format.
2) Open up the JPG image in ArcMap.
3) Add the required basemap vector data for georeferencing.
a) This will generally be either the CDOT data or TIGER data
4) Change the coordinate system of the data frame to the desired end coordinate system
5) Zoom to the general location of the JPG map image
a) Thisis the location based on the vector data, not the JPG image itself. For example, if you know that
the JPG image represents an area around the town of Limon, zoom to the town of Limon in your
vector data.
6) Open up the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main menu bar.
7) Using the Georeferencing toolbar, select Fit to Display, results seen below:

T T-Fo e I
B LE I IE] |
OIS P L T ENIEEY

1 ity i

Seery -
Exp &

=

9393 % w8 Deomi

R
9 e s n A B g e

8) Use the Control Point button "Z'- to add control points to the map
9) Use common points in the base data set and the JPG image
a) For example, find major street intersections, county/city boundaries, etc.
b) Try to distribute the points more or less in the four corners on the image for the best transformation
10) Click on the location on the image first, then click on the corresponding location on the vector data base
map, as in the image below:
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11) After placing each control point, the image transformation will update automatically.
12) Repeat until satisfied with the transformation.
a) Note: The transformation may take up to four points, although sometimes only two are necessary.
13) When satisfied with the transformation, select Update Georeferencing from the Georeferencing toolbar
dropdown.
a) This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image file.
14) In ArcCatalog, create a new polygon shapefile with the appropriate data schema for a provider coverage
area, which can be found in Appendix D.
Add the shapefile to ArcMap.
Using the Editor Toolbar, select Start Editing. Set the Task: to “Create New Feature.”

15
16

— —

17) Use the Sketch Tool ‘? b to digitize a new coverage polygon using the coverage area outline from the

~

georeferenced JPG and add the required attributes manually.
18
19

-~

Repeat the above steps for all subscriber speed coverage areas provided.

~—~

Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.2 Coverage Area — KML/KMZ

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format please follow the
steps below:




5)
6)

BROADNMAP

Beyond The Boundaries

Use a KML to SHP converter to translate file into an ESRI format
http://arcscripts.esri.com/details.asp?dbid=15603

Download the script and follow the provided instructions for installing it in ArcToolbox.
Double-click on the script in ArcToolbox and navigate to the location of the KML file, as seen below:

£/ Convert KML to SHP (=13
KML File
| C:'\Documents and Settings\forr \Desktop\Google \fiupton. kml
Feature Type
| PoLYGON |
Output shapefile
| C:'\Documents and Settings\forr \Desktop\Google\fiupton_kml_to_shp.shp g

oK | Cancel | Environments...| Show Help >> |

Add the new shapefile to ArcMap. Repeat for all KML files provided.
Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.3 Coverage Area — CAD Data

In the event that the provider supplies coverage area data in GIS format please follow the steps below:

1)
2)
3)
4)

5)

6)
7)

8)

9)

Transform the CAD dataset into an ESRI format
http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming CAD datasets

It may be necessary to contact the provider first to determine the coordinate system of the CAD data.

If the CAD data is not in a standard coordinate system, it may be necessary to use ArcMap to
georeference the CAD data to a known coordinate system first.

a) Todo so, follow the instructions provided above in “Coverage Area — PDF/JPG/Other Image Format.”
In ArcCatalog, create a new polygon shapefile with the appropriate data schema for a provider coverage
area, which can be found in Appendix D.

Add the shapefile to ArcMap.

Using the Editor Toolbar, select Start Editing. Set the Task: to “Create New Feature.”

Use the Sketch Tool ‘? b to digitize a new coverage polygon using the coverage area outline from the
georeferenced CAD file and add the required attributes manually.
Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.4 Coverage Area — GIS Data

In the event that the provider supplies coverage area data in GIS format please follow the steps below:



http://arcscripts.esri.com/details.asp?dbid=15603
http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datasets
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1) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the GIS
feature class either created above or supplied by the provider into it.
a) Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate
to the location of the service area feature class
b) Press the Add button, hit Next
c) Accept the defaults and hit Next
d) Do NOT attempt to map any fields, as seen below:

X

Simple Data Loader

For each target field, select the source field that should be loaded into it,

Target Field Matching Source Field &
|Pru'.fr-lame [string] <None>
| DBAName [string] <MNone>
| FRM [int] =None=
_| GeegUnit [string] <None>
| GeogUnitiD [string] <MNone>
| TransTech [short int] =None=
_| MaxAdvDown [ghort inf] <None>
| MaxAdvUp [short int] <MNone>
| ARPU [float] =None=

SWHomSpeed [float] <None= b

Reset

< Back | Mext = | Cancel

e) Press Next, then Next again, then Finish.
2) In ArcToolBox, go to Data Management Tools>General>Append
3) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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Input Datasets

| =l @

C:\Working'\Broadband\ProviderData\ColumbineColumbine. gdb\service_area_bb... +

x|
il
3

Target Dataset
| C:\Working\Broadband \ProviderData\Columbine\Columbine.gdb'\bb_cov j
Schema Type (optional)

Field Map {optional)

[+ L] &

‘ w

O | Cancel | Environmems...| Show Help = |

4) Leave the Schema Type as TEST
5) Press OK.
6) In ArcMap, open up bb_cov for editing and manually input associated attribution, if necessary.

3.5.4.5 Compact Polygon From Subscriber Points

e Geo-code address list using latest state “Composite Locator”

e Verify that your geo-coded file has only one TT (Technology Type). If not export individual geo-coded
layers for each Technology Type.

e  For each TT check for differences in speed values or speed tiers and create separate layers for each speed
value/tier.

e Clean your geo-coding results - remove any points that geo-code to accuracy levels below ZIP+4 (ZIP
centroids, carrier route centroids, etc). Also, verify that outliers with acceptable accuracy levels are
legitimate, i.e. fall in correct City and Zip.

e  Perform spatial join between county polygons (using stcnyfips field) and the cleaned geo-coded subscriber
points, in order to carry the county name and stcnty fips.

e Summarize the number of subscribers by county and use the subscriber counts by county to populate the
Rate Tier table.
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e Un-join the county data from the geo-code subscribers list.

e Create Compact Polygon using cleaned geo-coded layer or sub-selection of using — XtoolsPro —
ConvexHull-DetailedHull option. A sub-selection of geo-coded points will be used in areas where more
than one polygon will need to be created for one provider’s service area.

e  Evaluate output Hull carefully — looking for areas that should not be covered by hull polygon.

o Ifitis determined that an area or areas should not be represented in coverage area, manually
reshape hull polygon until coverage area is adequate.

o When not obvious and as a general rule, manually resolve compact polygon when the distance
between the subscriber points used to define the outer boundary of the compact polygon
exceeds 5 miles . When reshaping the hull polygon, snap to the outermost geo-coded points.
See figure 2 and 3 for an example.

FIGURE 2- Compact Hull: Manual Resolution Required
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2\ o 00/ /@ o’ ®
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| Compact Hull /

As a general rule if the distance between
the subscriber points used to define the outer
boundary of the compact hull exceeds 5 miles,

manually reshape hull.




FIGURE 3a- Compact Hull: Manual Resolution Required FIGURE 3b- Compact Hull: After Manual Resolution
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e To attribute the compact polygon - Perform a “Spatial Join” where your Target Feature Class is the

compact polygon and the Join Feature Class is your geo-coded point layer. Export compact hull with
joined attributes and name file appropriately.

e Append attributed compact polygon to BroadBand TT template Feature Class and if required manually
input any provider attribution that may not have carried over in the append process.

e Intersect compact polygon with county boundaries to create unique records by county and use the state-
county-fips field to populate “stcty_fips” field. Also use the county name field to populate the
“BBCov_Name” field.

o Exceptions is where a provider’s coverage is distributed throughout more than one area of any
given county where the “BBcov_Name” should be populated using an appropriate city or other

logical name based on geographical location.

e Export/Load into appropriate BB TT model Dataset.
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3.5.4.6 Census Blocks — List or Spreadsheet

In the event that the provider supplies census block data in a list or spreadsheet, please follow the steps below:

1) Ensure block polygons supplied by the provider are 2000 currency

2) If other currency, convert to 2000 currency before proceeding
a. Todo this, remove the trailing letter (a, b, etc.) from the block ID
b. You will now have two blocks that equate to one block in the 2000 block geometry
c. Delete duplicate block IDs, retaining the higher service tier in each case

3) Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells, colors,
borders, etc.

4) Import the spreadsheet into ArcMap.

5) Right-click on the 2000 census block feature class in the layer list in ArcMap and select Joins and
Relates>Join from the drop down menu. Join the census block list to the 2000 census blocks feature class
using the block ID and export joined records in a new feature class. The Join dialog box and process can be
seen above in the TIGER Street Segments — List, Spreadsheet, or GIS Data section.

6) Follow the steps in Census Blocks — GIS Data below.

3.5.4.7 Census Blocks — GIS Data

In the event that the provider supplies census block GIS data please follow the steps below:

1) Ensure that the blocks supplied by the provider are in the required data schema and are complete as far
as require attribution.

a. If not, manually enter the required attribution or contact the provider to fill gaps.

2) If census block geometry is distributed throughout more than one county then select Data Management
Tools>Generalization>Dissolve in ArcToolbox and dissolve based on County/Provider/TT/Speed Tier so
that unique records are created for each unique combination.

a. The dissolve dialog box can be seen above in the TIGER Street Segments — List, Spreadsheet, or
GIS Data section.
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Figure 1: Undissolved census block polygons

Dissolved Census Blocks

will all slivers and holes removed. YAMHILL COUNTY
Yamhill County
b\___ Provider A
TT10
Speed Tier 1

Polk County
Provider A
1710
X Speed Tier 1

| POLK COUNTY

Figure 2: Census block polygons dissolved by county

2) For each dissolved region use the Editing toolbar in ArcMap to remove unnecessary slivers and other
small holes.

3) In ArcToolbox, select Data Management Tools>General>Merge and merge the processed polygons
together into single layer.

4) The merged census blocks will need to have the subscriber’s “frn” field added and populated.

5) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the GIS
feature class either created above or supplied by the provider into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class

fii )
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b. Pressthe Add button, hit Next
c. Accept the defaults and hit Next
d. Do NOT attempt to map any fields, as seen below:

X

Simple Data Loader

For each target field, select the source field that should be loaded inta it.

Target Field Matching Source Figld =

[ProvName [string] <Nones =
_| DBAName [string] =None=
_| FRN [int] <None>
| GeogUnit [string] =MNonex
_| GeogUnitiD [string] =None=
| TraneTech [zhort int] <None>
| MaxAdvDown [ghort int] =MNonex
| MaxAdvUp [short int] <Nones
| ARPU [float] <None>

SWNomSpeed [float] <None= b

Reset

< Back | MNext > | Cancel

e. Press Next, then Next again, then Finish.
6) In ArcToolBox, go to Data Management Tools>General>Append
7) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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BX
-
Input Datasets

| Rl
C:\Warking'\Broadband'\ProviderData\Columbine\Columbine. gdb\service _area_bb... +
X

Target Dataset

| C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\bb_cov ﬂ
Schema Type {optional)

Field Map (optional)

Ey

| w

QK | Cancel Environments... | Show Help == |

8) Leave the Schema Type as TEST
9) Press OK.
10) In ArcMap, open up bb_cov for editing and manually input associated attribution, if necessary.

3.6 Metadata Transactions

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts staging
environment, the GIS-Analyst runs transactions to compare that f{GDB with the one stored on the Core server to
ensure metadata on all changes are recorded.

Below outlines the steps taken to run transactions on the updated Core database:

1. Openacommand line window and run generateTransactions.py
a. Usage: generateTransactions.py [Core fGDB] [Staging Environment fGDB]

b. Example of command line:

<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb

2. Below is an example of the output screen that will be displayed:
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we

Collecting Transactions

Calculating rec_id field for BBCov_W_BBE_FPOLY_TEMPLATE
value can not he B or less
Troubhle creating the progress meter

Calculating rec_id field for BBCov_18_CenturyLink

Merging change: X:~BDIA_BE_GDBE=-M5_BB_POLY_SRU_AREAS .gdb~AddPt
Calculating Tranzaction fields for AddPt

W :~BDIA_BB_GDB=~MS_BB_POLY_SRU_AREAS .gdb~AddPt.. .changesz is complete.

Your transaction FeatureClasses are in:
~samichigan~AllAccess~BDIA_BB_GDB=z_HIST-M5_BBE_POLY_SRU_AREAS_HIST.gdh

elapsed time = 2994_4 seconds

3. After process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb
a. The transactions scripts records changes at a feature level.
b. Below is a screen shot supporting the directory structure of the historical fGDB.




Bl ArcCatalog - ArcView - MABDIA_BE_GDEs CO_BB_POLY SRV_AREAS HIST.gdb

File Edit View Go Tools Window Help
o | gy K| 2

B QDO N2

Location: |M ABDIA_BB_GDBs_HISTNCO_BB_POLY_SRV_AREAS_HIST gdb

Stylesheet:  |FGDC ESRI
= § CO_BE_POLY_SRV_AREAS_HIST.gdb o

[E] AddPt

-.[El BECov_0_POLY_TEMPLATE

BBCov_10_Agate

BBCov_10_BigSandy

BBCov_10_Bijou o
BBCov_10_Blanca
BBCov_10_CenturyLink

..[Hl BBCov_10_Columbine

..[El BBCov_10_Covad
BBCov_10_DuboisTelExchange
-[El BBCov_10_ESRTA
BBCov_10_Farmers

-.[El BBCov_10_Glenwood

.[El BBCov_10_HaxtunTele
BBCov_10_Internet_CO

/5l BBCov_10_JED

_.[El BBCov_10_MNunn |
..l BBCov_10_PineDrive

BBCov_10_PlainsCoop

.[El BBCov_10_Qwest

..[El BBCov_10_Rico

BBCov_10_Rye

X

m

5|
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Contents l Preview ] Metadata ]

MName

Type

Modified

BECov_10_Munn

[ AddPt

BECov 80_ATT
BBCov_80_Sprint
BBCov_10_DuboisTelExchange
BBCov_70_Mohilelnet
BBECov_10_Sunflower
BECov_10_Qwest
BECov_30_XOComm
BBECov 41_Comcast
BECov_20_XOComm
BBCov_50_Rye
BECov_71_SECOM
BECov_50_Glenwood
BECov_10_Rico
BECov_71_Sanlsabel
BBCov_80_Verizon
BBCov_10_Wiggins
BBCov_10_PlainsCoop
BBCov_70_Bijou
BECov_30_Covad

BECov_70_SouthPark
[Flpnra: 10 HavhiinTele

File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class

File Geodatabase Feature Class
Eile Gandatahace Eastiiras Clace

8/30/2010 8:57:53 AM
11/30/2010 4:49:46 PM
11/30/2010 4:37:35 PM

8/30/2010 8:37:43 AM
11/30/2010 4:35:50 PM
11/30/2010 4:36:30 PM
9/10/2010 11:07:22 AM
8/30/2010 8:42:13 AM
2NN AT ARA

c. Attribution associated with each added/removed/changed features is tracked, including the

following additional columns appended to the end of each:
i. Commit_by

1. Records the GIS-Analyst that committed the changes to the historical fGDB.

ii. Commit_date

1. Records the date and time stamp that the changes were committed.

iii. Trans_type
1. This field reflects the type of change recorded.

2. Categorized by:

a. Adds/Change/Deletes

iv. New_values

1. Records the new values when a change was completed on a feature. Example:

Name or speed change
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d. MD_Process is also transferred from the edited fGDB to the historical f{GDB, which states the
actions completed by the GIS-Analyst.

| ArcCatalog - ArcView
File Edit View Go Toels Windew Help
EL LR tlelasonwjaaveean|o®]
Location:  [N-\BDIA_BB_GDBs_HIST\CO_BB_POLY_SRV_AREAS_HIST gobAddPt |
Styleshest:  [FGOC £5R) S R TR T |
x| Conterts Preview | Metadata |
9 CO_BE_POLY_SRV_AREAS_HIST.gdb -
B Addpt md_address md_process commit_by commit_date trans_type new_values
B8Cav.0_POLY TEMPLATE =dd8aseBBHctadslaF alis gy 1.2, added Jab 14 Hle ponts back nlo do per critgen Cmabey 872472010 4435 | change 57671
addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5768]
BECav 10 Agate ad0BaseBEMetadataFields py_v1 2, added Jab Mid Mie points back into db per critigen cmabey BI2412010 4435 | change 5769]
BBCav_10_BigSandy addBas BB HetadataFields.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 82472010 4435 | change 5770]
-] BBCov_10_Bijou - addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey 802412010 4:43:5 | change 5771]
-1l BBCov_10_Blanca addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 57721
-] BBCov 10_CenturyLink addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey 8242010 4435 | change 577
-[E] BBCov_10_Columbine addBaseBBMetadataF ields.py_v1.2, added Jab Mid Mie points back into db per critigen cmabey @/2412010 4435 | change 5774]
81| BBCov 10 Coved addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 577"
Bl 88Cov 10 DuboisTelExchange addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5776]
- addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 5777)
~&l BBCov 10 ESRTA 3 addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 577
~&| BBCov_10_Farmers addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 22472010 4435 | change 5779]
-] BBCov_10_Glenwood addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey 802412010 4:43:5 | change 5780]
BECov_10_HaxtunTele addBassBBMeladalaFields. py_v1.2, added Jab Mid Mis points back into db per criigen cmabey 872472010 4435 | change 5781]
BEBCov_10_Internet_CO addBaseBEMetadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey BI2412010 4:43:5 | change 5782]
BECov_10_JED addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 5783]
BBCov 10 Nunn addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5784]
BBCov 10 PineDrive addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 5785]
o addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 57861
BBCov 10 PlainsCoop addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per critigen cmabey 22472010 4:435 | change 5787]
BBCov 10 Qwest a00BaseBBMetadataFields.py_v1.2, added Jab Wid Mie points back into b per criigen cmabey B2412010 £.43:5 | change 5788]
BECov 10 Rico addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 82472010 4:43:5 | change 5789]
BBCov 10 Rye addBassBBMeladataFields.py_v1.2, added Jab Wid Mis points back into db per criigen cmabey 872472010 4435 | change 5790]
BECov_10_SandT addBas BB HetadataF elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 5791]
BECov_10_Sunflower addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5792]
BECov.10_TDS addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 5793]
B8Cov_10, Wiggins addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change s784]
- - addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5795]
BBCav 20 Covad ad0BaseBEMetadataFields py_v1 2, added Jab Mid Mie points back into db per critigen cmabey BI2412010 4435 | change 5796]
BBCav_20_Intemet CO addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 82472010 4435 | change 5797)
BBCov_20_NewEdge addBaseBBletadataFields py_v12, added Jab Mid Mie points back into db per riigen cmabey 802412010 4435 | change 5798]
BEBCov_20_X0Cemm addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey @/2412010 4435 | change 5799]
BECov_30_Covad addBas BB HetadataFields.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change [5800)
BECov_30_Intemet_CO addBaseBEMetadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey @/2412010 4435 | change [5801]
BBCov_30_NewEdge addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 15802)
B8Cow 30 TWTelecom addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 2803
- addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 15802]
BBCav 30 XOComm addBaseBEetadataFields. py_v1.2, added Jab 1id Mie points back info db per critigen cmabey 872472010 4435 | change 158051
ssi ““7:?; ommComm addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 22472010 4435 | change 5306]
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BBCov_41_Bresnan J o,
BBCov_41_Comcast Record: ﬂ j 1 j ﬂ Show: [[AI selected Records (of 29424) Cptions -
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3.7 Data Processing

3.7.1 Data Processing Overview

The following items outline the actions required to process the service provider data further to meet the NTIA
requirements.

e  Weighted Nominal Speed

e Middle Mile

e Broadband Coverage Template

3.7.2 Weighted Nominal Speed

The weighted nominal speed is populated one of the following two ways:
3.7.2.1 Subscriber Data Supplied by Provider

Where the data provider supplies subscriber speed information , the following formula from the NOFA is used:
(speed tier-1 in kbps x no. of tier-1 subscribers) + (speed tier-2 in kbps x no. of tier-2 subscribers) + (etc.)

Total average monthly subscribers

Data is initially broken up in the following order:
1) Stcty_fips
2) Transmission technology type
3) Subscriber tiers

3.7.2.2 Value Supplied by Provider

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be populated
instead of using the NOFA formula.

These obtained or calculated values are used to update the service overview layer. This can be done manually or
by creating a table with the provider’s FRN and average weighted speed and joining it to the service overview table
in ArcMap. To Join, right-click on the layer to join to and select Joins and Relates>Join... from the dropdown menu.
Then navigate to the table to join to and select the join fields from the drop down list. Then open up the source
table (the table in ArcMap) and right-click on the header of the Average Weighted Speed field and select Calculate
Field from the drop down menu. Use the value of the average weighted speed from the joined table.

3.7.3 Middle Mile

Middle mile information is generally provided in spreadsheet or text file format. The process is to take what is
supplied by the provider and translate it into the required data schema.
1) If the data is supplied with address information, follow the process outlined above in Subscriber Location
— Address Data.
2) If the data is supplied with associated XY coordinates, follow the process outlined above in Subscriber
Location — XY Data.
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3) Once the datais in GIS format, use the Append (Data Management Tools>General>Append) command in
ArcToolbox to append the data to the overall middle mile dataset.

4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the source to the
target dataset.

3.7.4 Broadband Coverage Template

Below is the description of the fields within the BB_Cov layer, which is the interim data set that is used to create
the final product deliverable.

Name Alias Description

objectid OBJECTID Internal Object ID

shape SHAPE Internal Shape storage

prov_id PROVIDER_ID Unique numeric identifier for each provider

prov_name PROVIDER_NAME Unigue name for each provider

dba_name DOING_BUSINESS_AS An alternative "Doing-Business-As" name for the provider

frn :CC_REGISTRATlON_NUMBE Provider FCC Registration Number

bbcov_name BBCOV_NAME BroadMap Broadband Coverage name

trans_ code TRANSMISSION_CODE Ur?ique code for the transmission technology type described by
this layer

trans_name TRANSMISSION_NAME Name for the transmissions technology type

trans_desc TRANSMISSION_DESC Description for the transmissions technology type

spect_code SPECTRUM_CODE Unique code for the spectrum [WIRELESS ONLY]

spect_name SPECTRUM_NAME Name for the spectrum [WIRELESS ONLY]

spect_desc SPECTRUM_DESC Description for the spectrum [WIRELESS ONLY]

Maximum advertised downstream speed available within given
mad_dwn_t MAX_AD _DOWN_TIER .
-7 - T - area (speed tier)

Maximum advertised upstream speed available within given
mad_up_t MAX_AD_UP_TIER ,
area (speed tier)

Typical downstream speed available within given area (speed
typ_dwn_t TYPICAL_DOWN_TIER tien)
ier

typ_up_t TYPICAL_UP_TIER Typical upstream speed available within given area (speed tier)

Maximum advertised downstream speed available within given
mad_dwn_k | MAX_AD_DOWN_KBPS
area (kbps)

Maximum advertised upstream speed available within given
mad_up_k MAX_AD_UP_KBPS
area (kbps)
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Name Alias ‘ Description
typ_dwn_k TYPICAL_DOWN_KBPS Typical downstream speed available within given area (kbps)
typ_up_k TYPICAL_UP_KBPS Typical upstream speed available within given area (kbps)
Total average monthly subscribers for this provider for this
subs SUBSCRIBERS .
technology for this coverage polygon
Metadata: Comma separated list of source id's from which the
md_geom MD_GEOMETRY
polygon extent was produced
. Metadata: Comma separated list of source id's used in
md_exists MD_EXISTS . . . .
- - understanding and editing the provider data for this polygon
Metadata: Name of the editor who last edited this feature at
md_who MD_WHO L
- - the time in md_when
md_when MD_WHEN Metadata: Date/timethat this feature was last edited
Metadata: Comma separated list of processed used to create
md_process MD_PROCESS . .
and/or modify this layer
stcty_fips STATE_COUNTY_FIPS State/County FIPS code
Compound Key formed from
rec_id RECORD_ID STCTY_FIPS+"|"+Provider_ID+"|"+Trans_Code+"|"+BBCov_Nam
e
st_area ST_AREA(SHAPE) Area in square decimal degrees
st_length ST_LENGTH(SHAPE) Length in decimal degrees

Provider_Typ
e

Type of Provider

Has Subtype (1:Broadband provider as described in the
NOFA,2:Reseller,3:Unknown), default value =1 (New 04/11
Model)

3.7.5 Verification and Validation

3.7.5.1 Provider Validation — Provider Portal/PDF Map Review

Following the collection and aggregation of provider data, the aggregated data is validated by the provider to

ensure it is an accurate representation of their coverage area and supporting broadband information.

This validation is completed through the Provider Portal web application, which is a secure interactive map that

displays the provider’s coverage areas and allows the provider to validate, submit feedback or request changes. If

changes are requested, then the features on the portal are updated and an automatic request is sent to the

provider to complete the validation process.

Providers that did not use the Provider Portal are asked to validate a PDF map displaying their coverage area(s).

this is accomplished via e-mail notification.
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3.7.5.2 Provider Verification — 3" Party Source Review

After the provider has validated its coverage areas, a 3™ party source comparison and analysis is performed.

Where anomalies or discrepancies are identified, a ‘SCAN’ point is dropped and descriptive comments are applied

to be reviewed later with the provider.

During the provider review, the map is displayed along with the ‘SCAN’ points and potential refinement is

completed based on input from the Provider.

3" Party Sources Utilized

3" Party Source Name | Source Type

Verification Type

InfoUSA Consumer and Business Community Anchor Institutions
Listings Can also be used for demographic information supporting
the State websites
Pitney Bowes (PBBI) Exchange Info Plus Exchange datasets are used to verify the following

(Central Office Locations)

Transmission Technologies (TT):

Asymmetric xDSL (10), Symmetric xDSL (20), Other Copper
Wireline (30), and Optical Carrier/Fiber to the End User
(50).

Media Prints Cable Boundaries Used to verify the following TT:
Cable Modem—DOCSIS 3.0 (40) and Cable Modem—Other
(41)
American Roamer Wireless Coverage Used to verify the following TT:
Patterns (EVDO, GPRS, Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
WISP, HSPA) Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80)
ComSearch Wireless Spectrum Used to verify the following TT:

Holdings and Tower Data

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80)
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3.7.5.3 Assigning Confidence Values

All findings and results from the above-mentioned validation and verification activities, plus internal peer quality
reviews are captured and tracked in a Validation table and form the basis of the confidence value assigned for
each provider and then each technology.

The confidence values are as follows:
0 = Coverage area has not been reviewed
10 = Extremely Low. Single Source QC.
20 =Very Low. Needs Additional Validation\Verification
30 =Low. Even with Validation\Verification, Coverage is still suspect.
40 = Acceptable, confirm with State prior to shipment.
50 = Meets requirements to be included in shipment.
60 = Moderate. Meets NTIA/State’s standards, representative of Technology Type (TT)
70 =High. Accurate representation of coverage based upon TT.
80 =Very High. Multiple validation\verification with most 3™ party sources
90 = Extremely High. Multiple validation\verification sources
100 = Perfect. Multiple validation\verification sources, with complete alignment with sources and ground
truth verification activities

This Validation table is maintained as updates or changes occur for each provider, down to technology type, with
the overall goal to improve the confidence values and overall map representation.

Example of the Validation table:

Corterts Provew | Metaduta |

ojecrio: | acov [ COMMDUNCE_COOE | PROVIDER 1D | PRER_GC | PROVIOUR_GE | THRD_PARTY_ VIRINCATION | Twikb_ PARTY.10 | 4
Twcos w 7T TR 0 %7

0710 v e ndsres Areas

%0 | v ot ex 8 nge datasat

) N N N N N O

P T Receth (o 122 ootors

Povew: [T 3
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3.7.6 Community Anchor Institution (CAl) Data

3.7.6.1 Data Collection

The CAl data was initially collected from the State to create the baseline inventory. All location information and
broadband coverage data supplied was also ingested into the data deliverable.

Additional collection of CAl information was done via data mining and/or webscraping to build out the inventory
further. For example: Collection of additional CAls and location information.

The state-agency-provided CAl inventory was comprehensive but the challenge is collecting broadband related
data; service provider(s), technology and speed data for each CAl. Availability of the CAl portal has not significantly
increase submission of this data. Additional promotion to CAls to utilize the CAl portal will be needed to increase
this data for subsequent deliverables.

3.7.6.2 Institution Data

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet format. The
general process for incorporating this data is below:
1) If the datais provided in Excel or some similar format:

a. Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.
b. Standardize the address format as defined in the staging CAl database

c. Ifthe spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY Data
tool in ArcMap to create a spatial data layer.

d. [Ifthere are only addresses, then follow the geocoding steps outlined above to create spatial data
points for each of the institutions.

i. Institutions that do not geocode based on the TIGER 2009 data set will have to be
manually located using Google Maps, Google Earth, or some other information source.

2) If the CAl source data is in GIS format, add the Latitude and Longitude fields and use the Calculate
Geometry tool to populate them, using the WGS 84 coordinate system.

3) Using ArcCatalog, load the new data into the staging CAl database.

4) This database is ready for the makeDeliverable.py script to process the information into the final state
and NTIA deliverables.
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3.7.6.3 Community Anchor Institution (CAl) Portal Updates

A web application has been released to allow for further data collection and validation of anchor institution
location information, broadband coverage, and speed test data.

Information collected from the CAl Portal is then ingested into the overall inventory and will later be compared
against the provider coverage areas mapped for any potential discrepancies.
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3.8 Product Extract
3.8.1 Python Scripts

The following sections make use of Python scripts. In general, to use a Python scrip, you must have Python
installed on your computer. To download the latest version of Python, go to http://www.python.org/download/
and download the latest stable version. As of August 2010, this was version 2.7. Once this is installed, the general
way to run a script is to type the following at a command prompt: C:\Python27\python.exe C:\<location of script>.

Many of the scripts provided have environment variables that must be set before they can be run.

The python code for BroadMap’s product extract has been incorporated into a Hudson Cl System, which is detailed
in the Process Operation and Monitoring section of this document. This was a process improvement activity so all
processes can be monitored, controlled and contain historical tracking on each process.

3.8.2 Product Extract Process

Note: specific Python scripts are called out in red font in the sections below.
The MapConnect product extract process, makeDeliverable.py, uses the BB_Cov and BROADMAP_POINTS interim
data sets to create the following layers according to the current specifications:
e BB_Service_Road_Segment
- This layer contains all broadband services associated with specific street segments for census 2000
blocks larger in area than two square miles
e BB_ServiceCensusBlock
- Contains all broadband services associated with census blocks of no greater than two square miles.
e  BB_Service_Wireless
- This layer contains all wireless services not associated with specific addresses.
e BB_ServiceOverview
- This layer contains subscriber-weighted nominal speed for each provider's service area at a county
level and is meant to act as a summarized view.
e BB_ConnectionPoint_MiddleMile
- This layer contains middle-mile and backbone interconnection points
e BB_Service_CAlnstitutions
- Broadband Service at Community Anchor Institutions (CAl)
= Community Anchor Institutions consist of schools, libraries, medical and healthcare providers,
public safety entities, community colleges and other institutions of higher education, and other
community support organizations and entities.

Due to a NTIA model change for the October 2010 data deliverable, an addition to this code was created to
support both models in the case a comparison is later desired or a request is made to revert back to the original
model. This script name is bdia2ntia.py and creates the following layers in addition to the layers mentioned above,
rolled up to NATL_Broadband_Map.
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BB_ConnectionPoint_LastMile

- This layer contains last mile infrastructure points, which is only populated if data cannot be provided
at a more granular level.

BB_Service_Address

- Represents broadband availability for service address points. Address Point availability refers to
those individual addresses at which each facilities-based provider of broadband service can provide
broadband services of minimal characteristics within 7 - 10 business days.

State_Boundary

- State boundary supporting topological validation of point feature classes.

NATL_Broadband_Topology

- Supports basic topology quality checking. Example: No CAl’s or Middle Mile points outside of the
state boundary

The following process flow provides a view of how the Core fGDB is extrapolated to the NTIA final deliverable via
the makeDeliverable.py script. Following that, the bdia2ntia.py script is run, which limits what’s placed in the final
layers based on the NTIA modeling standards.

The product scripts and supporting extract were originally created separately per request, in case data model
comparisons were to be completed.

3.8.3 Product Statistics

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py) extracts
the following information supporting that product deliverable.

Provider Statistics

Collects all provider information, listing by Provider Name

Provides output of FRN

Counts the number of features supported within the following layers:

= Census Block

= Street Segment

=  Max Upstream

= Wireless Services

= Infrastructure Points

These updates were made to support the Data Package required to accompany every NTIA product
deliverable.

Community Anchor Institution (CAl) Statistics

Breaks CAl down to the 8 categories
= 1: School: K through 12
= 2: Library
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=  3: Medical/Healthcare
4: Public Safety
= 5: University/College
6: Other Government
7: Other Community non-government
= None: Unknown Category
e In cases where this occurs, further investigation is completed prior to product shipment to
ensure all CAl's are categorized accurately
- Reports out the following counts
=  Total CAls within that category
= Total CAls that contain partial BB coverage
e  Contains any of the following information for given CAl:
¢ BB Subscriber, Transmission Technology, Speed Down Speed Up
= Total CAls that contain full BB coverage
e Contains all of the above-mentioned BB information for given CAI.

The output of this script is two CSV files: AnchorlInstitutions.csv and Providers.csv. These files can then be
inspected to ensure that there are the expected number of CAls and providers for every release.

3.9 Quality Assurance

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase, and on
the final product. For scheduled product releases, a test product extract and subsequent manual and algorithmic
QC run is completed along with a release review. The product specifications, project status reports, previous
product release notes are used as references throughout this review.

The following parameters are tested using the methodology listed below each:

e Product Deliverable Format
- Correct names and format of data deliverables
=  BDIA_QC_SUITES (please see below for details)
- Correct Projections/Datum
=  Manual interaction with product
- Metadata Present and Correct
=  Manual interaction with product
e Table Structure
- Allrequired tables included
= BDIA_QC_SUITES
- Extraneous tables identified
= BDIA_QC_SUITES
e  Field Structure
- Allfields included
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* BDIA_QC_SUITES
- Extraneous fields identified
» BDIA_QC_SUITES
- Correct field names, types and widths
» BDIA_QC_SUITES
Field Domains
- Values in all tables are constrained to the specified values specified
= This action is accomplished via BDIA_QC_SUITES and manual review of the product
=  This tends to identify project completeness issues as fields with a null value are identified.
Geometric Representation
- Identify if all layers have the correct geometric representation
=  Manual review of the BB_ServiceOverview layer
=  Dependent on NTIA and client requirements
Geographic Extent
- Product includes the necessary Geography associated with Product?
=  Manual Review - ArcGIS
- Isthere extraneous geography included in Product?
=  Manual Review - ArcGIS
Completeness
- Products contain the expected amount of data?
=  Manual review of product stats relative to weekly State reports and defined expectations.
Accuracy
- Product meets the stated accuracy requirements for the deliverable?
=  Sampling procedure to manually review source material to resulting product
=  Provider Validation
=  Verification using 3" Party Data
= Verification against reality, where applicable
Data Regression
- Any unexplainable data loss or change?
= This action is accomplished by comparing results within product statistics script
(BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product
Confidentiality
- Any unauthorized confidential information included in the delivery?
=  Review of NDAs and delivery expectations
Prior Issues Resolved
- Have expected internal issues been resolved?
=  Manual review of data against previous product release notes
- Have agreed upon customer issues been resolved?
=  Manual review of data against previous product release notes, status report and client feedback
Delivery Medium
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- Has the product medium been verified?

= Manual review
- Allfiles present

=  Manual review of SFTP site to ensure all files are copied correctly, including file/directory size
- Correct location

=  Manual review — confirmation of SFTP link, username and password

3.9.1 QC Suite

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These scripts are all
run in concert and are called from the test_runner script and the test_BDIAProductGDB script.

3.9.1.1 Configuration
These scripts establish the configuration for the test_ BDIAProductGDB script which is the core of the QC Suite.

- update_test_config

- active_config

- config_PROCESS01_automated
- config_PROCESS01_manual

- set_active_config

3.9.1.2 Libraries
These scripts provide additional functionality that is called from with the test_ BDIAProductGDB script.

- bb_unittest_fixture
- bbcov_structure

- BC_XmlWriter

- file_folder

- search_and_replace
- unittst_fixture

- validate_BB_DB

- validate_BB_GDB

- xmlrunner_gui

3.9.1.3 QC Suite
This is the core script for performing automated QA/QC on the interim and final data deliverables.
- test_BDIAProductGDB

3.9.1.4 Other

These scripts perform other functions detailed below:
- test_runner —this is the main script that runs all the other QC scripts and imports all the necessary scripts
and libraries
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- which_build —this determines the current build and passes information to the configuration scripts

3.10 Process Operation and Monitoring

Product Extract, makeDeliverable.py and bdia2ntia.py, is run within BroadMap using a platform called Hudson that
has been enhanced to support BDIA product extraction, process monitoring, as well as product validation. The
same platform can be planned for implementation for the State, if desired.

Below are examples of the product create, product validation, product statistics and monitoring processes which

are managed within the BroadMap Hudson CI-System. All of the above-mentioned python scripts, with the
exception of metadata transactions script, are run via this system.

3.10.1 BDIA Product Create

Below is an example of the main page where the type of product build can be selected.

Hudson

Hudson

% New Job
f—— BROADVMAP
& peovle )b

Build History ipti
> Build Histo (edit description

Build Queue Al | BDIA Product Create | BDIA Product Validation | BDIA_Sourcing | Core Database Validation  FCC Product Validation | MCE Product Validation | Map Connect Enterprise | Mesh Creation | Postal Product Create | Postal Product Prep | WebPortalPrep | + 1
No builds in the queue. s w Job | Last Success Last Failure Last Duration
Build Executor Status Q BDIA Build 12 hr (2197) WA 125ec [}
i Master
1|idle s BDIA Product Validation AS 2 mo 10 days (2157) wa &min 10 sec %3}
2 Bu\\dmﬁ NVT MeshMakerBlocks Stream2 #2 =] o
2 . =5
3| Building Postal GeocodePrep Streams £2 a 4 BDIA Product Validation CNMI 3 mo 22 days (251) 3 mo 23 days (£80) 2 min 16 sec [%3)
4|ldle [ BDIA Product Validation €O 13 days (2271) WA 37 min [%3)]
5 ldle o
Suilding Doctal " 2 =\ =N

Selecting based on the type of process that will be initiated.

Hudson » BDIA Product Create = BDIA ProductCreate

4 Back to Dashboard

Project BDIA_ProductCreate

OR on Alaska

O, status

"> Changes
Warkspace
[« Build How (B Workspace

() Delste Project Last Successful Artifacts

4 Configure @  bdia2ntia.log =

® makeDeliverable.log &

3, Build History (trend) ® robocopy.log &
@ #123 Decd, 201012:30:00PM 186KE o Hudson > BDIA Product Create > BDIA ProductCreate
Running for provider portal update | = Recent Changes & Back o Dashboare
@ #122 Dec9.20109:53:37 AM 179KB — O, swus Project BDIA_ ProductCreate
Running for provider portal update - Test will rerun A
when Midco is complete Permalinks = Changes his build requires paramePs
@ #121 Dec7, 2010 6:09:02 PM 46KB 1 vorianace State oR +
SD build for portal test  Last build (#123), 4 days 23 hr ago e State or Terrtory to Process
a1 - #® Last stable build (£123), 4 days 23 hr ago Build Now
#119 Dec1,201013:41;51 AM <
== 1asee ® Last successful build (123), 4 days 23 hr aqo
CO Monthly Deliverable w/ Crit Feedback - Round 2 ® Last failed build (£121). 6 davs 18 hr ago @ Delete Protect
@ #118 Now 30, 2010 4:58:45 PM SO0KB ® Las build (#121), 6 davs 18 hr ago #, confiaure

CO Monthly Deliverable w/ Crit Feedback




The Console Output can be reviewed to see the progress of product create. Following the completion of each
product creation process, an e-mail notification is automatically sent to the team.

Hudson

Hudzan > BOIA Product Crests > BOIA ProductCreste » £117

QCcnsnle Output

me. This can rasult in inconsistent chack oub BaRAvSse
Fre—

DTA_BB_GDE1CO_BB_DOLY_SHV_AREAS.qdb "D:\udaco\jabs\BDIA_Prodsctisaste\nazkapace™\CO_BB_DOLY_SHV_AREAS.gdb /MIR /LOG: sobocopy.1og
opy. 109
cho RUBOCOFY RETUAN CODE 3 ***FATAL ERROR'** & goso ERRCR
oo BOIOCOPY RETURN COOE 3 FAIL MISM XTAA COPY & gots ERAGR
\che ROS0COPY RETURN CODE 3 FAIL MISM XTHA & goms ERRER
cho RUBOCOPY RETUAN CODE 3 FAIL MISM COPY & goko ERROR
2 echo RB0COPY RETURN COOE 3 FAIL MISM & govo SRROR
cho BOBOCOPY RETURN CODE 3 FAIL XTRA COBY & goso ERROR
e ROBOCOPY RETUMN CODE 3 FAIL XTRA

cho R0BOCOPY RETURN CODE 3 TAIL CORY &

cho ROBOCOFY RETURN CODE 3 FAIL & guto ZRROR

All processes run via the BroadMap Hudson CI-System are stored for historical reporting. Each process can be
reviewed, including the Console Output and Build Artifacts from that run.

Hudson

Hudson » BDIA Product Create » BDIA ProductCreate » £161

4 Backto Project
Q status Q Build #161 (Mar 28, 2011 9:44:40 PM)

= Changes

OR Pre-Release Build
B console output

Parameters

o Parameters Build Artfacts
Tag this build @ b
o ms ledog
[Z] oewnsiream buid view  robocopy loq &=
4 Previous Build —
[ Revision: 3099
B Nt Build =

No changes.
= <

Started by user anonvmous

& search ©)

ENABLE AUTO REFRECH]

Delete this buid

Started 1 day 1 hr ago
Took 3 hr 31 min on Alsska

(edit description

3.10.2 Product Validation and Statistics

Once the product creation process is complete, Product Validation and Statistics are then initiated. These support
the BDIA_ReleaseNotesStats.py script and the BDIA_QC_SUITES scripts detailed above.

All statistics and reports are stored for historical review with the capability to place violation criticality on each
quality control check allowing the identification of errors due to project status/completeness verses project
correctness. Example: Typical Speeds populated.




Hudson

Hudson » BDIA Product Validation » BDIA Product Validation CO

4 Backto Dashboard
O, status
"> Changes

@ worksosce

) suidnow

E Il M
© Dslete project & e
4 Confiauce G 1e00m0 /
B oo H f
S 100000
S 2 |
Build Hist. trend 5
uild History (rend)| 5 o0
P
Final QC on SOW monthly CO product - & & & 5 £ 5 5 5 - & &5 7 £ 5 = &5 & =
#270 Nov 18, 2010 9:56:35 AM 55MB = T = = 5 s @ w ® = B 4 O: 3
#2609 Nov 18, 2010 8:45:08 AM 79K8 §— < ;: £ s £ 3 £ 2 4 £ £ 3 5 2 8 & o
& 2 B 5 8 B & 8 8 B B 2 B r BE R &
#2668 Nov 18, 2010 9:22:49 AM 79KB & @ ¢ & & ¢ € ¢ ¢ ¢ 8 ¢ ¢ € g § w
) #267  MNov 18, 2010 5:08:05 AM 77K8 D
QC on SOW monthly CO product [<+-BB_Senice_CAnstitutions Error — BB_Service_Wireles Error -+ BB_Senice_CensusBlock Emor
#266  Sep 29, 2010 11:12:00 PM 4
< Bane |4-BB_Senice_Road_Segment Error 4-B8_Senvice_Oveniew Error
#265  Sep 26,2010 11:17:56 BM S0k
o validation build Latest Stats Regression: Link
#264  Sep 24, 2010 12:22:28 PM 78KE Latest Provider Regression: Link
#263  Aug 31,2010 1:29:41 P “ans Latest Error Regression: Link
Aug 31, 2010 1:17:05 FM sic
#262  AuQ31.20101:17:05 M 65K SFedit description
) #261  Aug 31,2010 12:22:02 PM 102M8
_®pisk Usage: Workspace 238M8, Builds 1GB
#260  Aug 30, 2010 8:25:39 AM 110MB =
By workspace
#259  Aug 27,2010 1:33:49 AW 110M8 Test Result Trend
#258  Aug 24, 2010 5:00:41 AM 108M8 Lost Suceessfyl Artifacts
#257  Aug 23, 2010 5:00:41 AM 108MB @ * EDIA STRUCTURE QC.log &
* SB OC OUTPUT.7z &
) #256  Aug 22, 2010 5:00:41 AM 108MB & SBDD TRANSFER counts.cov &8 =
#255 Aug 21, 2010 5:00:41 AM 108MB ® SBDD TRANSFER counts diff-htm| 4= 2
* SBOD TRANSFERAnchorInstitutions.csv &=
00 SBOD TRANSFERAnchorlnstitutions.csv
F25¢ Aua20. 2010 :00:41 A0 Hoane ® 5BDD TRANSFERAnchor] Giff.htrml 8-
#253  Aug 19, 2010 5:00:41 AM 108M8 ® SEDD TRANSFERProviders.csv &-
| #252  Auai8. 2010 5:00:41 AW . * SBDD TRANSFERProviders diff.ntml &
@ #151  1ul9, 20101:47:28 PM 41k8 o,
) for oll F) for failures |=# Recent Changes
et
—

Project BDIA_Product_Validation_CO
This job checks db integrity on file GeoDatabase.
Record Error Monitor
250000 [

ENABLE AUTO REFRESH

Similar to the Product Create process, all results from the process are maintained:

‘Hudson » BOIA Proguct validation » BDIA Product Validation CO » 5270

4 Back o Project

Paramsiscs

Beaul

W fisat Buid

Build #270 (Nov 18, 2010 9:56:35 AM)

Mo changes,

Started by user anonymaus

Test Resul {2 failures / +1)
Dlassannest,sitss5 B01AProdUCtGDBE o rSUmMmary ADIAP UG OB o SummaryClazs.A01A STRUCTURE G SUMMARY

ENABLE 410 REFRESH
Kees e s oraver |
[

Started 26 days ago

Jroc casriptin 10K L2080 o mastar

Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA data model

or project completion statements. Any errors of concern are communicated ahead of product delivery and

included within the product release notes.

Further detail on the Hudson CI System environment can be found by navigating to the following link:
http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson
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Hudson = BDIA Product Validation CO

4 Back to Dashboard Project name BDIA_Product_Validation_CO
O status Description <pThis job checks db integrity on file GeoDatabass. </p> ®
- <ima src=http://vermont:8080/job/BDIA_Product_Validation_CO/p
"> Chanaes <p>Latest Stats Reg g : DIA_Product_Validation_CO/lastSuccessfulBuild/artifact/SEDD_TRANSFER_counts_diff.ntml">Link</as <p>

<p>Latest Provider Reg i <a DIA_Product_Vadation_CO DD_TRA! diff.htm">Link o
@ workspace sErLates rar haa . <a hre DIA_Product_Validation_CO/lastSuccessfulBuld/artifact/CO_errar_summary_dift.htmi

> Link</a><p>
) suid now <poLatest CAT Reg <a href="http: DIA_Product_Validation_CO/lastSuccessfulBuild/artifsct/SEDD_TRANSFERAnchornsttutions_diff-himi">Link</a><p>
@ Delete Project —

Discard Old Builds L]

& Configure
. Days to keep builds

i@ Plots

° ifnot empty, build records are only kept up to this number of days

& Build History (trend)|  Max # of builds to keep 2o

£280  Dec 22, 2010 9:47:05 Al if ot empty, only up to this number of build records are kept

£279  Dec21.201011:41:46 AM

#272  Dec17,20108:41:12 PM This build is parameterized
CO SOW deliverable validation
2271 Dec 1, 2010 8:16:58 AM
Final QC on SOW monthly CO product
#270 Nov 18, 2010 9:56:35 AM

String Parameter

Name TestMethoderefix

Default Value Bp1A_STRUCTURE
£269  Nov 18, 2010 9:49:09 AM

L)

#268  Nov 18, 2010 5:20:45 AM Deseription

2267 Nov 18, 2010 9:08:05 AM

QC on SOW monthly CO product
#266  Sep 25,2010 11:12:09 PM
#265 Sep 26, 2010 11:17:56 PM

€O validation build
#264  Sep 24,2010 12:22:28 PM

String Parameter

#263  Aug 31, 2010 1:79:41 PM
Name GDBLocation
#262  Aug 31,2010 1:17:05PM

#261  Aug 31, 2010 12:22:02 M Default Value //alaska/ReleaseCandidates/CO_20101117-1947

2260  Aug 30, 2010 8:25:30 AM

Description  parent path for the release candidate GRE

3.11 Product Extract Data Delivery

Product delivery for MapConnect Broadband is handled two ways, depending on client requirements:
1) State Submittal
a) Data is submitted via SFTP site
b) Product Release Notes and QC Test Report accompanies the delivery

2) NTIA Submittal

a) Directions for using the NTIA State Broadband Data file submission tool
b) Go to the following WWW web site: https://esupport.fcc.gov/statedata
c) Enter your username and password as provided to you from the NTIA program administrator.

FCC SUPPORT CENTER

Broadband State Data Management Tool

Broadband State Data Management Tool

Login
Username: * =

d) Clickin Upload afile field
e) Browse to local file for submission using the ‘Browse’ button. Select file then select ATTACH FILE.

> 2
T
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FCC SUPPORT CENTER

Broadband State Data Management Tool Alaska (jgeorge@denali.gov) Logout

Upload File| | View Files

UPLOAD NEW FILE

* denotes required field

Upload File

Upload File® —
? C:\Users\20100323142745_offer20100323.paf (S| ATTACH FILE

f) Logout/ Receipt using the Logout button in the Top Right of the screen
g) A receipt of submission is emailed to username e-mail address




